aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-date2
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
commitcd1d50eb08fefd091401ac45d81c225ac24920fc (patch)
treef5195afcb927cef5e3ed6aec9dd6e655c101af1e /devel/ruby-date2
parentc8b2a40e7936d06271e36a2b20c453a478fe308e (diff)
downloadports-cd1d50eb08fefd091401ac45d81c225ac24920fc.tar.gz
ports-cd1d50eb08fefd091401ac45d81c225ac24920fc.zip
Notes
Diffstat (limited to 'devel/ruby-date2')
-rw-r--r--devel/ruby-date2/Makefile56
-rw-r--r--devel/ruby-date2/distinfo1
-rw-r--r--devel/ruby-date2/pkg-comment1
-rw-r--r--devel/ruby-date2/pkg-descr8
-rw-r--r--devel/ruby-date2/pkg-plist23
5 files changed, 89 insertions, 0 deletions
diff --git a/devel/ruby-date2/Makefile b/devel/ruby-date2/Makefile
new file mode 100644
index 000000000000..24fba534182c
--- /dev/null
+++ b/devel/ruby-date2/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: Ruby-date2
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= date2
+PORTVERSION= 2
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www.kt.rim.or.jp/~tadf/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+MODULES= date2.rb date3.rb holiday.rb odate.rb \
+ parsedate2.rb parsedate2.ry parsedate3.rb \
+ qholiday.rb strftime.rb strptime.rb
+
+DOCS_EN= CHANGES.en MANUAL.en README.en
+DOCS_JA= MANUAL README
+EXAMPLES_EN= cal.rb daylight.rb goodfriday.rb
+EXAMPLES_JA= ncal.rb
+
+do-install:
+.for f in ${MODULES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/ruby/site_ruby/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/date2/examples/ja
+ ${MKDIR} ${PREFIX}/share/doc/ruby/date2/ja
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/doc/ruby/date2/examples/
+.endfor
+.for f in ${EXAMPLES_JA}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/doc/ruby/date2/examples/ja/
+.endfor
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-date2/distinfo b/devel/ruby-date2/distinfo
new file mode 100644
index 000000000000..dad6856030c2
--- /dev/null
+++ b/devel/ruby-date2/distinfo
@@ -0,0 +1 @@
+MD5 (date2-2.tar.gz) = 6180117536bab3d3e8fcbbd47efff841
diff --git a/devel/ruby-date2/pkg-comment b/devel/ruby-date2/pkg-comment
new file mode 100644
index 000000000000..f54f0d0121e0
--- /dev/null
+++ b/devel/ruby-date2/pkg-comment
@@ -0,0 +1 @@
+An alternative date class for Ruby
diff --git a/devel/ruby-date2/pkg-descr b/devel/ruby-date2/pkg-descr
new file mode 100644
index 000000000000..796bfd9b15db
--- /dev/null
+++ b/devel/ruby-date2/pkg-descr
@@ -0,0 +1,8 @@
+date2 is an alternative date class for Ruby.
+
+This class handles calculations about dates. The day of reform can be
+specified freely in this class. The procedures about holiday
+(holiday.rb) and date format (parsedate2.rb, strftime.rb and
+strptime.rb) are also available.
+
+WWW: http://www.kt.rim.or.jp/~tadf/ruby-en.html#date2
diff --git a/devel/ruby-date2/pkg-plist b/devel/ruby-date2/pkg-plist
new file mode 100644
index 000000000000..d5d3928d247e
--- /dev/null
+++ b/devel/ruby-date2/pkg-plist
@@ -0,0 +1,23 @@
+lib/ruby/site_ruby/date2.rb
+lib/ruby/site_ruby/date3.rb
+lib/ruby/site_ruby/holiday.rb
+lib/ruby/site_ruby/odate.rb
+lib/ruby/site_ruby/parsedate2.rb
+lib/ruby/site_ruby/parsedate2.ry
+lib/ruby/site_ruby/parsedate3.rb
+lib/ruby/site_ruby/qholiday.rb
+lib/ruby/site_ruby/strftime.rb
+lib/ruby/site_ruby/strptime.rb
+share/doc/ruby/date2/CHANGES.en
+share/doc/ruby/date2/MANUAL.en
+share/doc/ruby/date2/README.en
+share/doc/ruby/date2/examples/cal.rb
+share/doc/ruby/date2/examples/daylight.rb
+share/doc/ruby/date2/examples/goodfriday.rb
+share/doc/ruby/date2/examples/ja/ncal.rb
+share/doc/ruby/date2/ja/MANUAL
+share/doc/ruby/date2/ja/README
+@dirrm share/doc/ruby/date2/examples/ja
+@dirrm share/doc/ruby/date2/examples
+@dirrm share/doc/ruby/date2/ja
+@dirrm share/doc/ruby/date2