aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-ecore
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
commitee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442 (patch)
tree1bf12eadb5a7920766bf7a613174c0475b810d0d /devel/ruby-ecore
parent32e98c797bd5b952894ff185e59df8a91844f4ab (diff)
- Move to LOCALBASE
- Use new EFL framework - Update all e17 ports to the lates stable cvs snapshot - Add additional knobs/options to ports makefiles to control the feature set - Add a bunch of new e17 applications/libraries - Minor improvements/modification. Approved by: vanilla (old maintainer), sem (mentor)
Notes
Notes: svn path=/head/; revision=174934
Diffstat (limited to 'devel/ruby-ecore')
-rw-r--r--devel/ruby-ecore/Makefile21
-rw-r--r--devel/ruby-ecore/distinfo6
-rw-r--r--devel/ruby-ecore/files/patch-Rakefile17
3 files changed, 34 insertions, 10 deletions
diff --git a/devel/ruby-ecore/Makefile b/devel/ruby-ecore/Makefile
index ecbccba61193..0a259e79d6a0 100644
--- a/devel/ruby-ecore/Makefile
+++ b/devel/ruby-ecore/Makefile
@@ -6,30 +6,37 @@
#
PORTNAME= ecore
-PORTVERSION= 20060516
+PORTVERSION= 20061008
+PORTREVISION= 0
CATEGORIES= devel ruby
-MASTER_SITES= http://mbsd.msk.ru/dist/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-ecore-${PORTVERSION}
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Ruby bindings for Ecore library
BUILD_DEPENDS= ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake \
- ${RUBY_SITEARCHLIBDIR}/evas/rb_evas.h:${PORTSDIR}/graphics/ruby-evas
-LIB_DEPENDS= ecore.1:${PORTSDIR}/x11/ecore
+ ${RUBY_SA}/evas/rb_evas.h:${PORTSDIR}/graphics/ruby-evas
USE_BZIP2= yes
USE_RUBY= yes
+USE_EFL= ecore
+
+RUBY_SA= ${RUBY_SITEARCHLIBDIR}
.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} "s#%%X11BASE%%#${X11BASE}#g" ${WRKSRC}/Rakefile
+
do-build:
- @(cd ${WRKSRC}; ${SETENV} ECORE_PREFIX=${X11BASE} \
+ @(cd ${WRKSRC}; ${SETENV} ECORE_PREFIX=${LOCALBASE} \
${LOCALBASE}/bin/rake)
do-install:
- @(cd ${WRKSRC}; ${SETENV} ECORE_PREFIX=${X11BASE} \
+ @(cd ${WRKSRC}; ${SETENV} ECORE_PREFIX=${LOCALBASE} \
${LOCALBASE}/bin/rake install)
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
.include <bsd.port.post.mk>
diff --git a/devel/ruby-ecore/distinfo b/devel/ruby-ecore/distinfo
index f99bed4bb76e..66380ad14d36 100644
--- a/devel/ruby-ecore/distinfo
+++ b/devel/ruby-ecore/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby-ecore-20060516.tar.bz2) = 98a7372297633d6ce6bc4216d4807673
-SHA256 (ruby-ecore-20060516.tar.bz2) = ca6ea98584c533804bfd333cad059294cb457c85322e77ea461513aeada2ad52
-SIZE (ruby-ecore-20060516.tar.bz2) = 23928
+MD5 (ruby-ecore-20061008.tar.bz2) = a54661c6c9ff982a80f231fb5456fa37
+SHA256 (ruby-ecore-20061008.tar.bz2) = de3477d05c25cba51345b8dca9564e751262452cd9fe775fc9b0583336d8e24b
+SIZE (ruby-ecore-20061008.tar.bz2) = 24053
diff --git a/devel/ruby-ecore/files/patch-Rakefile b/devel/ruby-ecore/files/patch-Rakefile
new file mode 100644
index 000000000000..d5c309404789
--- /dev/null
+++ b/devel/ruby-ecore/files/patch-Rakefile
@@ -0,0 +1,17 @@
+--- Rakefile.orig Sun Oct 8 11:05:35 2006
++++ Rakefile Sun Oct 8 11:06:20 2006
+@@ -18,12 +18,12 @@
+
+ ext_libs.each do |lib|
+ file lib.so => lib.objects do |t|
+- sh "cc #{lib.ldflags} #{t.prerequisites.join(" ")} -o #{t.name}"
++ sh "cc -L%%X11BASE%%/lib #{lib.ldflags} #{t.prerequisites.join(" ")} -o #{t.name}"
+ end
+
+ lib.objects.each do |object|
+ file object => object.sub(/\.[^.]+$/, ".c") do |t|
+- sh "cc #{lib.cflags} #{t.prerequisites.first} " +
++ sh "cc -I%%X11BASE%%/include #{lib.cflags} #{t.prerequisites.first} " +
+ "-c -o #{t.name}"
+ end
+ end