aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-flexmock
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-12-01 01:24:37 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-12-01 01:24:37 +0000
commit09c5b77709e44a671b07fe602200aca74c192750 (patch)
tree28d560b285737582c59572531dc6bd725cd61de4 /devel/ruby-flexmock
parente9a69a476db0b133b2ed39ca818b3f3284b71bd6 (diff)
downloadports-09c5b77709e44a671b07fe602200aca74c192750.tar.gz
ports-09c5b77709e44a671b07fe602200aca74c192750.zip
Notes
Diffstat (limited to 'devel/ruby-flexmock')
-rw-r--r--devel/ruby-flexmock/Makefile25
-rw-r--r--devel/ruby-flexmock/distinfo6
-rw-r--r--devel/ruby-flexmock/pkg-descr12
-rw-r--r--devel/ruby-flexmock/pkg-plist12
4 files changed, 11 insertions, 44 deletions
diff --git a/devel/ruby-flexmock/Makefile b/devel/ruby-flexmock/Makefile
index f0437a538ad0..d4792db5c7c9 100644
--- a/devel/ruby-flexmock/Makefile
+++ b/devel/ruby-flexmock/Makefile
@@ -6,32 +6,15 @@
#
PORTNAME= flexmock
-PORTVERSION= 0.3.0
-CATEGORIES= devel ruby
+PORTVERSION= 0.8.6
+CATEGORIES= devel rubygems
MASTER_SITES= RF
-MASTER_SITE_SUBDIR= ecal
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A simple mock object for Ruby
USE_RUBY= yes
-
-NO_BUILD= yes
-
-DOCS= CHANGELOG README
-
-do-install:
- cd ${WRKSRC}; ${RUBY} install.rb
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS}
- ${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
-.endif
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/devel/ruby-flexmock/distinfo b/devel/ruby-flexmock/distinfo
index a4ff5eef5eb1..17a90f6d8f8c 100644
--- a/devel/ruby-flexmock/distinfo
+++ b/devel/ruby-flexmock/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/flexmock-0.3.0.tgz) = 007cf2ff2bd0804746a6eb95d6cf5576
-SHA256 (ruby/flexmock-0.3.0.tgz) = ff885a3464f04775fdb4e115d17745b9d6f813462db9e3d32bebba6f8da928fb
-SIZE (ruby/flexmock-0.3.0.tgz) = 16949
+MD5 (rubygem/flexmock-0.8.6.gem) = b087a648c5051e44e1d16fd886a7ce20
+SHA256 (rubygem/flexmock-0.8.6.gem) = 209722b60d13aa11b72c8e761ce83c8e7e446bfac92454bc064854c54d065731
+SIZE (rubygem/flexmock-0.8.6.gem) = 76800
diff --git a/devel/ruby-flexmock/pkg-descr b/devel/ruby-flexmock/pkg-descr
index 7cca1fe5102f..b87a2c238450 100644
--- a/devel/ruby-flexmock/pkg-descr
+++ b/devel/ruby-flexmock/pkg-descr
@@ -1,9 +1,5 @@
-sqlite3-ruby provides an interface for the SQLite DB engine version 3.
-This differs from the DBD::SQLite module in that it is more complete,
-and from the ruby DBI version of SQLite in that it is SQLite specific,
-so you can do things that would otherwise be more difficult via DBI.
-If you want portability between backends, use DBI. If you want ease
-of use with SQLite, use this.
+FlexMock is a flexible mocking library for use in unit testing and behavior
+specification. Mocks are defined with a fluent API that makes mock
+specifications easy to read and easy to remember.
-Author: Jamis Buck (minam) <jgb3@email.byu.edu>
-WWW: http://sqlite-ruby.rubyforge.org
+WWW: http://flexmock.rubyforge.org/
diff --git a/devel/ruby-flexmock/pkg-plist b/devel/ruby-flexmock/pkg-plist
deleted file mode 100644
index 48023a157cb5..000000000000
--- a/devel/ruby-flexmock/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-%%RUBY_SITELIBDIR%%/flexmock.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_example.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_mock.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_naming.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_record_mode.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_samples.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_should_receive.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_tu_integration.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGELOG
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%