aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gconf2/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-20 11:51:26 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-20 11:51:26 +0000
commit52512d3ab6a91b75d3947bc30f62a31c606bc9db (patch)
tree0dea91c08048733a06dd7416c796b4e01af8cf40 /devel/ruby-gconf2/Makefile
parent6092cf2d58aff3d1c5a1230ec5d29264027e3d67 (diff)
Notes
Diffstat (limited to 'devel/ruby-gconf2/Makefile')
-rw-r--r--devel/ruby-gconf2/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/ruby-gconf2/Makefile b/devel/ruby-gconf2/Makefile
new file mode 100644
index 000000000000..602d9e19c645
--- /dev/null
+++ b/devel/ruby-gconf2/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ruby-gconf
+# Date created: 20 October 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gconf
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ruby-gnome
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= gconf-gtk-1.1:${PORTSDIR}/devel/gconf
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+USE_GTK= yes
+
+CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
+INSTALL_TARGET= site-install
+
+DOCS= CREDITS \
+ ChangeLog \
+ INSTALL \
+ Makefile \
+ README \
+ README.DEV \
+ TODO
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>