aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gems/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-02-13 20:08:13 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-02-13 20:08:13 +0000
commit92f91aecedc9353e88b2492453ffacf32139fb52 (patch)
tree8926ab3b73eb75f8694c76d4ad3db6793a1deeeb /devel/ruby-gems/Makefile
parent56ed0767476a38843049df5e5ccd8c106fd81ca0 (diff)
Notes
Diffstat (limited to 'devel/ruby-gems/Makefile')
-rw-r--r--devel/ruby-gems/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/devel/ruby-gems/Makefile b/devel/ruby-gems/Makefile
index 26af0279aca9..e116f2b90ec5 100644
--- a/devel/ruby-gems/Makefile
+++ b/devel/ruby-gems/Makefile
@@ -55,6 +55,15 @@ post-install:
@${TOUCH} ${PREFIX}/${GEMS_DOC_BASE_DIR}/.keep_this
@${LN} -sf ${PREFIX}/bin/gem18 ${PREFIX}/bin/gem
+ @${FIND} -ds ${PREFIX}/lib/ruby/gems/${RUBY_VER}/doc/${DISTNAME} \
+ -type f -print | ${SED} -E -e 's,^${PREFIX}/?,,' >> ${TMPPLIST}
+ @${FIND} -ds ${PREFIX}/lib/ruby/gems/${RUBY_VER}/doc/${DISTNAME} \
+ -type d -print | ${SED} -E -e 's,^${PREFIX}/?,@dirrm ,' >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/lib/ruby/gems/${RUBY_VER}/doc 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/lib/ruby/gems/${RUBY_VER} 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/lib/ruby/gems 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/lib/ruby 2>/dev/null || true" >> ${TMPPLIST}
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
${ECHO} bin/gem > pkg-plist.new