aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gems
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-09 03:16:12 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-09 03:16:12 +0000
commit45ed55a9535f13b3a5c90a684d2ba1938caeef10 (patch)
treeb654053a3ae73466825be7d0d523b8fec46dc058 /devel/ruby-gems
parent77dc83a8e2e578765758036090b7e4855436a407 (diff)
downloadports-45ed55a9535f13b3a5c90a684d2ba1938caeef10.tar.gz
ports-45ed55a9535f13b3a5c90a684d2ba1938caeef10.zip
Notes
Diffstat (limited to 'devel/ruby-gems')
-rw-r--r--devel/ruby-gems/Makefile.common10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/ruby-gems/Makefile.common b/devel/ruby-gems/Makefile.common
index 512f1239f1b8..2bc29f31d232 100644
--- a/devel/ruby-gems/Makefile.common
+++ b/devel/ruby-gems/Makefile.common
@@ -41,5 +41,13 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
RUBYGEMBIN= ${LOCALBASE}/bin/gem
+.if defined(DISTFILES)
+GEMFILES= ${DISTFILES:C/:[^:]+$//}
+.else
+GEMFILES= ${DISTNAME}${EXTRACT_SUFX}
+.endif
+
do-install:
- ${RUBYGEMBIN} install --no-ri --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX}
+.for _D in ${GEMFILES}
+ ${RUBYGEMBIN} install --no-ri --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${_D}
+.endfor