aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gnustep/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-04-18 03:59:21 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-04-18 03:59:21 +0000
commit8177536f1110d09f126ae1c5b51e28a432f124ee (patch)
treef664369d2198c9b3fbf4298646d27fc6f1b2bb29 /devel/ruby-gnustep/Makefile
parent4a0c8446cc5130dba59a5bd9599d1e87e6f42244 (diff)
downloadports-8177536f1110d09f126ae1c5b51e28a432f124ee.tar.gz
ports-8177536f1110d09f126ae1c5b51e28a432f124ee.zip
Notes
Diffstat (limited to 'devel/ruby-gnustep/Makefile')
-rw-r--r--devel/ruby-gnustep/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index 63c785bde696..8b71054ab379 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -23,6 +23,7 @@ BUILD_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/g
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/lang/gnustep-base \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/x11-toolkits/gnustep-gui \
${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+LIB_DEPENDS+= objc:${PORTSDIR}/${GNUSTEP_OBJC_PORT}
RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/lang/gnustep-base \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/x11-toolkits/gnustep-gui \
@@ -31,8 +32,10 @@ RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnu
USE_RUBY= yes
RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
-USE_GCC= 3.2
+CC= gcc32
+CXX= g++32
+GNUSTEP_OBJC_PORT?= lang/gnustep-objc
GNUSTEP_PREFIX= ${LOCALBASE}/GNUstep
GNUSTEP_LOCAL_ROOT= ${GNUSTEP_PREFIX}/Local
GNUSTEP_SYSTEM_ROOT= ${GNUSTEP_PREFIX}/System