aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gnustep
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-08-28 19:23:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-08-28 19:23:02 +0000
commit6096f0f31ab668b06281063c3a92b2562ced7917 (patch)
treeafa2c0829cbde1d5e1bbbc429ca9b9f636db2f8e /devel/ruby-gnustep
parentf42b9fdd271824c49843d37d689156c9f07dd063 (diff)
downloadports-6096f0f31ab668b06281063c3a92b2562ced7917.tar.gz
ports-6096f0f31ab668b06281063c3a92b2562ced7917.zip
Notes
Diffstat (limited to 'devel/ruby-gnustep')
-rw-r--r--devel/ruby-gnustep/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index e6f1186793e6..7af4cb4ad900 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -18,12 +18,12 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= A Ruby interface to the GNUstep development environment
-BUILD_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
+BUILD_DEPENDS= ${SYSMAKEDIR}/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT} \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT} \
${BACKBUNDLEDIR}/libgnustep-back${BACKSUFFIX}:${PORTSDIR}/${GNUSTEP_BACK_PORT}
-RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
+RUN_DEPENDS= ${SYSMAKEDIR}/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT} \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT} \
${BACKBUNDLEDIR}/libgnustep-back${BACKSUFFIX}:${PORTSDIR}/${GNUSTEP_BACK_PORT}
@@ -52,10 +52,11 @@ GNUSTEP_LOCAL_ROOT= ${GNUSTEP_PREFIX}/Local
GNUSTEP_SYSTEM_ROOT= ${GNUSTEP_PREFIX}/System
GNUSTEP_NETWORK_ROOT= ${GNUSTEP_PREFIX}/Network
GNUSTEP_USER_ROOT= ${GNUSTEP_PREFIX}/Local/Users
-GNUSTEP_MAKEFILES= ${GNUSTEP_SYSTEM_ROOT}/Makefiles
+GNUSTEP_MAKEFILES= ${GNUSTEP_SYSTEM_ROOT}/Library/Makefiles
BACKBUNDLEDIR= ${GNUSTEP_PREFIX}/System/Library/Bundles/libgnustep-back${BACKSUFFIX}.bundle
SYSLIBDIR= ${GNUSTEP_PREFIX}/System/Library/Libraries
+SYSMAKEDIR= ${GNUSTEP_MAKEFILES}
COMBOLIBDIR= ${SYSLIBDIR}
MAKE_ENV+= GNUSTEP_FLATTENED=yes