aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gnustep
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-05-25 05:55:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-05-25 05:55:36 +0000
commit13b3264699685f92129a875b8e9a748e4009018d (patch)
tree3f76be59fd9d08b893230429270df55a0603b1aa /devel/ruby-gnustep
parentd4fbb7ad92f38ed96c3850958601133f20ea14ad (diff)
downloadports-13b3264699685f92129a875b8e9a748e4009018d.tar.gz
ports-13b3264699685f92129a875b8e9a748e4009018d.zip
Notes
Diffstat (limited to 'devel/ruby-gnustep')
-rw-r--r--devel/ruby-gnustep/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index 6da1cc0caa56..f16484447c03 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -24,11 +24,14 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+MAKE_FLAGS+= debug=no
+
post-extract:
${FIND} ${WRKSRC}/ -type f -name '.cvsignore' -delete
${FIND} -d ${WRKSRC}/ -type d -name CVS -exec ${RM} -rf "{}" ";"
post-patch:
+ ${ECHO_CMD} "" > ${WRKSRC}/Source/${MAKEFILE}.postamble
${RUBY} -i~ -p \
-e 'gsub(/-lpthread/, "-pthread");' \
-e 'gsub(/-lgmodel/, "");' \
@@ -37,6 +40,7 @@ post-patch:
${XARGS} ${RUBY} -i -pe 'gsub(/ ruby -/, " ${RUBY} -")'
post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/Source/obj/librigs.so $(RUBY_SITEARCHLIBDIR)/
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/Examples/* ${RUBY_MODEXAMPLESDIR}/