aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gnustep
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-04-30 06:30:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-04-30 06:30:00 +0000
commita2910f9eb6ce390fa856b4779cc5c7df70161289 (patch)
tree89df7494a5ace0c550c0b1fcecb9925272376c54 /devel/ruby-gnustep
parent14afa43118f0a64bf0bbeaedcdff169ad21e3a64 (diff)
downloadports-a2910f9eb6ce390fa856b4779cc5c7df70161289.tar.gz
ports-a2910f9eb6ce390fa856b4779cc5c7df70161289.zip
Notes
Diffstat (limited to 'devel/ruby-gnustep')
-rw-r--r--devel/ruby-gnustep/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index b2b65e0c7fe5..829d73795cf9 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -23,11 +23,17 @@ BUILD_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/${GNUST
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT} \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT} \
${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/${GNUSTEP_BACK_PORT}
-LIB_DEPENDS+= objc:${PORTSDIR}/${GNUSTEP_OBJC_PORT}
RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT} \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT} \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT} \
${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/${GNUSTEP_BACK_PORT}
+.if !defined(GNUSTEP_WITH_BASE_GCC)
+BUILD_DEPENDS+= ${TARGLIB}/libobjc.so:${PORTSDIR}/${GNUSTEP_GCC_PORT}
+RUN_DEPENDS+= ${TARGLIB}/libobjc.so:${PORTSDIR}/${GNUSTEP_GCC_PORT}
+.else
+BUILD_DEPENDS+= ${COMBOLIBDIR}/libobjc.so:${PORTSDIR}/${GNUSTEP_OBJC_PORT}
+RUN_DEPENDS+= ${COMBOLIBDIR}/libobjc.so:${PORTSDIR}/${GNUSTEP_OBJC_PORT}
+.endif
USE_RUBY= yes
RUBY_WITH_PTHREAD= yes
@@ -35,6 +41,7 @@ USE_GMAKE= yes
CC= gcc32
CXX= g++32
+GNUSTEP_GCC_PORT?= lang/gcc-objc
GNUSTEP_OBJC_PORT?= lang/gnustep-objc
GNUSTEP_MAKE_PORT?= devel/gnustep-make
GNUSTEP_BASE_PORT?= lang/gnustep-base
@@ -91,4 +98,8 @@ post-install:
.endfor
.endif
+.if !defined(GNUSTEP_WITH_BASE_GCC)
+TARGLIB!= (cd ${PORTSDIR}/${GNUSTEP_GCC_PORT} && make -V TARGLIB)
+.endif
+
.include <bsd.port.post.mk>