aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-io-reactor/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-12-25 19:51:40 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-12-25 19:51:40 +0000
commit9af30db32ec25961aca3134097b768a19b3386f7 (patch)
tree152d2942fa9dcdde8107ae68b743755c8fc4524d /devel/ruby-io-reactor/Makefile
parent4eae9ef70169e467be83bb0227eb45885329d786 (diff)
Notes
Diffstat (limited to 'devel/ruby-io-reactor/Makefile')
-rw-r--r--devel/ruby-io-reactor/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/ruby-io-reactor/Makefile b/devel/ruby-io-reactor/Makefile
new file mode 100644
index 000000000000..3ce85e23e734
--- /dev/null
+++ b/devel/ruby-io-reactor/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Ruby/io-reactor
+# Date created: 26 December 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= io-reactor
+PORTVERSION= 0.0.6
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.deveiate.org/code/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= IO-Reactor-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby module that implements an asynchronous multiplexeded IO Reactor
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= ChangeLog README
+EXAMPLES= examples/*
+
+do-install:
+ cd ${WRKSRC}; ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>