aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-io-reactor
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-12-25 19:51:40 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-12-25 19:51:40 +0000
commit9af30db32ec25961aca3134097b768a19b3386f7 (patch)
tree152d2942fa9dcdde8107ae68b743755c8fc4524d /devel/ruby-io-reactor
parent4eae9ef70169e467be83bb0227eb45885329d786 (diff)
downloadports-9af30db32ec25961aca3134097b768a19b3386f7.tar.gz
ports-9af30db32ec25961aca3134097b768a19b3386f7.zip
Notes
Diffstat (limited to 'devel/ruby-io-reactor')
-rw-r--r--devel/ruby-io-reactor/Makefile39
-rw-r--r--devel/ruby-io-reactor/distinfo2
-rw-r--r--devel/ruby-io-reactor/pkg-descr9
-rw-r--r--devel/ruby-io-reactor/pkg-plist6
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/ruby-io-reactor/Makefile b/devel/ruby-io-reactor/Makefile
new file mode 100644
index 000000000000..3ce85e23e734
--- /dev/null
+++ b/devel/ruby-io-reactor/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Ruby/io-reactor
+# Date created: 26 December 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= io-reactor
+PORTVERSION= 0.0.6
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.deveiate.org/code/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= IO-Reactor-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby module that implements an asynchronous multiplexeded IO Reactor
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= ChangeLog README
+EXAMPLES= examples/*
+
+do-install:
+ cd ${WRKSRC}; ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-io-reactor/distinfo b/devel/ruby-io-reactor/distinfo
new file mode 100644
index 000000000000..89158114dbb5
--- /dev/null
+++ b/devel/ruby-io-reactor/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/IO-Reactor-0.0.6.tar.gz) = 323e4d8bf8214596800d5427c450d9e8
+SIZE (ruby/IO-Reactor-0.0.6.tar.gz) = 16995
diff --git a/devel/ruby-io-reactor/pkg-descr b/devel/ruby-io-reactor/pkg-descr
new file mode 100644
index 000000000000..9bc274f481c7
--- /dev/null
+++ b/devel/ruby-io-reactor/pkg-descr
@@ -0,0 +1,9 @@
+This module is a pure-Ruby implementation of an asynchronous
+multiplexed IO Reactor which is based on the Reactor design pattern
+found in _Pattern-Oriented Software Architecture, Volume 2: Patterns
+for Concurrent and Networked Objects_. It allows a single thread to
+demultiplex and dispatch events from one or more IO objects to an
+appropriate handler.
+
+Author: Michael Granger <ged-raa@FaerieMUD.org>
+WWW: http://www.deveiate.org/code/IO-Reactor.html
diff --git a/devel/ruby-io-reactor/pkg-plist b/devel/ruby-io-reactor/pkg-plist
new file mode 100644
index 000000000000..f3106446a9b1
--- /dev/null
+++ b/devel/ruby-io-reactor/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITELIBDIR%%/io/reactor.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/chatserver.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%