aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-libglade2
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-07 20:00:57 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-07 20:00:57 +0000
commit5f46ac198804f878f5af19dd362539cb20306413 (patch)
tree03ce4503a54aec4ad8d5c59fd2c96ef7edf9183b /devel/ruby-libglade2
parentfc8e4f049f9f68443d2aabbc6faaafc5a95876c3 (diff)
downloadports-5f46ac198804f878f5af19dd362539cb20306413.tar.gz
ports-5f46ac198804f878f5af19dd362539cb20306413.zip
Notes
Diffstat (limited to 'devel/ruby-libglade2')
-rw-r--r--devel/ruby-libglade2/Makefile40
-rw-r--r--devel/ruby-libglade2/distinfo1
-rw-r--r--devel/ruby-libglade2/files/patch-extconf.rb25
-rw-r--r--devel/ruby-libglade2/pkg-comment1
-rw-r--r--devel/ruby-libglade2/pkg-descr4
-rw-r--r--devel/ruby-libglade2/pkg-plist6
6 files changed, 77 insertions, 0 deletions
diff --git a/devel/ruby-libglade2/Makefile b/devel/ruby-libglade2/Makefile
new file mode 100644
index 000000000000..47bbc13a6a75
--- /dev/null
+++ b/devel/ruby-libglade2/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby-libglade
+# Date created: 8 February 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libglade
+PORTVERSION= 1.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://beta4.com/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk.so:${PORTSDIR}/x11-toolkits/ruby-gtk
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+WANT_GLIB= yes
+WANT_GTK= yes
+
+WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
+CONFIGURE_ARGS= --with-glade-include="${LOCALBASE}/include/glade" \
+ --with-glib-config="${GLIB_CONFIG}" \
+ --with-gtk-config="${GTK_CONFIG}"
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/libglade/
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/libglade/
+ ${MKDIR} ${RUBY_DOCDIR}/libglade
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/libglade/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-libglade2/distinfo b/devel/ruby-libglade2/distinfo
new file mode 100644
index 000000000000..47a41b8f773b
--- /dev/null
+++ b/devel/ruby-libglade2/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-libglade-1.1.tar.gz) = 216279927ce94e10ba4c5abcaa83e88a
diff --git a/devel/ruby-libglade2/files/patch-extconf.rb b/devel/ruby-libglade2/files/patch-extconf.rb
new file mode 100644
index 000000000000..de691728f32d
--- /dev/null
+++ b/devel/ruby-libglade2/files/patch-extconf.rb
@@ -0,0 +1,25 @@
+--- extconf.rb.orig Wed Jan 24 12:29:18 2001
++++ extconf.rb Thu Feb 8 04:50:07 2001
+@@ -2,6 +2,16 @@
+
+ $objs = ["rbglade.o"]
+
++glib_config = with_config("glib-config", "glib-config")
++$CFLAGS += " " + %x(#{glib_config} --cflags).chomp
++$LDFLAGS += " " + %x(#{glib_config} --libs).chomp
++
++gtk_config = with_config("gtk-config", "gtk-config")
++$CFLAGS += " " + %x(#{gtk_config} --cflags).chomp
++$LDFLAGS += " " + %x(#{gtk_config} --libs).chomp
++
++puts $CFLAGS
++
+ dir_config("glade")
+ dir_config("xml")
+ dir_config("z")
+@@ -15,4 +25,4 @@
+ end
+ end
+
+-create_makefile("lglade")
++create_makefile("lglade")
diff --git a/devel/ruby-libglade2/pkg-comment b/devel/ruby-libglade2/pkg-comment
new file mode 100644
index 000000000000..1f69e4855a9a
--- /dev/null
+++ b/devel/ruby-libglade2/pkg-comment
@@ -0,0 +1 @@
+A wrapper library of libglade for Ruby
diff --git a/devel/ruby-libglade2/pkg-descr b/devel/ruby-libglade2/pkg-descr
new file mode 100644
index 000000000000..6869c89093e1
--- /dev/null
+++ b/devel/ruby-libglade2/pkg-descr
@@ -0,0 +1,4 @@
+Ruby-libglade -- A wrapper library of libglade for ruby
+
+Author: Avi Bryant <avi@beta4.com>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=Ruby%2FLibGlade
diff --git a/devel/ruby-libglade2/pkg-plist b/devel/ruby-libglade2/pkg-plist
new file mode 100644
index 000000000000..8e9a422c0f3e
--- /dev/null
+++ b/devel/ruby-libglade2/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITEARCHLIBDIR%%/lglade.so
+%%RUBY_EXAMPLESDIR%%/libglade/test.glade
+%%RUBY_EXAMPLESDIR%%/libglade/test.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/libglade
+%%RUBY_DOCDIR%%/libglade/README
+@dirrm %%RUBY_DOCDIR%%/libglade