aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-libgtop
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-04-13 15:53:54 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-04-13 15:53:54 +0000
commit3da122d1e941c65875db5f0f8c54116f38ed1014 (patch)
treefd5016786f5e23dbfad98f36a31fbad628e13e1c /devel/ruby-libgtop
parentcd086cfba5a470f41e0c90a5b3ff129676f433c0 (diff)
downloadports-3da122d1e941c65875db5f0f8c54116f38ed1014.tar.gz
ports-3da122d1e941c65875db5f0f8c54116f38ed1014.zip
Notes
Diffstat (limited to 'devel/ruby-libgtop')
-rw-r--r--devel/ruby-libgtop/Makefile41
-rw-r--r--devel/ruby-libgtop/distinfo1
-rw-r--r--devel/ruby-libgtop/files/patch-extconf.rb19
-rw-r--r--devel/ruby-libgtop/pkg-comment1
-rw-r--r--devel/ruby-libgtop/pkg-descr6
-rw-r--r--devel/ruby-libgtop/pkg-plist6
6 files changed, 74 insertions, 0 deletions
diff --git a/devel/ruby-libgtop/Makefile b/devel/ruby-libgtop/Makefile
new file mode 100644
index 000000000000..340cae343d7a
--- /dev/null
+++ b/devel/ruby-libgtop/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Ruby_libgtop
+# Date created: 13 Apr 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgtop
+PORTVERSION= 0.1.0
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.colinsteele.org/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby_${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= ChangeLog README
+EXAMPLES= test.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-libgtop/distinfo b/devel/ruby-libgtop/distinfo
new file mode 100644
index 000000000000..8555b23365bb
--- /dev/null
+++ b/devel/ruby-libgtop/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby_libgtop-0.1.0.tgz) = f50df5d99fa6a2dc0389ee6296ba645d
diff --git a/devel/ruby-libgtop/files/patch-extconf.rb b/devel/ruby-libgtop/files/patch-extconf.rb
new file mode 100644
index 000000000000..573aa083f399
--- /dev/null
+++ b/devel/ruby-libgtop/files/patch-extconf.rb
@@ -0,0 +1,19 @@
+--- extconf.rb.orig Fri Apr 13 04:03:18 2001
++++ extconf.rb Fri Apr 13 14:57:42 2001
+@@ -34,12 +34,10 @@
+ ######################################################################
+ require "mkmf"
+
+-dir_config("ruby_libgtop")
+-have_library("gtop", nil)
+-have_library("gtop_suid_common", nil)
+-have_library("gtop_common", nil)
+-have_library("gtop_names", nil)
+-have_library("gtop_sysdeps", nil)
++libgtop_config = with_config("libgtop-config", "libgtop-config")
++
++$CFLAGS = `#{libgtop_config} --cflags`.chomp
++$LDFLAGS = `#{libgtop_config} --libs`.chomp
+
+ create_makefile("ruby_libgtop")
+
diff --git a/devel/ruby-libgtop/pkg-comment b/devel/ruby-libgtop/pkg-comment
new file mode 100644
index 000000000000..1196df25263a
--- /dev/null
+++ b/devel/ruby-libgtop/pkg-comment
@@ -0,0 +1 @@
+A Ruby interface to libgtop
diff --git a/devel/ruby-libgtop/pkg-descr b/devel/ruby-libgtop/pkg-descr
new file mode 100644
index 000000000000..bbcea64def01
--- /dev/null
+++ b/devel/ruby-libgtop/pkg-descr
@@ -0,0 +1,6 @@
+Ruby_libgtop -- a Ruby interface to the very useful libgtop, a
+portable library that fetches system related information such as CPU
+Load, Memory Usage and information about running processes.
+
+Author: Colin Steele <colin@colinsteele.org>
+WWW: http://www.colinsteele.org/
diff --git a/devel/ruby-libgtop/pkg-plist b/devel/ruby-libgtop/pkg-plist
new file mode 100644
index 000000000000..c3b55b8757fb
--- /dev/null
+++ b/devel/ruby-libgtop/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITEARCHLIBDIR%%/ruby_libgtop.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/libgtop/test.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/libgtop
+%%PORTDOCS%%%%RUBY_DOCDIR%%/libgtop/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/libgtop/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/libgtop