aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-mmap
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-02-02 00:57:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-02-02 00:57:15 +0000
commit4e412a71aaf6493feaf5018e88faf09de48bb59c (patch)
tree1d617cc96271d1c575a419ae264976b45630944c /devel/ruby-mmap
parent1039a3414799968c65bbdf7e8ab7a56895653e38 (diff)
downloadports-4e412a71aaf6493feaf5018e88faf09de48bb59c.tar.gz
ports-4e412a71aaf6493feaf5018e88faf09de48bb59c.zip
Notes
Diffstat (limited to 'devel/ruby-mmap')
-rw-r--r--devel/ruby-mmap/Makefile5
-rw-r--r--devel/ruby-mmap/files/extra-patch-oniguruma20
2 files changed, 25 insertions, 0 deletions
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
index 9d69794eb62f..405273756d9e 100644
--- a/devel/ruby-mmap/Makefile
+++ b/devel/ruby-mmap/Makefile
@@ -31,6 +31,11 @@ DOCS= Changes \
.include <bsd.port.pre.mk>
+post-patch:
+.if exists(${RUBY_ARCHLIBDIR}/oniguruma.h)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-oniguruma
+.endif
+
post-build:
.if !defined(NOPORTDOCS)
cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} rdoc
diff --git a/devel/ruby-mmap/files/extra-patch-oniguruma b/devel/ruby-mmap/files/extra-patch-oniguruma
new file mode 100644
index 000000000000..6b5160b4fc62
--- /dev/null
+++ b/devel/ruby-mmap/files/extra-patch-oniguruma
@@ -0,0 +1,20 @@
+--- mmap.c.orig Thu Feb 1 14:52:50 2007
++++ mmap.c Thu Feb 1 14:55:16 2007
+@@ -1113,7 +1113,7 @@
+ }
+ else {
+ RSTRING(str)->ptr += start;
+- repl = rb_reg_regsub(repl, str, regs);
++ repl = rb_reg_regsub(repl, str, regs, pat);
+ RSTRING(str)->ptr -= start;
+ }
+ if (OBJ_TAINTED(repl)) tainted = 1;
+@@ -1211,7 +1211,7 @@
+ }
+ else {
+ RSTRING(str)->ptr += start;
+- val = rb_reg_regsub(repl, str, regs);
++ val = rb_reg_regsub(repl, str, regs, pat);
+ RSTRING(str)->ptr -= start;
+ }
+ if (OBJ_TAINTED(repl)) tainted = 1;