aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-nodedump/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-09 19:59:45 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-09 19:59:45 +0000
commitac2919d4d2c59840abbbc3dea6c625653b80f4bc (patch)
tree2acbb003b4ac7dd84c733636ae9e62d3c8a2a7dc /devel/ruby-nodedump/Makefile
parent83deb5a918b50eeaa0fd44e5382d432862e409f8 (diff)
downloadports-ac2919d4d2c59840abbbc3dea6c625653b80f4bc.tar.gz
ports-ac2919d4d2c59840abbbc3dea6c625653b80f4bc.zip
Notes
Diffstat (limited to 'devel/ruby-nodedump/Makefile')
-rw-r--r--devel/ruby-nodedump/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/ruby-nodedump/Makefile b/devel/ruby-nodedump/Makefile
new file mode 100644
index 000000000000..1b6b9aadd9a1
--- /dev/null
+++ b/devel/ruby-nodedump/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: NodeDump for Ruby
+# Date created: 10 November 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nodedump
+PORTVERSION= 0.1.7
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.pragmaticprogrammer.com/ruby/downloads/files/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= nodeDump-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+PORTCOMMENT= Displays the internal structure of a parsed Ruby program
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/
+.endif
+
+.include <bsd.port.mk>