aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-optparse
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-12 20:09:41 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-12 20:09:41 +0000
commit596ebf8a494ccec324a561d381d1c60d5f35cf02 (patch)
tree740528554f6f5efe5651a2e1c0f603dcf8fb5474 /devel/ruby-optparse
parentfa205cf0127276fbc75367f39be16135d70b5d9e (diff)
downloadports-596ebf8a494ccec324a561d381d1c60d5f35cf02.tar.gz
ports-596ebf8a494ccec324a561d381d1c60d5f35cf02.zip
Notes
Diffstat (limited to 'devel/ruby-optparse')
-rw-r--r--devel/ruby-optparse/Makefile16
-rw-r--r--devel/ruby-optparse/pkg-descr3
-rw-r--r--devel/ruby-optparse/pkg-plist8
3 files changed, 15 insertions, 12 deletions
diff --git a/devel/ruby-optparse/Makefile b/devel/ruby-optparse/Makefile
index 3b0709caef60..5686fd3f09cb 100644
--- a/devel/ruby-optparse/Makefile
+++ b/devel/ruby-optparse/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: Ruby-OptionParser
-# Date created: 7 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+# New ports collection makefile for: Ruby-OptionParser
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
@@ -21,14 +21,14 @@ NO_BUILD= yes
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
do-install:
- ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/optparse
+ ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/optparse
.for f in optparse.rb optparse/shellwords.rb optparse/time.rb
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/ruby/site_ruby/${f}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/${f}
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/ruby/optparse/ja
diff --git a/devel/ruby-optparse/pkg-descr b/devel/ruby-optparse/pkg-descr
index be0473d5854b..a0f4e3c7fd58 100644
--- a/devel/ruby-optparse/pkg-descr
+++ b/devel/ruby-optparse/pkg-descr
@@ -6,3 +6,6 @@ Features:
* can emit options' summaries
* can add options on the fly
* completion for option/argument
+
+Author: Nobuyoshi.Nakada <nobu.nokada@softhome.net>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=OptionParser \ No newline at end of file
diff --git a/devel/ruby-optparse/pkg-plist b/devel/ruby-optparse/pkg-plist
index c2c979696251..d05a1b66a99c 100644
--- a/devel/ruby-optparse/pkg-plist
+++ b/devel/ruby-optparse/pkg-plist
@@ -1,7 +1,7 @@
-lib/ruby/site_ruby/optparse/shellwords.rb
-lib/ruby/site_ruby/optparse/time.rb
-lib/ruby/site_ruby/optparse.rb
-@dirrm lib/ruby/site_ruby/optparse
+lib/ruby/site_ruby/%%RUBY_VER%%/optparse/shellwords.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/optparse/time.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/optparse.rb
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/optparse
share/examples/ruby/optparse/ja/getopts.test
share/examples/ruby/optparse/cmd-ls.rb
share/examples/ruby/optparse/cmd.rb