aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-pcsc-lite
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-12 18:29:58 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-12 18:29:58 +0000
commit469797ca3229e7c9ad8f6c239e546b9a3730d816 (patch)
tree792d6650b18d2607b1860671ac418a98ca93927f /devel/ruby-pcsc-lite
parent503d35e63793f0e966663161872a0ed3f667e086 (diff)
downloadports-469797ca3229e7c9ad8f6c239e546b9a3730d816.tar.gz
ports-469797ca3229e7c9ad8f6c239e546b9a3730d816.zip
Notes
Diffstat (limited to 'devel/ruby-pcsc-lite')
-rw-r--r--devel/ruby-pcsc-lite/Makefile41
-rw-r--r--devel/ruby-pcsc-lite/distinfo1
-rw-r--r--devel/ruby-pcsc-lite/pkg-comment1
-rw-r--r--devel/ruby-pcsc-lite/pkg-descr4
-rw-r--r--devel/ruby-pcsc-lite/pkg-plist6
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/ruby-pcsc-lite/Makefile b/devel/ruby-pcsc-lite/Makefile
new file mode 100644
index 000000000000..7e17f32220d3
--- /dev/null
+++ b/devel/ruby-pcsc-lite/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: PCSC-ruby
+# Date created: 27 Dec 2001
+# Whom: Toni Andjelkovic <toni@ants.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcsc-lite
+PORTVERSION= 0.5
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.ants.at/ruby/PCSC-ruby/dist/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= PCSC-ruby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= toni@ants.at
+
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+RUBY_SETUP= install.rb
+
+WRKSRC= ${WRKDIR}/PCSC-ruby
+
+DOCS= README.txt
+EXAMPLES= examples/test.rb examples/pcsclient.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${EXAMPLES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-pcsc-lite/distinfo b/devel/ruby-pcsc-lite/distinfo
new file mode 100644
index 000000000000..f03d58e94136
--- /dev/null
+++ b/devel/ruby-pcsc-lite/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/PCSC-ruby-0.5.tar.gz) = e0f3d37ac326f1daf8870b041048cdbf
diff --git a/devel/ruby-pcsc-lite/pkg-comment b/devel/ruby-pcsc-lite/pkg-comment
new file mode 100644
index 000000000000..e99aaaf8bd0d
--- /dev/null
+++ b/devel/ruby-pcsc-lite/pkg-comment
@@ -0,0 +1 @@
+Ruby extension for the UNIX PC/SC Lite API (MUSCLE)
diff --git a/devel/ruby-pcsc-lite/pkg-descr b/devel/ruby-pcsc-lite/pkg-descr
new file mode 100644
index 000000000000..bd935e3a8764
--- /dev/null
+++ b/devel/ruby-pcsc-lite/pkg-descr
@@ -0,0 +1,4 @@
+Ruby extension for the UNIX PC/SC Lite API (MUSCLE).
+
+Author: Toni Andjelkovic <toni@ants.at>
+WWW: http://www.ants.at/ruby/PCSC-ruby/
diff --git a/devel/ruby-pcsc-lite/pkg-plist b/devel/ruby-pcsc-lite/pkg-plist
new file mode 100644
index 000000000000..2b904ea9d466
--- /dev/null
+++ b/devel/ruby-pcsc-lite/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_ARCHLIBDIR%%/PCSC.so
+%%PORTDOCS%%%%RUBY_DOCDIR%%/pcsc-lite/README.txt
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/pcsc-lite/test.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/pcsc-lite/pcsclient.rb
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/pcsc-lite
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/pcsc-lite