aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-property/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-07 14:39:47 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-07 14:39:47 +0000
commit6be33926020dcfa43ec8a1bf94700238962f3b92 (patch)
treeb915338a31558eaf368cfd16cdf2b7ec1e6e80db /devel/ruby-property/Makefile
parent79507948280cacb290417077cbdc3e8420c3f9c1 (diff)
downloadports-6be33926020dcfa43ec8a1bf94700238962f3b92.tar.gz
ports-6be33926020dcfa43ec8a1bf94700238962f3b92.zip
Notes
Diffstat (limited to 'devel/ruby-property/Makefile')
-rw-r--r--devel/ruby-property/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/devel/ruby-property/Makefile b/devel/ruby-property/Makefile
index df59c6b52edc..3b8428f2c246 100644
--- a/devel/ruby-property/Makefile
+++ b/devel/ruby-property/Makefile
@@ -9,36 +9,33 @@ PORTNAME= property
PORTVERSION= 19990308
CATEGORIES= devel ruby
MASTER_SITES= http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/
-PKGNAMEPREFIX= ruby-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
post-patch:
${PERL} -i -pe 's|rubyapi.css|../rubyapi.css|g' ${WRKSRC}/Properties-ja.html
do-install:
- ${INSTALL_DATA} ${WRKSRC}/property.rb ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/
+ ${INSTALL_DATA} ${WRKSRC}/property.rb ${RUBY_SITELIBDIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ruby/property/ja
+ ${MKDIR} ${RUBY_DOCDIR}/property/ja
.for f in property-example.rb test.default property.README Properties.html rubyapi.css
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/property
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/property
.endfor
.for f in property.README.ja Properties-ja.html
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/property/ja
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/property/ja
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>