aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-rcov
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-06-14 01:56:45 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-06-14 01:56:45 +0000
commit80d0f67f70de01cff687d4975c4a5ceae30b4650 (patch)
tree1983e5aff2ded3afb357fb451dfad5c109053b4f /devel/ruby-rcov
parent3f2859d5d1c84913d51913fea649d3d6e7ba725a (diff)
downloadports-80d0f67f70de01cff687d4975c4a5ceae30b4650.tar.gz
ports-80d0f67f70de01cff687d4975c4a5ceae30b4650.zip
Notes
Diffstat (limited to 'devel/ruby-rcov')
-rw-r--r--devel/ruby-rcov/Makefile36
-rw-r--r--devel/ruby-rcov/distinfo3
-rw-r--r--devel/ruby-rcov/pkg-descr13
-rw-r--r--devel/ruby-rcov/pkg-plist21
4 files changed, 73 insertions, 0 deletions
diff --git a/devel/ruby-rcov/Makefile b/devel/ruby-rcov/Makefile
new file mode 100644
index 000000000000..5a2bc99e0d7d
--- /dev/null
+++ b/devel/ruby-rcov/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: rcov
+# Date created: 25 May 2006
+# Whom: Rui Lopes (rgl ruilopes com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= rcov
+PORTVERSION= 0.5.0
+CATEGORIES= devel ruby
+MASTER_SITES= http://eigenclass.org/static/rcov/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= rgl@ruilopes.com
+COMMENT= A tool for simple code coverage analysis in Ruby
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+DOC_FILES= BLURB CHANGES LEGAL LICENSE README.API \
+ README.en README.rake README.rant THANKS
+EXAMPLE_FILES= Rakefile Rantfile
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${RUBY_MODEXAMPLESDIR} ${RUBY_MODDOCDIR}
+.for f in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}
+.endfor
+.for f in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-rcov/distinfo b/devel/ruby-rcov/distinfo
new file mode 100644
index 000000000000..4724d5b09058
--- /dev/null
+++ b/devel/ruby-rcov/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/rcov-0.5.0.tar.gz) = 83ee7904b078a9bf748873627ad9d323
+SHA256 (ruby/rcov-0.5.0.tar.gz) = 288ceb46947d244ba51f5d27d24edd143bf67c377429e752de3c5c6fa965f560
+SIZE (ruby/rcov-0.5.0.tar.gz) = 51263
diff --git a/devel/ruby-rcov/pkg-descr b/devel/ruby-rcov/pkg-descr
new file mode 100644
index 000000000000..d1ef4ddc27c1
--- /dev/null
+++ b/devel/ruby-rcov/pkg-descr
@@ -0,0 +1,13 @@
+rcov is a tool for simple code coverage analysis in Ruby.
+
+It features:
+
+* fast execution: 20-300 times faster than previous tools
+* multiple analysis modes
+* fairly accurate coverage information through code linkage
+ inference using simple heuristics
+* XHTML and several kinds of text reports
+* easy automation with Rake via a RcovTask
+* colorblind-friendliness
+
+WWW: http://eigenclass.org/hiki.rb?rcov
diff --git a/devel/ruby-rcov/pkg-plist b/devel/ruby-rcov/pkg-plist
new file mode 100644
index 000000000000..1dd85760749b
--- /dev/null
+++ b/devel/ruby-rcov/pkg-plist
@@ -0,0 +1,21 @@
+bin/rcov
+%%RUBY_SITELIBDIR%%/rcov.rb
+%%RUBY_SITELIBDIR%%/rcov/lowlevel.rb
+%%RUBY_SITELIBDIR%%/rcov/rant.rb
+%%RUBY_SITELIBDIR%%/rcov/rcovtask.rb
+%%RUBY_SITELIBDIR%%/rcov/version.rb
+%%RUBY_SITEARCHLIBDIR%%/rcovrt.so
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/Rantfile
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/Rakefile
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/BLURB
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGES
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/LEGAL
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/LICENSE
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.API
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.rake
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.rant
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/THANKS
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+@dirrm %%RUBY_SITELIBDIR%%/rcov