aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-setup.rb/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-06-11 07:20:35 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-06-11 07:20:35 +0000
commit736ab8ca228c926182957cd044b5274598267f88 (patch)
tree3a1fd0d0e9f2f1aa8ee6ca54a3def6b18160fe7b /devel/ruby-setup.rb/Makefile
parent04453ec58bdea9735daaba769b2904939ee82138 (diff)
Notes
Diffstat (limited to 'devel/ruby-setup.rb/Makefile')
-rw-r--r--devel/ruby-setup.rb/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/ruby-setup.rb/Makefile b/devel/ruby-setup.rb/Makefile
new file mode 100644
index 000000000000..f98ba9f517eb
--- /dev/null
+++ b/devel/ruby-setup.rb/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby/setup.rb
+# Date created: 11 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= setup.rb
+PORTVERSION= 2.0.4
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www9.xdsl.ne.jp/~aamine/soft/ \
+ http://www.xdsl.ne.jp/Cd/aamine/soft/
+MASTER_SITE_SUBDIR= knu
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:R}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS_EN= doc.en/*
+DOCS_JA= doc.ja/*
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME} ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>