aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-statgrab
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2008-06-16 20:10:44 +0000
committerTim Bishop <tdb@FreeBSD.org>2008-06-16 20:10:44 +0000
commit03c5905ba2288ff1f267e9aa8eb37b17da9af536 (patch)
tree23dd76f9317665f217691e441b4b1880f04357b5 /devel/ruby-statgrab
parentf5c9b5def5a6622779d985e67b66328205882364 (diff)
downloadports-03c5905ba2288ff1f267e9aa8eb37b17da9af536.tar.gz
ports-03c5905ba2288ff1f267e9aa8eb37b17da9af536.zip
Notes
Diffstat (limited to 'devel/ruby-statgrab')
-rw-r--r--devel/ruby-statgrab/Makefile33
-rw-r--r--devel/ruby-statgrab/distinfo3
-rw-r--r--devel/ruby-statgrab/files/patch-extconf.rb7
-rw-r--r--devel/ruby-statgrab/pkg-descr4
-rw-r--r--devel/ruby-statgrab/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/ruby-statgrab/Makefile b/devel/ruby-statgrab/Makefile
new file mode 100644
index 000000000000..fa0ec814b3ec
--- /dev/null
+++ b/devel/ruby-statgrab/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ruby-statgrab
+# Date created: 16 June 2008
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= statgrab
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= A set of Ruby bindings for libstatgrab
+
+LIB_DEPENDS= statgrab.8:${PORTSDIR}/devel/libstatgrab
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+USE_GNOME= pkgconfig
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.mkdn ${RUBY_MODDOCDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-statgrab/distinfo b/devel/ruby-statgrab/distinfo
new file mode 100644
index 000000000000..914eceae64a2
--- /dev/null
+++ b/devel/ruby-statgrab/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/statgrab-0.1.tar.gz) = 95d6a3d4370affcd8f453659173c6df5
+SHA256 (ruby/statgrab-0.1.tar.gz) = aecb3ff8bfd27fa267ac4681eff29ec88586148046e2aedec6169ad407916cda
+SIZE (ruby/statgrab-0.1.tar.gz) = 9829
diff --git a/devel/ruby-statgrab/files/patch-extconf.rb b/devel/ruby-statgrab/files/patch-extconf.rb
new file mode 100644
index 000000000000..9959a70aa765
--- /dev/null
+++ b/devel/ruby-statgrab/files/patch-extconf.rb
@@ -0,0 +1,7 @@
+--- ./extconf.rb.orig 2008-06-16 20:37:28.000000000 +0100
++++ ./extconf.rb 2008-06-16 20:37:35.000000000 +0100
+@@ -1,3 +1,4 @@
+ require 'mkmf'
++pkg_config('libstatgrab')
+ have_library("statgrab")
+ create_makefile("statgrab")
diff --git a/devel/ruby-statgrab/pkg-descr b/devel/ruby-statgrab/pkg-descr
new file mode 100644
index 000000000000..60780f5819b5
--- /dev/null
+++ b/devel/ruby-statgrab/pkg-descr
@@ -0,0 +1,4 @@
+Statgrab for Ruby contains a set of Ruby bindings to the libstatgrab
+portable system statistics library.
+
+WWW: http://statgrab.rubyforge.org/
diff --git a/devel/ruby-statgrab/pkg-plist b/devel/ruby-statgrab/pkg-plist
new file mode 100644
index 000000000000..71a3c7e3f1ba
--- /dev/null
+++ b/devel/ruby-statgrab/pkg-plist
@@ -0,0 +1,7 @@
+%%RUBY_SITEARCHLIBDIR%%/statgrab.so
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.mkdn
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%@dirrmtry %%RUBY_DOCDIR%%
+@dirrmtry %%RUBY_SITEARCHLIBDIR%%
+@dirrmtry lib/ruby/site_ruby
+@dirrmtry lib/ruby