aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-activesupport
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /devel/rubygem-activesupport
parent090dbb7b77d15ec9d072089f51c17e73d6e22f59 (diff)
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Notes
Notes: svn path=/head/; revision=210636
Diffstat (limited to 'devel/rubygem-activesupport')
-rw-r--r--devel/rubygem-activesupport/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/rubygem-activesupport/Makefile b/devel/rubygem-activesupport/Makefile
index 0cd545074eab..0cc39feb80c8 100644
--- a/devel/rubygem-activesupport/Makefile
+++ b/devel/rubygem-activesupport/Makefile
@@ -13,6 +13,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jw@innerewut.de
COMMENT= Utility classes and extension that are required by Rails MVC Framework
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -26,6 +29,4 @@ x-generate-plist:
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>