aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-arrayfields
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-09 23:05:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-09 23:05:41 +0000
commit2dfb96a62be9e3d9cbf9a2738f9c9ecf4791a72d (patch)
tree2881027eb9df5bbfd9e17f2db431c026e9f4fbb4 /devel/rubygem-arrayfields
parenta23357c7a72d4ccdd239bc09314b291621edda77 (diff)
downloadports-2dfb96a62be9e3d9cbf9a2738f9c9ecf4791a72d.tar.gz
ports-2dfb96a62be9e3d9cbf9a2738f9c9ecf4791a72d.zip
Notes
Diffstat (limited to 'devel/rubygem-arrayfields')
-rw-r--r--devel/rubygem-arrayfields/Makefile27
-rw-r--r--devel/rubygem-arrayfields/distinfo3
-rw-r--r--devel/rubygem-arrayfields/pkg-descr12
3 files changed, 42 insertions, 0 deletions
diff --git a/devel/rubygem-arrayfields/Makefile b/devel/rubygem-arrayfields/Makefile
new file mode 100644
index 000000000000..1540c9235e98
--- /dev/null
+++ b/devel/rubygem-arrayfields/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rubygem-arrayfields
+# Date created: 07, Nov 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arrayfields
+PORTVERSION= 4.6.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RF/codeforpeople
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Allow Keyword Access to Array Instances
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} ${GEM_CACHE} > ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-arrayfields/distinfo b/devel/rubygem-arrayfields/distinfo
new file mode 100644
index 000000000000..f7f7a068c3fc
--- /dev/null
+++ b/devel/rubygem-arrayfields/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/arrayfields-4.6.0.gem) = 1fc502b73d1c0061232e306f881c17ea
+SHA256 (rubygem/arrayfields-4.6.0.gem) = 1a4a3563d026d6c11c3bee7a0ea1222cc7d4c4b152da86aa7ee3aa40951de59f
+SIZE (rubygem/arrayfields-4.6.0.gem) = 13312
diff --git a/devel/rubygem-arrayfields/pkg-descr b/devel/rubygem-arrayfields/pkg-descr
new file mode 100644
index 000000000000..145f36919ebb
--- /dev/null
+++ b/devel/rubygem-arrayfields/pkg-descr
@@ -0,0 +1,12 @@
+arrayfields allow keyword access to array instances.
+arrayfields works by adding only a few methods to arrays,
+namely #fields= and fields, but the #fields= method is
+hooked to extend an array on a per object basis.In
+otherwords __only__ those arrays whose fields are set
+will have auto-magical keyword access bestowed on
+them - all other arrays remain unaffected.arrays with
+keyword access require much less memory when compared
+to hashes/objects and yet still provide fast lookup and
+preserve data order.
+
+WWW: http://codeforpeople.com/lib/ruby/arrayfields/