aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-gettext/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-10-26 04:22:47 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-10-26 04:22:47 +0000
commit79c5ed3adbe57077f7beb0b916f8e4f9196f10ff (patch)
tree7001cf9936b410c4e8f75c354f9d499443ce0e8f /devel/rubygem-gettext/Makefile
parentde948f13272fe58c2ddde08b215d485f52753b91 (diff)
Notes
Diffstat (limited to 'devel/rubygem-gettext/Makefile')
-rw-r--r--devel/rubygem-gettext/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/devel/rubygem-gettext/Makefile b/devel/rubygem-gettext/Makefile
index fbdb1b483a65..a6e23568c363 100644
--- a/devel/rubygem-gettext/Makefile
+++ b/devel/rubygem-gettext/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gettext
-PORTVERSION= 0.6.1
+PORTVERSION= 0.7.0
CATEGORIES= devel ruby
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -23,21 +23,25 @@ USE_RUBY= yes
USE_RUBY_FEATURES= racc-runtime
USE_RUBY_SETUP= yes
-RUBY_RD_FILES= # defined
RUBY_SHEBANG_FILES= ${WRKSRC}/samples/*.rb
+DOCS_EN= ChangeLog README
+DOCS_JA= README.ja
+
post-install: doc-install
.include <bsd.port.mk>
doc-install:
.if !defined(NOPORTDOCS)
-.if !defined(RUBY_NO_RD_HTML)
- cd ${WRKSRC}/docs; ${RUBY} makehtml.rb
-.endif
cd ${WRKSRC}/samples; ${RUBY} makemo.rb
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/samples/* ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}
- ${CP} -R ${WRKSRC}/docs/* ${RUBY_MODDOCDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
.endif