aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-grit/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-09 23:01:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-09 23:01:24 +0000
commit035e3310b1f05db6fb88f67545717890f678ccea (patch)
tree603ece40861072a8eeec26313b552e04ca0ae012 /devel/rubygem-grit/Makefile
parent00031d4dc5cc83e0c3702356091244a791b3aecd (diff)
Grit is a Ruby library for extracting information from a git repository in
an object oriented manner. Grit gives you object model access to your git repository. Once you have created a repository object, you can traverse it to find parent commit(s), trees, blobs, etc. WWW: http://grit.rubyforge.org/ PR: ports/128592 Submitted by: Daniel Roethlisberger <daniel at roe.ch>
Notes
Notes: svn path=/head/; revision=222654
Diffstat (limited to 'devel/rubygem-grit/Makefile')
-rw-r--r--devel/rubygem-grit/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/rubygem-grit/Makefile b/devel/rubygem-grit/Makefile
new file mode 100644
index 000000000000..31ef21a86ca4
--- /dev/null
+++ b/devel/rubygem-grit/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: rubygem-grit
+# Date created: 2008-11-05
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+
+PORTNAME= grit
+PORTVERSION= 0.7.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RF/gems
+
+MAINTAINER= daniel@roe.ch
+COMMENT= An object-oriented ruby library to access git repositories
+
+BUILD_DEPENDS= rubygem-open4>=0.0.0:${PORTSDIR}/devel/rubygem-open4 \
+ rubygem-diff-lcs>=0.0.0:${PORTSDIR}/textproc/rubygem-diff-lcs \
+ rubygem-mime-types>=0.0.0:${PORTSDIR}/misc/rubygem-mime-types \
+ rubygem-hoe>=1.4.0:${PORTSDIR}/devel/rubygem-hoe
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>