aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-hoe/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-31 10:05:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-31 10:05:11 +0000
commitf9d8200c73fc531cff6cb3aa4ec3a15bd9f7f6e0 (patch)
tree8a5e87f64f8e5790ef93211966ac978ffa9626b8 /devel/rubygem-hoe/Makefile
parente01324bdafcfe99e5103d3f417919dd63fe5e969 (diff)
downloadports-f9d8200c73fc531cff6cb3aa4ec3a15bd9f7f6e0.tar.gz
ports-f9d8200c73fc531cff6cb3aa4ec3a15bd9f7f6e0.zip
Notes
Diffstat (limited to 'devel/rubygem-hoe/Makefile')
-rw-r--r--devel/rubygem-hoe/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/devel/rubygem-hoe/Makefile b/devel/rubygem-hoe/Makefile
index face8b578612..9a917a1bb834 100644
--- a/devel/rubygem-hoe/Makefile
+++ b/devel/rubygem-hoe/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= hoe
-PORTVERSION= 1.4.0
+PORTVERSION= 1.5.0
CATEGORIES= devel rubygems
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= seattlerb
@@ -17,6 +17,15 @@ BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
rubyforge:${PORTSDIR}/devel/rubygem-rubyforge
RUN_DEPENDS= ${BUILD_DEPENDS}
+post-install:
+ @${ECHO} bin/sow > ${TMPPLIST}
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
.include <bsd.port.post.mk>