aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-igraph
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:07:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:07:50 +0000
commitb168507c6cb24016b2df56e28275b6c2dc24e4a6 (patch)
treed5249c58dd27665f1a0efccbf3ed89e120b49ff8 /devel/rubygem-igraph
parent0a55efea43228322e68d8be3ef0bb9386a8dd333 (diff)
Notes
Diffstat (limited to 'devel/rubygem-igraph')
-rw-r--r--devel/rubygem-igraph/Makefile25
-rw-r--r--devel/rubygem-igraph/distinfo3
-rw-r--r--devel/rubygem-igraph/pkg-descr5
3 files changed, 33 insertions, 0 deletions
diff --git a/devel/rubygem-igraph/Makefile b/devel/rubygem-igraph/Makefile
new file mode 100644
index 000000000000..b96c5096c3cd
--- /dev/null
+++ b/devel/rubygem-igraph/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: igraph
+# Date created: 09 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= igraph
+PORTVERSION= 0.9.6
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Ruby extension for using the igraph library
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libigraph.so:${PORTSDIR}/math/igraph
+
+CONFIGURE_ARGS+= --with-igraph-include=${LOCALBASE}/include/igraph \
+ --without-igraph-lib=${LOCALBASE}/lib
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-igraph/distinfo b/devel/rubygem-igraph/distinfo
new file mode 100644
index 000000000000..2fac098e5944
--- /dev/null
+++ b/devel/rubygem-igraph/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/igraph-0.9.6.gem) = 8cc075cc3a553dbe3ba5aff1421d8694
+SHA256 (rubygem/igraph-0.9.6.gem) = f6c6fb3c12e25f53eb17a944040b362f95ba5cf302f5dc8dbc245294ce4aa603
+SIZE (rubygem/igraph-0.9.6.gem) = 72704
diff --git a/devel/rubygem-igraph/pkg-descr b/devel/rubygem-igraph/pkg-descr
new file mode 100644
index 000000000000..9dd5784b866f
--- /dev/null
+++ b/devel/rubygem-igraph/pkg-descr
@@ -0,0 +1,5 @@
+rubygem-igraph is a Ruby extension for using the igraph library.
+igraph is a library for creating and manipulating graphs with a
+particular emphasis on network analysis functions.
+
+WWW: http://rubyforge.org/projects/igraph/