aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-inline
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-03 13:30:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-03 13:30:40 +0000
commit2fe6ff7c79741b2c56337393d23772e3f0f9b6f8 (patch)
tree7ef9ada64b5e89bca9326b009ccea248c8b22f64 /devel/rubygem-inline
parentcbdc7448f752874db5aa12020188b52a911d6cae (diff)
downloadports-2fe6ff7c79741b2c56337393d23772e3f0f9b6f8.tar.gz
ports-2fe6ff7c79741b2c56337393d23772e3f0f9b6f8.zip
Notes
Diffstat (limited to 'devel/rubygem-inline')
-rw-r--r--devel/rubygem-inline/Makefile29
-rw-r--r--devel/rubygem-inline/distinfo6
-rw-r--r--devel/rubygem-inline/pkg-descr31
-rw-r--r--devel/rubygem-inline/pkg-plist28
4 files changed, 53 insertions, 41 deletions
diff --git a/devel/rubygem-inline/Makefile b/devel/rubygem-inline/Makefile
index b75ae749ca30..e90f77fffdfb 100644
--- a/devel/rubygem-inline/Makefile
+++ b/devel/rubygem-inline/Makefile
@@ -6,32 +6,17 @@
#
PORTNAME= inline
-PORTVERSION= 2.2.0
-CATEGORIES= devel ruby
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTVERSION= 3.5.0
+CATEGORIES= devel rubygems
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= ruby${PORTNAME}
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= RubyInline-${PORTVERSION}
-DIST_SUBDIR= ruby
MAINTAINER= seanc@FreeBSD.org
COMMENT= Inline::C allows you to embed C/Ruby directly in ruby scripts
-USE_RUBY= yes
+GEM_NAME= ${DISTNAME}
-NO_BUILD= yes
-
-DOCS= README.txt
-EXAMPLES= example.rb tutorial/example1.rb tutorial/example2.rb
-
-post-install:
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
-.endfor
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
-.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}
-.endfor
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/rubygem-inline/distinfo b/devel/rubygem-inline/distinfo
index 3fb74941790a..8eb65023ca41 100644
--- a/devel/rubygem-inline/distinfo
+++ b/devel/rubygem-inline/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/RubyInline-2.2.0.tar.gz) = f2c8184b7c0511723bfb94c8fe42ceb2
-SHA256 (ruby/RubyInline-2.2.0.tar.gz) = ff39fb0680eb43685af101aebc25002d05e561b58213701f4c5463c61985b175
-SIZE (ruby/RubyInline-2.2.0.tar.gz) = 9525
+MD5 (rubygem/RubyInline-3.5.0.gem) = 18858cdedb688e8f0a5813d24a44b424
+SHA256 (rubygem/RubyInline-3.5.0.gem) = aec87c423fcdbd55ae74448fd6d301969aa5c5e1a9041196bbafc5a12d1a7401
+SIZE (rubygem/RubyInline-3.5.0.gem) = 21504
diff --git a/devel/rubygem-inline/pkg-descr b/devel/rubygem-inline/pkg-descr
index 78257e6966b6..38504a889fb6 100644
--- a/devel/rubygem-inline/pkg-descr
+++ b/devel/rubygem-inline/pkg-descr
@@ -1,11 +1,24 @@
-Inline::C allows for quick and use of inlined C code in Ruby scripts.
-This library automatically:
+Ruby Inline is an analog to Perl's Inline::C. Out of the box, it allows you to
+embed C/++ external module code in your ruby script directly. By writing
+simple builder classes, you can teach how to cope with new languages (fortran,
+perl, whatever). The code is compiled and run on the fly when needed.
-* provides rudimentary automatic conversion between Ruby and C basic
- types: (unsigned)? (char|int|long|char *)
-* provides compilation of inline code
-* only recompiles if the C code has changed
-* can easily provide speedups in excess of 25x for tight loops when
- objects are being recycled too quickly.
+Using the package_inline tool Inline now allows you to package up your
+inlined object code for distribution to systems without a compiler
+(read: windows)!
-WWW: http://sourceforge.net/projects/rubyinline
+FEATURES/PROBLEMS:
+ * Quick and easy inlining of your C or C++ code embedded in your ruby
+ script.
+ * Extendable to work with other languages.
+ * Automatic conversion between ruby and C basic types
+ o char, unsigned, unsigned int, char *, int, long, unsigned long
+ * inline_c_raw exists for when the automatic conversion isn't
+ sufficient.
+ * Only recompiles if the inlined code has changed.
+ * Pretends to be secure.
+ * Only requires standard ruby libraries, nothing extra to download.
+ * Can generate a basic Rakefile and package up built extensions for
+ distribution.
+
+WWW: http://rubyforge.org/projects/rubyinline/
diff --git a/devel/rubygem-inline/pkg-plist b/devel/rubygem-inline/pkg-plist
index 42a5570d1a21..04d806e6081c 100644
--- a/devel/rubygem-inline/pkg-plist
+++ b/devel/rubygem-inline/pkg-plist
@@ -1,7 +1,21 @@
-%%RUBY_SITELIBDIR%%/inline.rb
-%%RUBY_MODDOCDIR%%/README.txt
-@dirrm %%RUBY_MODDOCDIR%%
-%%RUBY_MODEXAMPLESDIR%%/example.rb
-%%RUBY_MODEXAMPLESDIR%%/example1.rb
-%%RUBY_MODEXAMPLESDIR%%/example2.rb
-@dirrm %%RUBY_MODEXAMPLESDIR%%
+bin/inline_package
+%%GEM_CACHE%%
+%%GEM_SPEC%%
+%%GEM_LIB_DIR%%/History.txt
+%%GEM_LIB_DIR%%/Makefile
+%%GEM_LIB_DIR%%/Manifest.txt
+%%GEM_LIB_DIR%%/README.txt
+%%GEM_LIB_DIR%%/demo/fastmath.rb
+%%GEM_LIB_DIR%%/demo/hello.rb
+%%GEM_LIB_DIR%%/example.rb
+%%GEM_LIB_DIR%%/example2.rb
+%%GEM_LIB_DIR%%/inline.gemspec
+%%GEM_LIB_DIR%%/inline.rb
+%%GEM_LIB_DIR%%/inline_package
+%%GEM_LIB_DIR%%/test_inline.rb
+%%GEM_LIB_DIR%%/tutorial/example1.rb
+%%GEM_LIB_DIR%%/tutorial/example2.rb
+@dirrm %%GEM_LIB_DIR%%/tutorial
+@dirrm %%GEM_LIB_DIR%%/demo
+@dirrm %%GEM_LIB_DIR%%
+@dirrm %%GEM_DOC_DIR%%