aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-mongo/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-02-21 20:02:00 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-02-21 20:02:00 +0000
commita743f1f7e04dfa6777860b6da9d30d06797b9a14 (patch)
tree99b7af2b961109f37e4e71613a2efb751be6de54 /devel/rubygem-mongo/Makefile
parent4039c3f17aa9e410d303fa674fc19315e70b598e (diff)
Notes
Diffstat (limited to 'devel/rubygem-mongo/Makefile')
-rw-r--r--devel/rubygem-mongo/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/rubygem-mongo/Makefile b/devel/rubygem-mongo/Makefile
new file mode 100644
index 000000000000..9a31fe19cd26
--- /dev/null
+++ b/devel/rubygem-mongo/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: rubygem-mongo
+# Date created: 18 Feburary 2012
+# Whom: Evan Sarmiento <bsdports@wayfair.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mongo
+PORTVERSION= 1.5.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby library for mongo
+
+RUN_DEPENDS= rubygem-bson>=1.5.2:${PORTSDIR}/databases/rubygem-bson
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/mongo_console
+
+.include <bsd.port.mk>