aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-sequel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-25 00:25:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-25 00:25:47 +0000
commitf62242a8988520ee767d84d44bf7ea7de6fe2cc2 (patch)
tree3755beda92ba2d97d4e352e37028f6a05c6252f2 /devel/rubygem-sequel
parent274f0aed301ee959b5de1a89326853ed2c1af0ea (diff)
downloadports-f62242a8988520ee767d84d44bf7ea7de6fe2cc2.tar.gz
ports-f62242a8988520ee767d84d44bf7ea7de6fe2cc2.zip
Notes
Diffstat (limited to 'devel/rubygem-sequel')
-rw-r--r--devel/rubygem-sequel/Makefile28
-rw-r--r--devel/rubygem-sequel/distinfo3
-rw-r--r--devel/rubygem-sequel/pkg-descr14
3 files changed, 45 insertions, 0 deletions
diff --git a/devel/rubygem-sequel/Makefile b/devel/rubygem-sequel/Makefile
new file mode 100644
index 000000000000..f5b4e11e8464
--- /dev/null
+++ b/devel/rubygem-sequel/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rubygem-sequel
+# Date created: 24 Dec 2008
+# Whom: Wen Heping<wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sequel
+PORTVERSION= 2.8.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= The Database Toolkit for Ruby
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} bin/sequel > ${TMPPLIST}
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-sequel/distinfo b/devel/rubygem-sequel/distinfo
new file mode 100644
index 000000000000..0883c264b085
--- /dev/null
+++ b/devel/rubygem-sequel/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/sequel-2.8.0.gem) = 5c8d2f6b75b38e46f6dddf862e6a56a0
+SHA256 (rubygem/sequel-2.8.0.gem) = 49a6160d9dadef7b95e975cbc79db558530a4686680afb1b94608730142a24ab
+SIZE (rubygem/sequel-2.8.0.gem) = 260096
diff --git a/devel/rubygem-sequel/pkg-descr b/devel/rubygem-sequel/pkg-descr
new file mode 100644
index 000000000000..8d30f67dbd2f
--- /dev/null
+++ b/devel/rubygem-sequel/pkg-descr
@@ -0,0 +1,14 @@
+Sequel is a database toolkit for Ruby.
+ * Sequel provides thread safety, connection pooling and a concise
+ DSL for constructing database queries and table schemas.
+ * Sequel also includes a lightweight but comprehensive ORM layer for
+ mapping records to Ruby objects and handling associated records.
+ * Sequel supports advanced database features such as prepared
+ statements, bound variables, master/slave configurations, and database
+ sharding.
+ * Sequel makes it easy to deal with multiple records without having
+ to break your teeth on SQL.
+ * Sequel currently has adapters for ADO, DB2, DBI, Informix, JDBC,
+ MySQL, ODBC, OpenBase, Oracle, PostgreSQL and SQLite3.
+
+WWW: http://sequel.rubyforge.org/