aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-trollop
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-08 17:52:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-08 17:52:53 +0000
commit70e73aa9603dcffdc1ad39e6343d9d2333273df3 (patch)
tree3789f62b7baf069396b7c734a1748e7d0b98abc9 /devel/rubygem-trollop
parent9aff21ffbd0e1d31f0583f5dfbab9e300cfc2a19 (diff)
downloadports-70e73aa9603dcffdc1ad39e6343d9d2333273df3.tar.gz
ports-70e73aa9603dcffdc1ad39e6343d9d2333273df3.zip
Notes
Diffstat (limited to 'devel/rubygem-trollop')
-rw-r--r--devel/rubygem-trollop/Makefile28
-rw-r--r--devel/rubygem-trollop/distinfo3
-rw-r--r--devel/rubygem-trollop/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/devel/rubygem-trollop/Makefile b/devel/rubygem-trollop/Makefile
new file mode 100644
index 000000000000..dc9bf1f7b288
--- /dev/null
+++ b/devel/rubygem-trollop/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rubygem-trollop
+# Date created: 06/01/2009
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trollop
+PORTVERSION= 1.10.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RF/trollop
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A commandline option parser for Ruby that gets out of your way
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+USE_RAKE= yes
+
+post-install:
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-trollop/distinfo b/devel/rubygem-trollop/distinfo
new file mode 100644
index 000000000000..2000ad1d9cdf
--- /dev/null
+++ b/devel/rubygem-trollop/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/trollop-1.10.2.gem) = 02d53f41bd58f74047128be180455a65
+SHA256 (rubygem/trollop-1.10.2.gem) = 6bdd4b961f2ab74379aa6174221b110a479aa87d79f85ef2c3e09c48309f3d9b
+SIZE (rubygem/trollop-1.10.2.gem) = 18432
diff --git a/devel/rubygem-trollop/pkg-descr b/devel/rubygem-trollop/pkg-descr
new file mode 100644
index 000000000000..90f845dffa36
--- /dev/null
+++ b/devel/rubygem-trollop/pkg-descr
@@ -0,0 +1,7 @@
+Trollop is a commandline option parser for Ruby that gets out of your way.
+One line of code per option is all you need to write. For that, you get a
+nice automatically-generated help page (fit to your screen size!), robust
+option parsing, command subcompletion, and sensible defaults for everything
+you don't specify.
+
+WWW: http://trollop.rubyforge.org/