aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-tzinfo/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-10 11:38:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-10 11:38:37 +0000
commit4e5492a958883f2495b4841e5b0160b7dd5db8ef (patch)
tree6fc877ead4ecc1e8984089975f03fe31d4746e1c /devel/rubygem-tzinfo/Makefile
parentf8078849c28004d11a47da96f08fe10e4242ef34 (diff)
downloadports-4e5492a958883f2495b4841e5b0160b7dd5db8ef.tar.gz
ports-4e5492a958883f2495b4841e5b0160b7dd5db8ef.zip
Notes
Diffstat (limited to 'devel/rubygem-tzinfo/Makefile')
-rw-r--r--devel/rubygem-tzinfo/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/rubygem-tzinfo/Makefile b/devel/rubygem-tzinfo/Makefile
new file mode 100644
index 000000000000..733f6b70b43b
--- /dev/null
+++ b/devel/rubygem-tzinfo/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: tzinfo
+# Date created: 9 June 2006
+# Whom: Rui Lopes (rgl ruilopes com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= tzinfo
+PORTVERSION= 0.2.2
+CATEGORIES= devel rubygems
+MASTER_SITES= http://rubyforge.org/frs/download.php/10558/
+
+MAINTAINER= rgl@ruilopes.com
+COMMENT= Daylight-savings aware timezone support for Ruby
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist:
+ (${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
+ | ${SED} -E \
+ 's,.*share/nls/.+$$,,g \
+ ;s,^${GEM_CACHE}$$,%%GEM_CACHE%%,g \
+ ;s,${GEM_DOC_DIR}(/.+)?$$,%%GEM_DOC_DIR%%\1,g \
+ ;s,${GEM_LIB_DIR}(/.+)?$$,%%GEM_LIB_DIR%%\1,g \
+ ;s,^${GEM_SPEC}$$,%%GEM_SPEC%%,g \
+ ;s,^${GEMS_BASE_DIR}/(.+)$$,\1,g \
+ ;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
+ ' | ${TR} -s '\n') > temp-pkg-plist
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>