aboutsummaryrefslogtreecommitdiff
path: root/devel/rudiments/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2005-05-09 07:15:18 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2005-05-09 07:15:18 +0000
commit678278473834b3bb820885fb2b912f1d13c23e7e (patch)
treef9fc858f705cffaa6d84d5e60e771f8fa28406e8 /devel/rudiments/Makefile
parente83910244432b17faae1de2dab6148c08319cfe9 (diff)
Notes
Diffstat (limited to 'devel/rudiments/Makefile')
-rw-r--r--devel/rudiments/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index db472b0cd0f3..0d78b51209f9 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rudiments
-PORTVERSION= 0.27
-PORTREVISION= 1
+PORTVERSION= 0.28.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,8 +16,10 @@ COMMENT= A utility C++ class library for daemons, clients, servers and more
USE_GNOME= pkgconfig
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-ssl --disable-pcre
+USE_OPENSSL= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ARGS= --with-ssl-includes=-I${OPENSSLBASE}/include \
+ --with-ssl-libs=-L${OPENSSLBASE}/lib --disable-pcre
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= PTHREADINCLUDES="${PTHREAD_CFLAGS}" \
PTHREADLIB="${PTHREAD_LIBS}"