aboutsummaryrefslogtreecommitdiff
path: root/devel/sdl_sge/files
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-08-07 07:02:42 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-08-07 07:02:42 +0000
commit290f6233936d7ad0c9d7a892ac53a821ba4fd2b8 (patch)
tree2e4daeacf650f5414eb9291c4a16d0c070a1ba83 /devel/sdl_sge/files
parentdd838bc33707917a973b5c50f9d9d5e7d313c2ad (diff)
downloadports-290f6233936d7ad0c9d7a892ac53a821ba4fd2b8.tar.gz
ports-290f6233936d7ad0c9d7a892ac53a821ba4fd2b8.zip
Notes
Diffstat (limited to 'devel/sdl_sge/files')
-rw-r--r--devel/sdl_sge/files/patch-Makefile29
-rw-r--r--devel/sdl_sge/files/patch-Makefile.conf63
-rw-r--r--devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp17
3 files changed, 109 insertions, 0 deletions
diff --git a/devel/sdl_sge/files/patch-Makefile b/devel/sdl_sge/files/patch-Makefile
new file mode 100644
index 000000000000..9089803403f0
--- /dev/null
+++ b/devel/sdl_sge/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- work/sge030809/Makefile Tue Aug 12 00:40:41 2003
++++ Makefile Fri Aug 4 15:28:10 2006
+@@ -12,16 +12,11 @@
+
+ all: config $(OBJECTS)
+ @ar rsc libSGE.a $(OBJECTS)
++ $(CXX) $(CFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
+
+ $(OBJECTS): %.o:%.cpp %.h #Each object depends on thier .cpp and .h file
+ $(CXX) $(CFLAGS) -c $<
+
+-shared: all
+- $(CXX) $(CFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
+-
+-shared-strip: shared
+- @strip libSGE.so
+-
+ # Building a dll... I have no idea how to do this, but it should be something like below.
+ dll: config $(OBJECTS)
+ dlltool --output-def SGE.def $(OBJECTS)
+@@ -70,7 +65,7 @@
+ @echo ""
+ endif
+
+-install: shared
++install:
+ @mkdir -p $(PREFIX_H)
+ install -c -m 644 sge*.h $(PREFIX_H)
+ @mkdir -p $(PREFIX)/lib
diff --git a/devel/sdl_sge/files/patch-Makefile.conf b/devel/sdl_sge/files/patch-Makefile.conf
new file mode 100644
index 000000000000..cbe111883a44
--- /dev/null
+++ b/devel/sdl_sge/files/patch-Makefile.conf
@@ -0,0 +1,63 @@
+--- work/sge030809/Makefile.conf Tue Aug 12 00:43:35 2003
++++ Makefile.conf Fri Aug 4 15:20:41 2006
+@@ -7,11 +7,6 @@
+ #USE_IMG = n
+ #QUIET = y
+
+-
+-# Compilers (C and C++)
+-CC=gcc
+-CXX=g++
+-
+ # Make sure sdl-config is available
+ HAVE_SDL =$(shell if (sdl-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+ ifeq ($(HAVE_SDL),n)
+@@ -19,45 +14,24 @@
+ endif
+
+ # Where should SGE be installed?
+-PREFIX =$(shell sdl-config --prefix)
++PREFIX =PREFIX
+
+ # Where should the headerfiles be installed?
+-PREFIX_H =$(shell sdl-config --prefix)/include/SDL
++PREFIX_H =PREFIX_H
+
+ # Flags passed to the compiler
+-CFLAGS =-Wall -O3 -ffast-math
++CFLAGS +=-Wall -O3 -ffast-math
+ SGE_CFLAGS =$(shell sdl-config --cflags)
+-# Uncomment to make some more optimizations
+-#CFLAGS =-Wall -O9 -ffast-math -march=i686
+-
+
+ # Libs config
+ SGE_LIBS =$(shell sdl-config --libs) -lstdc++
+
+-
+-# Is freetype-config available?
+-HAVE_FT =$(shell if (freetype-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+-ifeq ($(HAVE_FT),n)
+- USE_FT = n
+-endif
+-
+ ifneq ($(USE_FT),n)
+ USE_FT = y
+ SGE_LIBS +=$(shell freetype-config --libs)
+ FT_CFLAGS =$(shell freetype-config --cflags)
+ endif
+
+-
+-# Is SDL_image available?
+-HAVE_IMG =$(shell if test -e "`sdl-config --prefix`/include/SDL/SDL_image.h" >/dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+-
+-ifneq ($(USE_IMG),y)
+- ifneq ($(USE_IMG),n)
+- USE_IMG =$(HAVE_IMG)
+- endif
+-endif
+-
+ ifeq ($(USE_IMG),y)
+ SGE_LIBS +=-lSDL_image
+ endif
+-
diff --git a/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp b/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp
new file mode 100644
index 000000000000..44571a375c9f
--- /dev/null
+++ b/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp
@@ -0,0 +1,17 @@
+diff -ur sge030809_orig/sge_tt_text.cpp sge030809/sge_tt_text.cpp
+--- sge030809_orig/sge_tt_text.cpp Fri Aug 8 14:48:08 2003
++++ sge_tt_text.cpp Sun Jul 30 20:49:29 2006
+@@ -36,9 +36,10 @@
+ #include "sge_textpp.h"
+
+ #ifndef _SGE_NOTTF
+-#include <freetype/freetype.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
++#include FT_OUTLINE_H
++#include FT_TRUETYPE_IDS_H
+ #include <freetype/internal/ftobjs.h>
+
+ /* The structure used to hold glyph information (cached) */