aboutsummaryrefslogtreecommitdiff
path: root/devel/sfslite
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-27 19:53:54 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-27 19:53:54 +0000
commitfb695bd164a8ef92f5cae593ab8c7d7fd2758fa6 (patch)
treede05fc658cec6ba674fe587f7a234f682a409471 /devel/sfslite
parent3ebfbeae106724d44850dff9f7a393a6c6aa8431 (diff)
Notes
Diffstat (limited to 'devel/sfslite')
-rw-r--r--devel/sfslite/Makefile6
-rw-r--r--devel/sfslite/distinfo6
-rw-r--r--devel/sfslite/files/patch-arpc-authopaque.C29
-rw-r--r--devel/sfslite/files/patch-arpc-authuint.C20
-rw-r--r--devel/sfslite/files/patch-arpc-rpctypes.h14
-rw-r--r--devel/sfslite/files/patch-arpc-xdr_suio.C20
-rw-r--r--devel/sfslite/files/patch-arpc-xdr_suio.h12
-rw-r--r--devel/sfslite/files/patch-async-sysconf.h18
-rw-r--r--devel/sfslite/pkg-install44
-rw-r--r--devel/sfslite/pkg-plist44
10 files changed, 59 insertions, 154 deletions
diff --git a/devel/sfslite/Makefile b/devel/sfslite/Makefile
index 9d08015498e6..9f6ed0376240 100644
--- a/devel/sfslite/Makefile
+++ b/devel/sfslite/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sfslite
-PORTVERSION= 0.8.4
-PORTREVISION= 1
+PORTVERSION= 1.2.2
CATEGORIES= devel
MASTER_SITES= http://dist.okws.org/dist/
@@ -16,8 +15,6 @@ COMMENT= Standard version of the sfslite library
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS+=--with-sfsuser=sfs \
- --with-sfsgroup=sfs
#
# rpcc does not work with byacc, so just require BISON
#
@@ -49,6 +46,7 @@ RPCC_BIN?= lib/${PORTNAME}-${SHORTVERSION}/${BUILD_MODE}
.else
BUILD_MODE?= shopt
RPCC_BIN?= bin
+CONFIGURE_ARGS += --enable-system-bin
.endif # define(BUILD_MODE)
USE_LDCONFIG= yes
diff --git a/devel/sfslite/distinfo b/devel/sfslite/distinfo
index b6a5f399eb06..3b41b27f2b1b 100644
--- a/devel/sfslite/distinfo
+++ b/devel/sfslite/distinfo
@@ -1,3 +1,3 @@
-MD5 (sfslite-0.8.4.tar.gz) = 743caad1058dc30d28698f80718af035
-SHA256 (sfslite-0.8.4.tar.gz) = b0b37ad6d319ca1f732aa88274e88f03884b9388cc396605cf101d3cb99451b4
-SIZE (sfslite-0.8.4.tar.gz) = 929145
+MD5 (sfslite-1.2.2.tar.gz) = a819f483eb2a0508f363c2f9cb2326e4
+SHA256 (sfslite-1.2.2.tar.gz) = 8b78bede2a2dc4d6756652a71ac22969490ab0bc2218b3651f2374067b146089
+SIZE (sfslite-1.2.2.tar.gz) = 1269819
diff --git a/devel/sfslite/files/patch-arpc-authopaque.C b/devel/sfslite/files/patch-arpc-authopaque.C
deleted file mode 100644
index 4ce45f062eae..000000000000
--- a/devel/sfslite/files/patch-arpc-authopaque.C
+++ /dev/null
@@ -1,29 +0,0 @@
---- arpc/authopaque.C.orig 2005-11-01 16:20:27.000000000 +0000
-+++ arpc/authopaque.C 2007-07-12 22:38:36.000000000 +0000
-@@ -41,7 +41,7 @@
- {
- AUTH *auth = New AUTH;
- bzero (auth, sizeof (*auth));
-- auth->ah_ops = (AUTH::auth_ops *) &auth_opaque_ops;
-+ auth->ah_ops = (AUTH::auth_ops *) ((void *)&auth_opaque_ops);
- auth->ah_cred.oa_base = static_cast<caddr_t> (xmalloc (MAX_AUTH_BYTES));
- auth->ah_verf.oa_base = static_cast<caddr_t> (xmalloc (MAX_AUTH_BYTES));
- authopaque_set (auth, NULL, NULL);
-@@ -66,7 +66,7 @@
- void
- authopaque_set (AUTH *auth, const opaque_auth *cred, const opaque_auth *verf)
- {
-- assert (auth->ah_ops == (AUTH::auth_ops *) &auth_opaque_ops);
-+ assert (auth->ah_ops == (AUTH::auth_ops *) ((void *)&auth_opaque_ops));
- authcopy (&auth->ah_cred, cred);
- authcopy (&auth->ah_verf, verf);
- }
-@@ -74,7 +74,7 @@
- void
- authopaque_set (AUTH *auth, const authunix_parms *aup)
- {
-- assert (auth->ah_ops == (AUTH::auth_ops *) &auth_opaque_ops);
-+ assert (auth->ah_ops == (AUTH::auth_ops *) ((void *)&auth_opaque_ops));
-
- auth->ah_cred.oa_flavor = AUTH_UNIX;
- xdrmem xdr (auth->ah_cred.oa_base, MAX_AUTH_BYTES);
diff --git a/devel/sfslite/files/patch-arpc-authuint.C b/devel/sfslite/files/patch-arpc-authuint.C
deleted file mode 100644
index bba84862ea86..000000000000
--- a/devel/sfslite/files/patch-arpc-authuint.C
+++ /dev/null
@@ -1,20 +0,0 @@
---- arpc/authuint.C.orig 2005-11-01 16:20:27.000000000 +0000
-+++ arpc/authuint.C 2007-07-12 22:38:40.000000000 +0000
-@@ -33,7 +33,7 @@
- u_int32_t
- authuint_getval (AUTH *auth)
- {
-- assert (auth->ah_ops == (AUTH::auth_ops *) &auth_uint_ops);
-+ assert (auth->ah_ops == (AUTH::auth_ops *) ((void *)&auth_uint_ops));
- return auth->ah_key.key.low;
- }
-
-@@ -43,7 +43,7 @@
- AUTH *auth = New AUTH;
- bzero (auth, sizeof (*auth));
- auth->ah_key.key.low = val;
-- auth->ah_ops = (AUTH::auth_ops *) &auth_uint_ops;
-+ auth->ah_ops = (AUTH::auth_ops *) ((void *)&auth_uint_ops);
- return auth;
- }
-
diff --git a/devel/sfslite/files/patch-arpc-rpctypes.h b/devel/sfslite/files/patch-arpc-rpctypes.h
deleted file mode 100644
index 40ed777bc168..000000000000
--- a/devel/sfslite/files/patch-arpc-rpctypes.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- arpc/rpctypes.h.orig 2005-11-22 17:42:29.000000000 +0000
-+++ arpc/rpctypes.h 2007-07-12 22:38:43.000000000 +0000
-@@ -271,9 +271,9 @@
- using rpc_vec<char, n>::base;
- using rpc_vec<char, n>::size;
-
-- void setstrmem (const str &s) { set (s.cstr (), s.len ()); }
-+ void setstrmem (const str &s) { rpc_vec<char, n>::set (s.cstr, s.len ()); }
- rpc_bytes &operator= (const str &s)
-- { setsize (s.len ()); memcpy (base (), s.cstr (), size ()); return *this; }
-+ { rpc_vec<char, n>::setsize (s.len ()); memcpy (base (), s.cstr (), size ()); return *this; }
- template<size_t m> rpc_bytes &operator= (const rpc_vec<char, m> &v)
- { rpc_vec<char, n>::operator= (v); return *this; }
- template<size_t m> rpc_bytes &operator= (const array<char, m> &v)
diff --git a/devel/sfslite/files/patch-arpc-xdr_suio.C b/devel/sfslite/files/patch-arpc-xdr_suio.C
deleted file mode 100644
index e888326b596d..000000000000
--- a/devel/sfslite/files/patch-arpc-xdr_suio.C
+++ /dev/null
@@ -1,20 +0,0 @@
---- arpc/xdr_suio.C.orig 2005-11-01 16:20:27.000000000 +0000
-+++ arpc/xdr_suio.C 2007-07-12 22:38:45.000000000 +0000
-@@ -66,7 +66,7 @@
- };
- static const XDR xsproto = {
- XDR_ENCODE,
-- (xdr_ops_t *) &xsops,
-+ (xdr_ops_t *) ((void *)&xsops),
- NULL, NULL, NULL, 0
- };
-
-@@ -82,7 +82,7 @@
- };
- static const XDR xsproto_scrub = {
- XDR_ENCODE,
-- (xdr_ops_t *) &xsops_scrub,
-+ (xdr_ops_t *) ((void *)&xsops_scrub),
- NULL, NULL, NULL, 0
- };
-
diff --git a/devel/sfslite/files/patch-arpc-xdr_suio.h b/devel/sfslite/files/patch-arpc-xdr_suio.h
deleted file mode 100644
index 60c77197634b..000000000000
--- a/devel/sfslite/files/patch-arpc-xdr_suio.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- arpc/xdr_suio.h.orig 2005-11-01 16:20:27.000000000 +0000
-+++ arpc/xdr_suio.h 2007-07-12 22:38:48.000000000 +0000
-@@ -26,7 +26,8 @@
- static inline suio *&
- xsuio (XDR *x)
- {
-- return (suio *&) x->x_private;
-+ void *& ptr = (void *&) x->x_private;
-+ return (suio *&)ptr;
- }
-
- extern "C" {
diff --git a/devel/sfslite/files/patch-async-sysconf.h b/devel/sfslite/files/patch-async-sysconf.h
index f060c826fc77..0bca4646e2e6 100644
--- a/devel/sfslite/files/patch-async-sysconf.h
+++ b/devel/sfslite/files/patch-async-sysconf.h
@@ -1,21 +1,25 @@
---- async/sysconf.h.orig 2005-11-01 16:20:33.000000000 +0000
-+++ async/sysconf.h 2007-07-12 22:38:10.000000000 +0000
-@@ -494,11 +494,12 @@
- #endif /* HAVE_MEMORY_H */
+--- async/sysconf.h.orig Thu Aug 30 16:57:16 2007
++++ async/sysconf.h Fri Sep 14 01:46:21 2007
+@@ -495,15 +495,16 @@
#include <dmalloc.h>
+
#undef memcpy
+#undef memmove
#undef xfree
+
+ #if DMALLOC_VERSION_MAJOR < 5 || \
+ (DMALLOC_VERSION_MAJOR == 5 && DMALLOC_VERSION_MINOR < 5)
+
#define memcpy(to, from, len) \
- _dmalloc_memcpy((char *) (to), (const char *) (from), len)
+ _dmalloc_memcpy(__FILE__, __LINE__, (char *) (to), (const char *) (from), len)
#define memmove(to, from, len) \
- _dmalloc_bcopy((const char *) (from), (char *) (to), len)
+ _dmalloc_bcopy(__FILE__, __LINE__, (const char *) (from), (char *) (to), len)
- /* Work around Dmalloc's misunderstanding of free's definition */
- #if DMALLOC_VERSION_MAJOR >= 5
-@@ -508,7 +509,7 @@
+ #endif /* version < 5.5 */
+
+@@ -515,7 +516,7 @@
dmalloc_malloc (f, l, s, DMALLOC_FUNC_MALLOC, 0, 0)
#define _xfree_leap(f, l, p) dmalloc_free (f, l, p, DMALLOC_FUNC_FREE)
#undef xstrdup
diff --git a/devel/sfslite/pkg-install b/devel/sfslite/pkg-install
index 1de77adb48a5..cbc76fde411f 100644
--- a/devel/sfslite/pkg-install
+++ b/devel/sfslite/pkg-install
@@ -1,45 +1,3 @@
#!/bin/sh
-if [ -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-USER=sfs
-GROUP=sfs
-UID=171
-GID=171
-PW=/usr/sbin/pw
-COMMENT='Self-Certifying File System'
-
-if [ "$2" = "PRE-INSTALL" ]; then
- echo -n "Checking for group '$GROUP'... "
-
- if ! ${PW} groupshow $GROUP >/dev/null 2>&1; then
- echo -n "doesn't exist, adding... "
- if ${PW} groupadd $GROUP -g ${GID}; then
- echo "success."
- else
- echo "FAILED!"
- exit 1
- fi
- else
- echo "exists."
- fi
-
- echo -n "Checking for user '$USER'... "
-
- if ! ${PW} usershow $USER >/dev/null 2>&1; then
- echo -n "doesn't exist, adding... "
- if ${PW} useradd $USER -u ${UID} -c ${COMMENT} \
- -d /nonexistent -g $GROUP -s /sbin/nologin -h -; then
- echo "success."
- else
- echo "FAILED!"
- exit 1
- fi
- else
- echo "exists."
- fi
-fi
-
-exit 0
+exit 0
diff --git a/devel/sfslite/pkg-plist b/devel/sfslite/pkg-plist
index d911c021a730..17bb6956a799 100644
--- a/devel/sfslite/pkg-plist
+++ b/devel/sfslite/pkg-plist
@@ -1,5 +1,5 @@
%%RPCC_BIN%%/rpcc
-%%RPCC_BIN%%/unwrap
+%%RPCC_BIN%%/tame
include/sfslite
include/sfslite-%%VERSION%%/%%TAG%%/aclnt.h
include/sfslite-%%VERSION%%/%%TAG%%/aes.h
@@ -27,6 +27,7 @@ include/sfslite-%%VERSION%%/%%TAG%%/bitvec.h
include/sfslite-%%VERSION%%/%%TAG%%/blowfish.h
include/sfslite-%%VERSION%%/%%TAG%%/callback.h
include/sfslite-%%VERSION%%/%%TAG%%/cbuf.h
+include/sfslite-%%VERSION%%/%%TAG%%/corebench.h
include/sfslite-%%VERSION%%/%%TAG%%/crypt.h
include/sfslite-%%VERSION%%/%%TAG%%/crypt_prot.h
include/sfslite-%%VERSION%%/%%TAG%%/crypt_prot.x
@@ -83,16 +84,40 @@ include/sfslite-%%VERSION%%/%%TAG%%/sfsmisc.h
include/sfslite-%%VERSION%%/%%TAG%%/sfsschnorr.h
include/sfslite-%%VERSION%%/%%TAG%%/sfsserv.h
include/sfslite-%%VERSION%%/%%TAG%%/sfstty.h
+include/sfslite-%%VERSION%%/%%TAG%%/sfs_select.h
include/sfslite-%%VERSION%%/%%TAG%%/sha1.h
include/sfslite-%%VERSION%%/%%TAG%%/srp.h
include/sfslite-%%VERSION%%/%%TAG%%/stllike.h
include/sfslite-%%VERSION%%/%%TAG%%/str.h
include/sfslite-%%VERSION%%/%%TAG%%/suio++.h
include/sfslite-%%VERSION%%/%%TAG%%/sysconf.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_aio.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_autocb.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_closure.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_connectors.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_event_ag.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_event_green.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_event.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_io.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_lock.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_nlock.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_pc.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_pipeline.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_recycle.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_rendezvous.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_rpcserver.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_run.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_slotset.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_tfork_ag.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_tfork.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_thread.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_trigger.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_typedefs.h
+include/sfslite-%%VERSION%%/%%TAG%%/tame_weakref.h
include/sfslite-%%VERSION%%/%%TAG%%/tiger.h
include/sfslite-%%VERSION%%/%%TAG%%/umac.h
include/sfslite-%%VERSION%%/%%TAG%%/union.h
-include/sfslite-%%VERSION%%/%%TAG%%/unwrap.h
include/sfslite-%%VERSION%%/%%TAG%%/uvfstrans.h
include/sfslite-%%VERSION%%/%%TAG%%/vatmpl.h
include/sfslite-%%VERSION%%/%%TAG%%/vec.h
@@ -100,7 +125,18 @@ include/sfslite-%%VERSION%%/%%TAG%%/wmstr.h
include/sfslite-%%VERSION%%/%%TAG%%/xdr_suio.h
include/sfslite-%%VERSION%%/%%TAG%%/xdrmisc.h
include/sfslite-%%VERSION%%/%%TAG%%/xhinfo.h
+include/sfslite-%%VERSION%%/%%TAG%%/dsa.h
+include/sfslite-%%VERSION%%/%%TAG%%/elgamal.h
+include/sfslite-%%VERSION%%/%%TAG%%/fips186.h
+include/sfslite-%%VERSION%%/%%TAG%%/fprint.h
+include/sfslite-%%VERSION%%/%%TAG%%/homoenc.h
+include/sfslite-%%VERSION%%/%%TAG%%/qtailq.h
+include/sfslite-%%VERSION%%/%%TAG%%/rabin_fprint.h
+include/sfslite-%%VERSION%%/%%TAG%%/rabinpoly.h
+include/sfslite-%%VERSION%%/%%TAG%%/rexcommon.h
+include/sfslite-%%VERSION%%/%%TAG%%/sfssesscrypt.h
lib/sfslite
+lib/sfslite-%%VERSION%%/acsfs.m4
lib/sfslite-%%VERSION%%/%%TAG%%/aiod
lib/sfslite-%%VERSION%%/%%TAG%%/env.mk
lib/sfslite-%%VERSION%%/%%TAG%%/libarpc.a
@@ -119,6 +155,10 @@ lib/sfslite-%%VERSION%%/%%TAG%%/libsfsmisc.a
lib/sfslite-%%VERSION%%/%%TAG%%/libsfsmisc.la
lib/sfslite-%%VERSION%%/%%TAG%%/libsfsmisc.so
lib/sfslite-%%VERSION%%/%%TAG%%/libsfsmisc.so.0
+lib/sfslite-%%VERSION%%/%%TAG%%/libtame.a
+lib/sfslite-%%VERSION%%/%%TAG%%/libtame.la
+lib/sfslite-%%VERSION%%/%%TAG%%/libtame.so
+lib/sfslite-%%VERSION%%/%%TAG%%/libtame.so.0
lib/sfslite-%%VERSION%%/%%TAG%%/mallock.o
lib/sfslite-%%VERSION%%/%%TAG%%/mmcd
@dirrm lib/sfslite-%%VERSION%%/%%TAG%%