aboutsummaryrefslogtreecommitdiff
path: root/devel/shapelib
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-16 08:07:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-16 08:07:40 +0000
commitb3394ff195aff0efdcd2959063a9c39c9de0fa8c (patch)
treeb4e33b4a585b4db48129e9418670832ca6cdf49a /devel/shapelib
parentb1db61c7357c92be88cac8175f552fd296e6f375 (diff)
Notes
Diffstat (limited to 'devel/shapelib')
-rw-r--r--devel/shapelib/Makefile14
-rw-r--r--devel/shapelib/files/patch-Makefile4
-rw-r--r--devel/shapelib/files/patch-contrib-Makefile2
-rw-r--r--devel/shapelib/pkg-plist12
4 files changed, 16 insertions, 16 deletions
diff --git a/devel/shapelib/Makefile b/devel/shapelib/Makefile
index 2162be498085..1ef480f476fa 100644
--- a/devel/shapelib/Makefile
+++ b/devel/shapelib/Makefile
@@ -23,7 +23,7 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${SHAPELIB_VER}
OPTIONS= DEBUG "Debugging" off \
- PROJ4 "Cartographic Projections library" off
+ PROJ "Cartographic Projections library" off
SHAPELIB_VER= ${PORTVERSION}b2
@@ -41,13 +41,13 @@ ENDIAN= -D_LITTLE_ENDIAN
ENDIAN= -D_BIG_ENDIAN
.endif
-.if defined(WITH_PROJ4)
+.if defined(WITH_PROJ)
LIB_DEPENDS+= proj:${PORTSDIR}/graphics/proj
-PLIST_SUB+= PROJ4=""
-PROJ4= -DPROJ4
+PLIST_SUB+= PROJ=""
+PROJ= -DPROJ4
.else
-PLIST_SUB+= PROJ4="@comment "
-PROJ4= -DNO_PROJ4
+PLIST_SUB+= PROJ="@comment "
+PROJ= -DNO_PROJ4
.endif
post-patch:
@@ -58,7 +58,7 @@ post-patch:
-e 's#%%LIBTOOL%%#${LIBTOOL}#g' \
-e 's#%%PREFIX%%#${PREFIX}#g' \
-e 's#%%ENDIAN%%#${ENDIAN}#g' \
- -e 's#%%PROJ4%%#${PROJ4}#g' \
+ -e 's#%%PROJ%%#${PROJ}#g' \
${WRKSRC}/Makefile ${WRKSRC}/contrib/Makefile
post-install:
diff --git a/devel/shapelib/files/patch-Makefile b/devel/shapelib/files/patch-Makefile
index 9a1face89568..f7fa6bd6dfd1 100644
--- a/devel/shapelib/files/patch-Makefile
+++ b/devel/shapelib/files/patch-Makefile
@@ -34,7 +34,7 @@
+.endfor
+
+contrib_tools:
-+ (cd contrib; ${MAKE} %%PROJ4%% all; cd ..)
++ (cd contrib; ${MAKE} %%PROJ%% all; cd ..)
+
+tools_install:
+.for _TOOL in ${TOOLS}
@@ -42,7 +42,7 @@
+.endfor
+
+contrib_install:
-+ (cd contrib; ${MAKE} %%PROJ4%% install; cd ..)
++ (cd contrib; ${MAKE} %%PROJ%% install; cd ..)
shpopen.o: shpopen.c shapefil.h
$(CC) $(CFLAGS) -c shpopen.c
diff --git a/devel/shapelib/files/patch-contrib-Makefile b/devel/shapelib/files/patch-contrib-Makefile
index b5ec39a25ccc..15931b85ee4e 100644
--- a/devel/shapelib/files/patch-contrib-Makefile
+++ b/devel/shapelib/files/patch-contrib-Makefile
@@ -8,7 +8,7 @@
+#ENDIAN = -D_LITTLE_ENDIAN
-CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
-+CFLAGS += %%DEBUG%% %%ENDIAN%% %%PROJ4%% -I.. -I%%PREFIX%%/include -L%%PREFIX%%/lib
++CFLAGS += %%DEBUG%% %%ENDIAN%% %%PROJ%% -I.. -I%%PREFIX%%/include -L%%PREFIX%%/lib
SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
diff --git a/devel/shapelib/pkg-plist b/devel/shapelib/pkg-plist
index abb8302ed7ad..a687a791381f 100644
--- a/devel/shapelib/pkg-plist
+++ b/devel/shapelib/pkg-plist
@@ -14,12 +14,12 @@ bin/shptest
bin/shptreedump
bin/shputils
bin/Shape_PointInPoly
-%%PROJ4%%bin/shpcentrd
-%%PROJ4%%bin/shpdata
-%%PROJ4%%bin/shpinfo
-%%PROJ4%%bin/shpproj
-%%PROJ4%%bin/shpsort
-%%PROJ4%%bin/shpwkb
+%%PROJ%%bin/shpcentrd
+%%PROJ%%bin/shpdata
+%%PROJ%%bin/shpinfo
+%%PROJ%%bin/shpproj
+%%PROJ%%bin/shpsort
+%%PROJ%%bin/shpwkb
include/shapefil.h
lib/libshp.a
lib/libshp.la