aboutsummaryrefslogtreecommitdiff
path: root/devel/shflags
diff options
context:
space:
mode:
authorYi-Jheng Lin <yzlin@FreeBSD.org>2009-12-17 14:21:05 +0000
committerYi-Jheng Lin <yzlin@FreeBSD.org>2009-12-17 14:21:05 +0000
commit930f5cddbacf084d1fbdcf922e01d8cc672e508f (patch)
treed4e56733253f5c8285d848cb909fc1b04e2372bb /devel/shflags
parente2ae93b2ae4a4f4fab5ec9d0838a422f5ebd719e (diff)
downloadports-930f5cddbacf084d1fbdcf922e01d8cc672e508f.tar.gz
ports-930f5cddbacf084d1fbdcf922e01d8cc672e508f.zip
Notes
Diffstat (limited to 'devel/shflags')
-rw-r--r--devel/shflags/Makefile23
-rw-r--r--devel/shflags/distinfo3
-rw-r--r--devel/shflags/pkg-descr12
3 files changed, 38 insertions, 0 deletions
diff --git a/devel/shflags/Makefile b/devel/shflags/Makefile
new file mode 100644
index 000000000000..8865201aeb82
--- /dev/null
+++ b/devel/shflags/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: shflags
+# Date created: 2009-12-17
+# Whom: Yi-Jheng Lin <yzlin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shflags
+PORTVERSION= 1.0.3
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= yzlin@FreeBSD.org
+COMMENT= Command-line flags module for Unix shell scripts
+
+NO_BUILD= yes
+PLIST_FILES= lib/shflags
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/shflags ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/shflags/distinfo b/devel/shflags/distinfo
new file mode 100644
index 000000000000..6349c1c2427c
--- /dev/null
+++ b/devel/shflags/distinfo
@@ -0,0 +1,3 @@
+MD5 (shflags-1.0.3.tgz) = b4d7133696ec05b71b27d8df5e278f0f
+SHA256 (shflags-1.0.3.tgz) = 956a14771230760e24fa6ad5692bf858d1c9ee2d314320091fd045181cec8a22
+SIZE (shflags-1.0.3.tgz) = 43549
diff --git a/devel/shflags/pkg-descr b/devel/shflags/pkg-descr
new file mode 100644
index 000000000000..521354078631
--- /dev/null
+++ b/devel/shflags/pkg-descr
@@ -0,0 +1,12 @@
+Shell Flags (shFlags) is a library written to greatly simplify the handling of
+command-line flags in Bourne based Unix shell scripts (bash, dash, ksh, sh,
+zsh) on many Unix OSes (Linux, Solaris, Mac OS X, etc.).
+
+Most shell scripts use getopt for flags processing, but the different versions
+of getopt on various OSes make writing portable shell scripts difficult.
+shFlags instead provides an API that doesn't change across shell and OS
+versions so the script writer can be confident that the script will work.
+
+shFlags is a port of the google-gflags C++/Python library.
+
+WWW: http://code.google.com/p/shflags/