aboutsummaryrefslogtreecommitdiff
path: root/devel/silc-toolkit
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 22:26:06 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 22:26:06 +0000
commit6a1f566d6bbeed80e5d9588955b4078b1675b8ab (patch)
tree0fe60f35616cd79c4fad4561bf8e14b4de573d44 /devel/silc-toolkit
parentf4dd222b6487074ae37b3bce97e9468092aa9e85 (diff)
downloadports-6a1f566d6bbeed80e5d9588955b4078b1675b8ab.tar.gz
ports-6a1f566d6bbeed80e5d9588955b4078b1675b8ab.zip
Notes
Diffstat (limited to 'devel/silc-toolkit')
-rw-r--r--devel/silc-toolkit/Makefile27
-rw-r--r--devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs40
-rw-r--r--devel/silc-toolkit/files/patch-Makefile.in40
-rw-r--r--devel/silc-toolkit/files/patch-irssi:Makefile.in11
-rw-r--r--devel/silc-toolkit/pkg-plist223
5 files changed, 172 insertions, 169 deletions
diff --git a/devel/silc-toolkit/Makefile b/devel/silc-toolkit/Makefile
index ce06bcca11ff..4b92cbc725d7 100644
--- a/devel/silc-toolkit/Makefile
+++ b/devel/silc-toolkit/Makefile
@@ -9,21 +9,32 @@ PORTNAME= silc
PORTVERSION= 0.6.1
CATEGORIES= devel net security
MASTER_SITES= http://www.silcnet.org/download/ \
- ftp://ftp.silcnet.org/pub/silc/
+ ftp://ftp.silcnet.org/pub/silc/ \
+ http://ftp.silcnet.org/ \
+ http://munitions.vipul.net/software/mirrors/silc/ \
+ ftp://ftp.wiretapped.net/pub/security/network-security/silc/ \
+ http://www.au.silcnet.org/download/ \
+ ftp://ftp.au.silcnet.org/pub/silcnet/ \
+ http://www.planetmirror.com/pub/silcnet/ \
+ http://the.wiretapped.net/security/network-security/silc/ \
+ ftp://ftp.wiretapped.net/pub/security/network-security/silc/ \
+ http://www.no.silcnet.org/download/ \
+ ftp://ftp.no.silcnet.org/pub/silc/
PKGNAMESUFFIX= -toolkit
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS= dotconf.0:${PORTSDIR}/devel/dotconf
+RUN_DEPENDS= silc:${PORTSDIR}/net/silc-client
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GLIB= yes
CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME} \
- --with-docdir=share/doc/${PORTNAME} \
+ --with-docdir=share/doc/${PORTNAME}${PKGNAMESUFFIX} \
--with-etcdir=${PREFIX}/etc/${PORTNAME} \
- --with-helpdir=share/${PORTNAME}/help \
+ --with-helpdir=share/${PORTNAME}${PKGNAMESUFFIX}/help \
--with-logsdir=${PORTNAME}/logs \
--with-simdir=libexec/${PORTNAME}/modules \
--includedir=${PREFIX}/include/${PORTNAME}
@@ -31,10 +42,6 @@ PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
-.ifdef(NOPORTDOCS)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in-noportdocs
-.endif
-
.ifdef(WITHOUT_OPTIMIZED_ASM)
CONFIGURE_ARGS+= --disable-asm
.endif
@@ -53,6 +60,12 @@ pre-everything::
@${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
.endif
+post-patch:
+.ifdef(NOPORTDOCS)
+ @${PERL} -pi -ne 's|doc includes|includes|;s| doc-install| |; \
+ s|^.*-mkdir -p \$$\(docdir\).*$$||' ${WRKSRC}/Makefile.in
+.endif
+
# ugly, ugly hack; for some reason (configure reason), this ports
# breaks if CONFIGURE_TARGET is given as an argument
do-configure:
diff --git a/devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs b/devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs
deleted file mode 100644
index 0d20ebd144bc..000000000000
--- a/devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs
+++ /dev/null
@@ -1,40 +0,0 @@
---- Makefile.in.orig Fri Nov 9 04:24:09 2001
-+++ Makefile.in Fri Nov 9 04:24:45 2001
-@@ -145,9 +145,9 @@
-
- AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
-
--COMMONDIRS = lib irssi silc silcd doc includes
--SUBDIRS = lib irssi silc silcd doc includes win32
--DIST_SUBDIRS = lib irssi silc silcd doc includes win32
-+COMMONDIRS = lib irssi silc silcd includes
-+SUBDIRS = lib irssi silc silcd includes win32
-+DIST_SUBDIRS = lib irssi silc silcd includes win32
-
- #
- # INCLUDE defines
-@@ -166,7 +166,6 @@
- -I$(silc_top_srcdir)/lib/silcclient \
- -I$(silc_top_srcdir)/lib/contrib \
- -I$(silc_top_srcdir)/includes \
-- -I$(silc_top_srcdir)/doc \
- -I$(silc_top_srcdir)/lib/trq
-
-
-@@ -514,7 +513,6 @@
- -mkdir -p $(etcdir)
- -mkdir -p $(modulesdir)
- -mkdir -p $(helpdir)
-- -mkdir -p $(docdir)
- -mkdir -p $(logsdir)
-
- generate-server-key:
-@@ -549,7 +547,7 @@
- $(etcdir)/silc.conf; \
- fi
-
--install-data-hook: install-dirs generate-server-key sim-install doc-install etc-install
-+install-data-hook: install-dirs generate-server-key sim-install etc-install
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/devel/silc-toolkit/files/patch-Makefile.in b/devel/silc-toolkit/files/patch-Makefile.in
index 1ef767350633..1160f5ca1e34 100644
--- a/devel/silc-toolkit/files/patch-Makefile.in
+++ b/devel/silc-toolkit/files/patch-Makefile.in
@@ -1,6 +1,31 @@
---- Makefile.in.orig Fri Nov 9 04:14:03 2001
-+++ Makefile.in Fri Nov 9 04:16:52 2001
-@@ -528,7 +528,8 @@
+--- Makefile.in.orig Tue Oct 23 02:36:24 2001
++++ Makefile.in Fri Nov 9 19:12:35 2001
+@@ -145,9 +145,9 @@
+
+ AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
+
+-COMMONDIRS = lib irssi silc silcd doc includes
+-SUBDIRS = lib irssi silc silcd doc includes win32
+-DIST_SUBDIRS = lib irssi silc silcd doc includes win32
++COMMONDIRS = lib irssi doc includes
++SUBDIRS = lib irssi doc includes win32
++DIST_SUBDIRS = lib irssi doc includes win32
+
+ #
+ # INCLUDE defines
+@@ -511,11 +511,8 @@
+ -rm -rf $(distdir)
+
+ install-dirs:
+- -mkdir -p $(etcdir)
+- -mkdir -p $(modulesdir)
+ -mkdir -p $(helpdir)
+ -mkdir -p $(docdir)
+- -mkdir -p $(logsdir)
+
+ generate-server-key:
+ -@if test '!' -f $(etcdir)/silcd.pub ; then \
+@@ -528,7 +525,8 @@
doc-install:
$(INSTALL_DATA) $(srcdir)/doc/CodingStyle $(docdir)/
$(INSTALL_DATA) $(srcdir)/doc/FAQ $(docdir)/
@@ -10,3 +35,12 @@
$(INSTALL_DATA) $(srcdir)/doc/*.txt $(docdir)/
$(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/
$(INSTALL_DATA) $(srcdir)/CHANGES $(docdir)/
+@@ -548,7 +546,7 @@
+ $(etcdir)/silc.conf; \
+ fi
+
+-install-data-hook: install-dirs generate-server-key sim-install doc-install etc-install
++install-data-hook: install-dirs sim-install doc-install
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/devel/silc-toolkit/files/patch-irssi:Makefile.in b/devel/silc-toolkit/files/patch-irssi:Makefile.in
new file mode 100644
index 000000000000..9506cdec7f7e
--- /dev/null
+++ b/devel/silc-toolkit/files/patch-irssi:Makefile.in
@@ -0,0 +1,11 @@
+--- irssi/Makefile.in.orig Fri Nov 9 18:23:24 2001
++++ irssi/Makefile.in Fri Nov 9 18:25:33 2001
+@@ -486,7 +486,7 @@
+
+ info-am:
+
+-install-data-am: install-confDATA
++install-data-am:
+
+ install-exec-am:
+
diff --git a/devel/silc-toolkit/pkg-plist b/devel/silc-toolkit/pkg-plist
index 4eafb3963e13..dd68b895d3c3 100644
--- a/devel/silc-toolkit/pkg-plist
+++ b/devel/silc-toolkit/pkg-plist
@@ -1,10 +1,3 @@
-bin/silc
-etc/silc/config
-etc/silc/default.theme
-etc/silc/silc.conf
-etc/silc/silcd.conf
-etc/silc/silcd.prv
-etc/silc/silcd.pub
include/silc/aes.h
include/silc/bitmove.h
include/silc/blowfish.h
@@ -75,116 +68,108 @@ include/silc/silcwin32.h
include/silc/twofish.h
include/silc/version.h
include/silc/version_internal.h
-sbin/silcd
-%%PORTDOCS%%share/doc/silc/CHANGES
-%%PORTDOCS%%share/doc/silc/COPYING
-%%PORTDOCS%%share/doc/silc/CREDITS
-%%PORTDOCS%%share/doc/silc/CodingStyle
-%%PORTDOCS%%share/doc/silc/FAQ
-%%PORTDOCS%%share/doc/silc/INSTALL
-%%PORTDOCS%%share/doc/silc/README
-%%PORTDOCS%%share/doc/silc/TODO
-%%PORTDOCS%%share/doc/silc/cell1_backup.conf
-%%PORTDOCS%%share/doc/silc/cell1_router.conf
-%%PORTDOCS%%share/doc/silc/cell1_server1.conf
-%%PORTDOCS%%share/doc/silc/cell1_server2.conf
-%%PORTDOCS%%share/doc/silc/cell2_router.conf
-%%PORTDOCS%%share/doc/silc/cell2_server1.conf
-%%PORTDOCS%%share/doc/silc/cell2_server2.conf
-%%PORTDOCS%%share/doc/silc/cell3_router.conf
-%%PORTDOCS%%share/doc/silc/cell3_server1.conf
-%%PORTDOCS%%share/doc/silc/cell3_server2.conf
-%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-commands-02.txt
-%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-ke-auth-04.txt
-%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-pp-04.txt
-%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-spec-04.txt
-%%PORTDOCS%%share/doc/silc/example_silc.conf
-%%PORTDOCS%%share/doc/silc/example_silcd.conf
-%%PORTDOCS%%share/doc/silc/silcd.prv
-%%PORTDOCS%%share/doc/silc/silcd.pub
-share/silc/help/action
-share/silc/help/admin
-share/silc/help/alias
-share/silc/help/away
-share/silc/help/ban
-share/silc/help/beep
-share/silc/help/bind
-share/silc/help/cat
-share/silc/help/cd
-share/silc/help/channel
-share/silc/help/clear
-share/silc/help/close
-share/silc/help/cmode
-share/silc/help/connect
-share/silc/help/cumode
-share/silc/help/cycle
-share/silc/help/date
-share/silc/help/dehilight
-share/silc/help/disconnect
-share/silc/help/echo
-share/silc/help/eval
-share/silc/help/exec
-share/silc/help/format
-share/silc/help/getkey
-share/silc/help/help
-share/silc/help/hilight
-share/silc/help/ignore
-share/silc/help/info
-share/silc/help/invite
-share/silc/help/join
-share/silc/help/key
-share/silc/help/kick
-share/silc/help/kickban
-share/silc/help/kill
-share/silc/help/knockout
-share/silc/help/lastlog
-share/silc/help/layout
-share/silc/help/levels
-share/silc/help/list
-share/silc/help/load
-share/silc/help/log
-share/silc/help/me
-share/silc/help/motd
-share/silc/help/msg
-share/silc/help/names
-share/silc/help/nick
-share/silc/help/notice
-share/silc/help/oper
-share/silc/help/part
-share/silc/help/ping
-share/silc/help/query
-share/silc/help/quit
-share/silc/help/reconnect
-share/silc/help/reload
-share/silc/help/rmreconns
-share/silc/help/rmrejoins
-share/silc/help/save
-share/silc/help/sconnect
-share/silc/help/scrollback
-share/silc/help/server
-share/silc/help/set
-share/silc/help/shutdown
-share/silc/help/silcoper
-share/silc/help/toggle
-share/silc/help/topic
-share/silc/help/umode
-share/silc/help/unalias
-share/silc/help/unignore
-share/silc/help/unload
-share/silc/help/unquery
-share/silc/help/users
-share/silc/help/version
-share/silc/help/whois
-share/silc/help/whowas
-share/silc/help/window
-@dirrm silc/logs
-@dirrm silc
-@dirrm share/silc/help
-@dirrm share/silc
-@dirrm share/doc/silc
-@dirrm libexec/silc/modules
-@dirrm libexec/silc
+%%PORTDOCS%%share/doc/silc-toolkit/CHANGES
+%%PORTDOCS%%share/doc/silc-toolkit/COPYING
+%%PORTDOCS%%share/doc/silc-toolkit/CREDITS
+%%PORTDOCS%%share/doc/silc-toolkit/CodingStyle
+%%PORTDOCS%%share/doc/silc-toolkit/FAQ
+%%PORTDOCS%%share/doc/silc-toolkit/INSTALL
+%%PORTDOCS%%share/doc/silc-toolkit/README
+%%PORTDOCS%%share/doc/silc-toolkit/TODO
+%%PORTDOCS%%share/doc/silc-toolkit/cell1_backup.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell1_router.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell1_server1.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell1_server2.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell2_router.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell2_server1.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell2_server2.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell3_router.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell3_server1.conf
+%%PORTDOCS%%share/doc/silc-toolkit/cell3_server2.conf
+%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-commands-02.txt
+%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-ke-auth-04.txt
+%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-pp-04.txt
+%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-spec-04.txt
+%%PORTDOCS%%share/doc/silc-toolkit/example_silc.conf
+%%PORTDOCS%%share/doc/silc-toolkit/example_silcd.conf
+%%PORTDOCS%%share/doc/silc-toolkit/silcd.prv
+%%PORTDOCS%%share/doc/silc-toolkit/silcd.pub
+share/silc-toolkit/help/action
+share/silc-toolkit/help/admin
+share/silc-toolkit/help/alias
+share/silc-toolkit/help/away
+share/silc-toolkit/help/ban
+share/silc-toolkit/help/beep
+share/silc-toolkit/help/bind
+share/silc-toolkit/help/cat
+share/silc-toolkit/help/cd
+share/silc-toolkit/help/channel
+share/silc-toolkit/help/clear
+share/silc-toolkit/help/close
+share/silc-toolkit/help/cmode
+share/silc-toolkit/help/connect
+share/silc-toolkit/help/cumode
+share/silc-toolkit/help/cycle
+share/silc-toolkit/help/date
+share/silc-toolkit/help/dehilight
+share/silc-toolkit/help/disconnect
+share/silc-toolkit/help/echo
+share/silc-toolkit/help/eval
+share/silc-toolkit/help/exec
+share/silc-toolkit/help/format
+share/silc-toolkit/help/getkey
+share/silc-toolkit/help/help
+share/silc-toolkit/help/hilight
+share/silc-toolkit/help/ignore
+share/silc-toolkit/help/info
+share/silc-toolkit/help/invite
+share/silc-toolkit/help/join
+share/silc-toolkit/help/key
+share/silc-toolkit/help/kick
+share/silc-toolkit/help/kickban
+share/silc-toolkit/help/kill
+share/silc-toolkit/help/knockout
+share/silc-toolkit/help/lastlog
+share/silc-toolkit/help/layout
+share/silc-toolkit/help/levels
+share/silc-toolkit/help/list
+share/silc-toolkit/help/load
+share/silc-toolkit/help/log
+share/silc-toolkit/help/me
+share/silc-toolkit/help/motd
+share/silc-toolkit/help/msg
+share/silc-toolkit/help/names
+share/silc-toolkit/help/nick
+share/silc-toolkit/help/notice
+share/silc-toolkit/help/oper
+share/silc-toolkit/help/part
+share/silc-toolkit/help/ping
+share/silc-toolkit/help/query
+share/silc-toolkit/help/quit
+share/silc-toolkit/help/reconnect
+share/silc-toolkit/help/reload
+share/silc-toolkit/help/rmreconns
+share/silc-toolkit/help/rmrejoins
+share/silc-toolkit/help/save
+share/silc-toolkit/help/sconnect
+share/silc-toolkit/help/scrollback
+share/silc-toolkit/help/server
+share/silc-toolkit/help/set
+share/silc-toolkit/help/shutdown
+share/silc-toolkit/help/silcoper
+share/silc-toolkit/help/toggle
+share/silc-toolkit/help/topic
+share/silc-toolkit/help/umode
+share/silc-toolkit/help/unalias
+share/silc-toolkit/help/unignore
+share/silc-toolkit/help/unload
+share/silc-toolkit/help/unquery
+share/silc-toolkit/help/users
+share/silc-toolkit/help/version
+share/silc-toolkit/help/whois
+share/silc-toolkit/help/whowas
+share/silc-toolkit/help/window
+@dirrm share/silc-toolkit/help
+@dirrm share/silc-toolkit
+%%PORTDOCS%%@dirrm share/doc/silc-toolkit
@dirrm include/silc
-@dirrm etc/silc
-@exec %%INSTALL_DIR%% %D/libexec/silc/modules
-@exec %%INSTALL_DIR%% %D/silc/logs