aboutsummaryrefslogtreecommitdiff
path: root/devel/silc-toolkit
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:52:04 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:52:04 +0000
commit869a5a1d08d4977d7f1c85e2f401784e2a0604ee (patch)
tree4b66ee2eab12af0643acd3b366a7cd44bd704c59 /devel/silc-toolkit
parent71c77b1076c4591849619fc5fd1764954cbb5628 (diff)
downloadports-869a5a1d08d4977d7f1c85e2f401784e2a0604ee.tar.gz
ports-869a5a1d08d4977d7f1c85e2f401784e2a0604ee.zip
Notes
Diffstat (limited to 'devel/silc-toolkit')
-rw-r--r--devel/silc-toolkit/Makefile72
-rw-r--r--devel/silc-toolkit/distinfo1
-rw-r--r--devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs40
-rw-r--r--devel/silc-toolkit/files/patch-Makefile.in12
-rw-r--r--devel/silc-toolkit/files/patch-configure11
-rw-r--r--devel/silc-toolkit/files/patch-lib:Makefile.in20
-rw-r--r--devel/silc-toolkit/pkg-comment1
-rw-r--r--devel/silc-toolkit/pkg-descr17
-rw-r--r--devel/silc-toolkit/pkg-plist190
9 files changed, 364 insertions, 0 deletions
diff --git a/devel/silc-toolkit/Makefile b/devel/silc-toolkit/Makefile
new file mode 100644
index 000000000000..ce06bcca11ff
--- /dev/null
+++ b/devel/silc-toolkit/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: silc toolkit
+# Date created: Thu Nov 8 01:50:05 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silc
+PORTVERSION= 0.6.1
+CATEGORIES= devel net security
+MASTER_SITES= http://www.silcnet.org/download/ \
+ ftp://ftp.silcnet.org/pub/silc/
+PKGNAMESUFFIX= -toolkit
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS= dotconf.0:${PORTSDIR}/devel/dotconf
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GLIB= yes
+CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME} \
+ --with-docdir=share/doc/${PORTNAME} \
+ --with-etcdir=${PREFIX}/etc/${PORTNAME} \
+ --with-helpdir=share/${PORTNAME}/help \
+ --with-logsdir=${PORTNAME}/logs \
+ --with-simdir=libexec/${PORTNAME}/modules \
+ --includedir=${PREFIX}/include/${PORTNAME}
+PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
+
+INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
+
+.ifdef(NOPORTDOCS)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in-noportdocs
+.endif
+
+.ifdef(WITHOUT_OPTIMIZED_ASM)
+CONFIGURE_ARGS+= --disable-asm
+.endif
+
+.ifndef(WITH_PTHREADS)
+CONFIGURE_ARGS+= --disable-threads
+.else
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
+.endif
+
+pre-everything::
+.ifndef(WITHOUT_OPTIMIZED_ASM)
+ @${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
+.endif
+.ifndef(WITH_PTHREADS)
+ @${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
+.endif
+
+# ugly, ugly hack; for some reason (configure reason), this ports
+# breaks if CONFIGURE_TARGET is given as an argument
+do-configure:
+ @cd ${CONFIGURE_WRKSRC}; ${SETENV} ${CONFIGURE_ENV} \
+ ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS:S/${CONFIGURE_TARGET}//} \
+ --host=${CONFIGURE_TARGET}
+
+pre-install:
+ @${RM} -Rf ${WRKSRC}/doc/examples/CVS
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_OPTIMIZED_ASM= yes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/silc-toolkit/distinfo b/devel/silc-toolkit/distinfo
new file mode 100644
index 000000000000..3280e2155785
--- /dev/null
+++ b/devel/silc-toolkit/distinfo
@@ -0,0 +1 @@
+MD5 (silc-toolkit-0.6.1.tar.bz2) = a0c9cae418be63f75d9c290de6dc48d5
diff --git a/devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs b/devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs
new file mode 100644
index 000000000000..0d20ebd144bc
--- /dev/null
+++ b/devel/silc-toolkit/files/extra-patch-Makefile.in-noportdocs
@@ -0,0 +1,40 @@
+--- Makefile.in.orig Fri Nov 9 04:24:09 2001
++++ Makefile.in Fri Nov 9 04:24:45 2001
+@@ -145,9 +145,9 @@
+
+ AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
+
+-COMMONDIRS = lib irssi silc silcd doc includes
+-SUBDIRS = lib irssi silc silcd doc includes win32
+-DIST_SUBDIRS = lib irssi silc silcd doc includes win32
++COMMONDIRS = lib irssi silc silcd includes
++SUBDIRS = lib irssi silc silcd includes win32
++DIST_SUBDIRS = lib irssi silc silcd includes win32
+
+ #
+ # INCLUDE defines
+@@ -166,7 +166,6 @@
+ -I$(silc_top_srcdir)/lib/silcclient \
+ -I$(silc_top_srcdir)/lib/contrib \
+ -I$(silc_top_srcdir)/includes \
+- -I$(silc_top_srcdir)/doc \
+ -I$(silc_top_srcdir)/lib/trq
+
+
+@@ -514,7 +513,6 @@
+ -mkdir -p $(etcdir)
+ -mkdir -p $(modulesdir)
+ -mkdir -p $(helpdir)
+- -mkdir -p $(docdir)
+ -mkdir -p $(logsdir)
+
+ generate-server-key:
+@@ -549,7 +547,7 @@
+ $(etcdir)/silc.conf; \
+ fi
+
+-install-data-hook: install-dirs generate-server-key sim-install doc-install etc-install
++install-data-hook: install-dirs generate-server-key sim-install etc-install
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/devel/silc-toolkit/files/patch-Makefile.in b/devel/silc-toolkit/files/patch-Makefile.in
new file mode 100644
index 000000000000..1ef767350633
--- /dev/null
+++ b/devel/silc-toolkit/files/patch-Makefile.in
@@ -0,0 +1,12 @@
+--- Makefile.in.orig Fri Nov 9 04:14:03 2001
++++ Makefile.in Fri Nov 9 04:16:52 2001
+@@ -528,7 +528,8 @@
+ doc-install:
+ $(INSTALL_DATA) $(srcdir)/doc/CodingStyle $(docdir)/
+ $(INSTALL_DATA) $(srcdir)/doc/FAQ $(docdir)/
+- $(INSTALL_DATA) $(srcdir)/doc/example* $(docdir)/
++ $(INSTALL_DATA) $(srcdir)/doc/examples/* $(docdir)/
++ $(INSTALL_DATA) $(srcdir)/doc/example*.conf $(docdir)/
+ $(INSTALL_DATA) $(srcdir)/doc/*.txt $(docdir)/
+ $(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/
+ $(INSTALL_DATA) $(srcdir)/CHANGES $(docdir)/
diff --git a/devel/silc-toolkit/files/patch-configure b/devel/silc-toolkit/files/patch-configure
new file mode 100644
index 000000000000..ad444ce8c461
--- /dev/null
+++ b/devel/silc-toolkit/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Nov 9 04:02:27 2001
++++ configure Fri Nov 9 04:02:43 2001
+@@ -8472,7 +8472,7 @@
+ fi
+ ;;
+ *-freebsd2.2*)
+- CFLAGS="$CFLAGS -D_THREAD_SAFE"
++ CFLAGS="$CFLAGS"
+ ;;
+ *-sysv5uw7*) # UnixWare 7
+ if test "$GCC" != "yes"; then
diff --git a/devel/silc-toolkit/files/patch-lib:Makefile.in b/devel/silc-toolkit/files/patch-lib:Makefile.in
new file mode 100644
index 000000000000..acb3f48d5723
--- /dev/null
+++ b/devel/silc-toolkit/files/patch-lib:Makefile.in
@@ -0,0 +1,20 @@
+--- lib/Makefile.in.orig Fri Nov 9 01:18:20 2001
++++ lib/Makefile.in Fri Nov 9 01:18:29 2001
+@@ -116,7 +116,6 @@
+ silcutil \
+ silcclient \
+ silcsftp \
+- dotconf \
+ trq
+
+
+@@ -134,8 +133,7 @@
+ silcske \
+ silcutil \
+ silcsftp \
+- trq \
+- dotconf
++ trq
+
+
+ # SILC Client Library dirs
diff --git a/devel/silc-toolkit/pkg-comment b/devel/silc-toolkit/pkg-comment
new file mode 100644
index 000000000000..8b3ecf87704d
--- /dev/null
+++ b/devel/silc-toolkit/pkg-comment
@@ -0,0 +1 @@
+Secure Internet Live Conferencing (SILC) development toolkit
diff --git a/devel/silc-toolkit/pkg-descr b/devel/silc-toolkit/pkg-descr
new file mode 100644
index 000000000000..64c0da921542
--- /dev/null
+++ b/devel/silc-toolkit/pkg-descr
@@ -0,0 +1,17 @@
+[ from developer's site FAQ ]
+
+This is a SILC development toolkit
+
+Q: What is SILC?
+
+A: SILC (Secure Internet Live Conferencing) is a protocol which
+provides secure conferencing services in the Internet over insecure
+channel. SILC is IRC like although internally they are very different.
+Biggest similarity between SILC and IRC is that they both provide
+conferencing services and that SILC has almost same commands as
+IRC. Other than that they are nothing alike.
+
+Biggest differences are that SILC is secure what IRC is not in any
+way. The network model is also entirely different compared to IRC.
+
+WWW: http://www.silcnet.org/
diff --git a/devel/silc-toolkit/pkg-plist b/devel/silc-toolkit/pkg-plist
new file mode 100644
index 000000000000..4eafb3963e13
--- /dev/null
+++ b/devel/silc-toolkit/pkg-plist
@@ -0,0 +1,190 @@
+bin/silc
+etc/silc/config
+etc/silc/default.theme
+etc/silc/silc.conf
+etc/silc/silcd.conf
+etc/silc/silcd.prv
+etc/silc/silcd.pub
+include/silc/aes.h
+include/silc/bitmove.h
+include/silc/blowfish.h
+include/silc/cast.h
+include/silc/ciphers.h
+include/silc/ciphers_def.h
+include/silc/client.h
+include/silc/clientlibincludes.h
+include/silc/command.h
+include/silc/command_reply.h
+include/silc/groups.h
+include/silc/idlist.h
+include/silc/mars.h
+include/silc/md5.h
+include/silc/mp_gmp.h
+include/silc/mp_mpi.h
+include/silc/mpi.h
+include/silc/mplogic.h
+include/silc/mpprime.h
+include/silc/none.h
+include/silc/payload.h
+include/silc/pkcs1.h
+include/silc/protocol.h
+include/silc/rc5.h
+include/silc/rc6.h
+include/silc/rsa.h
+include/silc/sha1.h
+include/silc/silcapi.h
+include/silc/silcauth.h
+include/silc/silcbuffer.h
+include/silc/silcbuffmt.h
+include/silc/silcbufutil.h
+include/silc/silcchannel.h
+include/silc/silccipher.h
+include/silc/silccommand.h
+include/silc/silcconfig.h
+include/silc/silcdh.h
+include/silc/silchash.h
+include/silc/silchashtable.h
+include/silc/silchmac.h
+include/silc/silcid.h
+include/silc/silcidcache.h
+include/silc/silcincludes.h
+include/silc/silclog.h
+include/silc/silcmath.h
+include/silc/silcmemory.h
+include/silc/silcmode.h
+include/silc/silcmp.h
+include/silc/silcmutex.h
+include/silc/silcnet.h
+include/silc/silcnotify.h
+include/silc/silcpacket.h
+include/silc/silcpayload.h
+include/silc/silcpkcs.h
+include/silc/silcprivate.h
+include/silc/silcprotocol.h
+include/silc/silcrng.h
+include/silc/silcschedule.h
+include/silc/silcsftp.h
+include/silc/silcsim.h
+include/silc/silcsimutil.h
+include/silc/silcske.h
+include/silc/silcske_status.h
+include/silc/silcsockconn.h
+include/silc/silcthread.h
+include/silc/silcutil.h
+include/silc/silcwin32.h
+include/silc/twofish.h
+include/silc/version.h
+include/silc/version_internal.h
+sbin/silcd
+%%PORTDOCS%%share/doc/silc/CHANGES
+%%PORTDOCS%%share/doc/silc/COPYING
+%%PORTDOCS%%share/doc/silc/CREDITS
+%%PORTDOCS%%share/doc/silc/CodingStyle
+%%PORTDOCS%%share/doc/silc/FAQ
+%%PORTDOCS%%share/doc/silc/INSTALL
+%%PORTDOCS%%share/doc/silc/README
+%%PORTDOCS%%share/doc/silc/TODO
+%%PORTDOCS%%share/doc/silc/cell1_backup.conf
+%%PORTDOCS%%share/doc/silc/cell1_router.conf
+%%PORTDOCS%%share/doc/silc/cell1_server1.conf
+%%PORTDOCS%%share/doc/silc/cell1_server2.conf
+%%PORTDOCS%%share/doc/silc/cell2_router.conf
+%%PORTDOCS%%share/doc/silc/cell2_server1.conf
+%%PORTDOCS%%share/doc/silc/cell2_server2.conf
+%%PORTDOCS%%share/doc/silc/cell3_router.conf
+%%PORTDOCS%%share/doc/silc/cell3_server1.conf
+%%PORTDOCS%%share/doc/silc/cell3_server2.conf
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-commands-02.txt
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-ke-auth-04.txt
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-pp-04.txt
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-spec-04.txt
+%%PORTDOCS%%share/doc/silc/example_silc.conf
+%%PORTDOCS%%share/doc/silc/example_silcd.conf
+%%PORTDOCS%%share/doc/silc/silcd.prv
+%%PORTDOCS%%share/doc/silc/silcd.pub
+share/silc/help/action
+share/silc/help/admin
+share/silc/help/alias
+share/silc/help/away
+share/silc/help/ban
+share/silc/help/beep
+share/silc/help/bind
+share/silc/help/cat
+share/silc/help/cd
+share/silc/help/channel
+share/silc/help/clear
+share/silc/help/close
+share/silc/help/cmode
+share/silc/help/connect
+share/silc/help/cumode
+share/silc/help/cycle
+share/silc/help/date
+share/silc/help/dehilight
+share/silc/help/disconnect
+share/silc/help/echo
+share/silc/help/eval
+share/silc/help/exec
+share/silc/help/format
+share/silc/help/getkey
+share/silc/help/help
+share/silc/help/hilight
+share/silc/help/ignore
+share/silc/help/info
+share/silc/help/invite
+share/silc/help/join
+share/silc/help/key
+share/silc/help/kick
+share/silc/help/kickban
+share/silc/help/kill
+share/silc/help/knockout
+share/silc/help/lastlog
+share/silc/help/layout
+share/silc/help/levels
+share/silc/help/list
+share/silc/help/load
+share/silc/help/log
+share/silc/help/me
+share/silc/help/motd
+share/silc/help/msg
+share/silc/help/names
+share/silc/help/nick
+share/silc/help/notice
+share/silc/help/oper
+share/silc/help/part
+share/silc/help/ping
+share/silc/help/query
+share/silc/help/quit
+share/silc/help/reconnect
+share/silc/help/reload
+share/silc/help/rmreconns
+share/silc/help/rmrejoins
+share/silc/help/save
+share/silc/help/sconnect
+share/silc/help/scrollback
+share/silc/help/server
+share/silc/help/set
+share/silc/help/shutdown
+share/silc/help/silcoper
+share/silc/help/toggle
+share/silc/help/topic
+share/silc/help/umode
+share/silc/help/unalias
+share/silc/help/unignore
+share/silc/help/unload
+share/silc/help/unquery
+share/silc/help/users
+share/silc/help/version
+share/silc/help/whois
+share/silc/help/whowas
+share/silc/help/window
+@dirrm silc/logs
+@dirrm silc
+@dirrm share/silc/help
+@dirrm share/silc
+@dirrm share/doc/silc
+@dirrm libexec/silc/modules
+@dirrm libexec/silc
+@dirrm include/silc
+@dirrm etc/silc
+@exec %%INSTALL_DIR%% %D/libexec/silc/modules
+@exec %%INSTALL_DIR%% %D/silc/logs