aboutsummaryrefslogtreecommitdiff
path: root/devel/simgear/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-18 23:05:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-18 23:05:36 +0000
commitd4fb3a868c8b4a4cb65806050f6b25b66678feba (patch)
tree2d75496377ee6b31fb26953161553b4c87457afc /devel/simgear/Makefile
parent79c6b3c0419b30bc5ed4d8008be7436b073bdff6 (diff)
Notes
Diffstat (limited to 'devel/simgear/Makefile')
-rw-r--r--devel/simgear/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index f1e710ffe67a..a4b5991f6fe0 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -19,9 +19,14 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
jpeg.9:${PORTSDIR}/graphics/jpeg \
alut.1:${PORTSDIR}/audio/freealut \
- osg.48:${PORTSDIR}/graphics/osg \
boost_thread.4:${PORTSDIR}/devel/boost
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
GNU_CONFIGURE= yes