aboutsummaryrefslogtreecommitdiff
path: root/devel/simgear/Makefile
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2017-07-23 20:19:59 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2017-07-23 20:19:59 +0000
commit3eaac613283a967b0ae5ae66bd06bbe66ca51b60 (patch)
treee59eecf4fded8e3a8132f49bac1686031c0a571e /devel/simgear/Makefile
parent8e9d970890134841ae3bf1b74ebf886f0a8353be (diff)
Notes
Diffstat (limited to 'devel/simgear/Makefile')
-rw-r--r--devel/simgear/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 950a3094ac39..77c6624a5004 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -2,7 +2,7 @@
PORTNAME= simgear
PORTVERSION= 2017.1.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
@@ -16,17 +16,15 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libosg.so:graphics/osg
-BROKEN_powerpc64= fails to compile: Package.cxx: 'to_string' is not a member of 'std
-
USE_XORG= ice sm x11 xext xi xmu xt
USE_GL= gl glu glut
-USES= alias cmake compiler cpe jpeg openal:al,alut tar:bzip2
+USES= alias cmake compiler:c++11-lib cpe jpeg openal:al,alut tar:bzip2
.include <bsd.port.pre.mk>
-# When building with Gcc, needs Gcc 4.6+
-.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 46
-USE_GCC= yes
+# Work around "'to_string' is not a member of 'std'" when building with Gcc < 6
+.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 60
+CFLAGS+= -D_GLIBCXX_USE_C99
.endif
.include <bsd.port.post.mk>