aboutsummaryrefslogtreecommitdiff
path: root/devel/simgear
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-11-09 18:12:54 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-11-09 18:12:54 +0000
commitc0c4da186a007e90ce1346e18d0beafaf5d930e1 (patch)
tree7ea79ef629e628e1141027f1d792057eb143b18a /devel/simgear
parentd8875adc9c12363cb87999d673a462db7501b5cf (diff)
downloadports-c0c4da186a007e90ce1346e18d0beafaf5d930e1.tar.gz
ports-c0c4da186a007e90ce1346e18d0beafaf5d930e1.zip
Notes
Diffstat (limited to 'devel/simgear')
-rw-r--r--devel/simgear/Makefile15
-rw-r--r--devel/simgear/distinfo4
-rw-r--r--devel/simgear/files/patch-ab4
-rw-r--r--devel/simgear/files/patch-simgear::scene::sky::cloud.cxx13
-rw-r--r--devel/simgear/files/patch-simgear::screen::extensions.cxx11
-rw-r--r--devel/simgear/pkg-plist7
6 files changed, 27 insertions, 27 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index eef737e2f8f2..8088eba4c2da 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= SimGear
-PORTVERSION= 0.3.5
+PORTVERSION= 0.3.7
CATEGORIES= devel games
MASTER_SITES= ftp://ftp.simgear.org/pub/simgear/Source/ \
ftp://ftp.de.flightgear.org/pub/simgear/Source/
@@ -20,15 +20,14 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libmk4.so:${PORTSDIR}/databases/metakit \
${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= ${LOCALBASE}/lib/libmk4.so:${PORTSDIR}/databases/metakit \
${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal
USE_X_PREFIX= yes
USE_GL= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}" \
+ CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Internal compiler error in gcc"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index 2fc7e89c7be0..e7a708431360 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,2 +1,2 @@
-MD5 (SimGear-0.3.5.tar.gz) = 24e87739c63c125a7c2c55836a27b121
-SIZE (SimGear-0.3.5.tar.gz) = 897193
+MD5 (SimGear-0.3.7.tar.gz) = d920855efb6ed72f97dad4b76914bfa8
+SIZE (SimGear-0.3.7.tar.gz) = 990939
diff --git a/devel/simgear/files/patch-ab b/devel/simgear/files/patch-ab
index 441d35fef2cc..2e9ac18fdfe5 100644
--- a/devel/simgear/files/patch-ab
+++ b/devel/simgear/files/patch-ab
@@ -6,8 +6,8 @@
-echo "$as_me:$LINENO: checking for pthread_exit in -lpthread" >&5
-echo $ECHO_N "checking for pthread_exit in -lpthread... $ECHO_C" >&6
-+echo "$as_me:$LINENO: checking for pthread_exit in -pthread" >&5
-+echo $ECHO_N "checking for pthread_exit in -pthread... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for pthread_exit in ${PTHREAD_LIBS}" >&5
++echo $ECHO_N "checking for pthread_exit in ${PTHREAD_LIBS}... $ECHO_C" >&6
if test "${ac_cv_lib_pthread_pthread_exit+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
diff --git a/devel/simgear/files/patch-simgear::scene::sky::cloud.cxx b/devel/simgear/files/patch-simgear::scene::sky::cloud.cxx
deleted file mode 100644
index 48c591568ec6..000000000000
--- a/devel/simgear/files/patch-simgear::scene::sky::cloud.cxx
+++ /dev/null
@@ -1,13 +0,0 @@
---- simgear/scene/sky/cloud.cxx.orig Tue Jun 1 10:38:58 2004
-+++ simgear/scene/sky/cloud.cxx Tue Jun 1 10:39:08 2004
-@@ -24,8 +24,8 @@
- // #if defined (__APPLE__)
- // // any C++ header file undefines isinf and isnan
- // // so this should be included before <iostream>
--// inline int (isinf)(double r) { return isinf(r); }
--// inline int (isnan)(double r) { return isnan(r); }
-+inline int (isinf)(double r) { return isinf(r); }
-+inline int (isnan)(double r) { return isnan(r); }
- // #endif
-
- // #include STL_IOSTREAM
diff --git a/devel/simgear/files/patch-simgear::screen::extensions.cxx b/devel/simgear/files/patch-simgear::screen::extensions.cxx
new file mode 100644
index 000000000000..488fa5cfca30
--- /dev/null
+++ b/devel/simgear/files/patch-simgear::screen::extensions.cxx
@@ -0,0 +1,11 @@
+--- simgear/screen/extensions.cxx.orig Tue Nov 9 13:31:54 2004
++++ simgear/screen/extensions.cxx Tue Nov 9 13:32:10 2004
+@@ -113,7 +113,7 @@
+ if (libHandle != NULL) {
+ fptr = dlsym(libHandle, func);
+
+- char *error = dlerror();
++ const char *error = dlerror();
+ if (error)
+ SG_LOG(SG_GENERAL, SG_INFO, error);
+ }
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index 55e1892e15e8..ce5134bd5bc1 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -53,9 +53,11 @@ include/simgear/scene/material/mat.hxx
include/simgear/scene/material/matlib.hxx
include/simgear/scene/material/matmodel.hxx
include/simgear/scene/model/animation.hxx
+include/simgear/scene/model/custtrans.hxx
include/simgear/scene/model/location.hxx
include/simgear/scene/model/model.hxx
include/simgear/scene/model/modellib.hxx
+include/simgear/scene/model/personality.hxx
include/simgear/scene/model/placement.hxx
include/simgear/scene/sky/cloud.hxx
include/simgear/scene/sky/clouds3d/SkySceneLoader.hpp
@@ -80,8 +82,9 @@ include/simgear/screen/tr.h
include/simgear/serial/serial.hxx
include/simgear/sg_inlines.h
include/simgear/sg_traits.hxx
-include/simgear/sound/sound.hxx
-include/simgear/sound/soundmgr.hxx
+include/simgear/sound/sample_openal.hxx
+include/simgear/sound/soundmgr_openal.hxx
+include/simgear/sound/xmlsound.hxx
include/simgear/structure/callback.hxx
include/simgear/structure/commands.hxx
include/simgear/structure/event_mgr.hxx