aboutsummaryrefslogtreecommitdiff
path: root/devel/spdict/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-08-02 15:04:29 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-08-02 15:04:29 +0000
commitd9f7aa19f9705823f43abb7bdf96bb1cc90dc145 (patch)
treeab98f155501d22c8330aa18965314454ddc4f62a /devel/spdict/Makefile
parent8478dff0b27784c0ab26c1d08807e9658ae3ea53 (diff)
Notes
Diffstat (limited to 'devel/spdict/Makefile')
-rw-r--r--devel/spdict/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/spdict/Makefile b/devel/spdict/Makefile
new file mode 100644
index 000000000000..0b5654fce992
--- /dev/null
+++ b/devel/spdict/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: spdict
+# Date created: 2 Aug 2007
+# Whom: vanilla@
+#
+# $FreeBSD$
+#
+
+PORTNAME= spdict
+PORTVERSION= 0.2
+CATEGORIES= devel
+MASTER_SITES= http://spdict.googlecode.com/files/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= A library of dictionary algorithms
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/spdict
+ @${INSTALL} ${WRKSRC}/*.hpp ${PREFIX}/include/spdict
+ @${INSTALL} ${WRKSRC}/libspdict.so ${PREFIX}/lib/libspdict.so.1
+ @${LN} -s ${PREFIX}/lib/libspdict.so.1 ${PREFIX}/lib/libspdict.so
+
+.include <bsd.port.mk>