aboutsummaryrefslogtreecommitdiff
path: root/devel/spin/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-02 23:42:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-02 23:42:50 +0000
commit4206955eff351c229a7e4d0ad6540b1300584466 (patch)
treea6ba067b5386954281d9153667d456afd07c7420 /devel/spin/Makefile
parente49e8a78d5fe1b0a5be3d3e2aeac30742682c4ef (diff)
downloadports-4206955eff351c229a7e4d0ad6540b1300584466.tar.gz
ports-4206955eff351c229a7e4d0ad6540b1300584466.zip
Notes
Diffstat (limited to 'devel/spin/Makefile')
-rw-r--r--devel/spin/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index 50a02281e039..f9a8654af9cb 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= spin
-PORTVERSION= 4.1.3
-PORTREVISION= 0
+PORTVERSION= 4.2.0
CATEGORIES= devel
MASTER_SITES= http://spinroot.com/spin/Src/
DISTNAME= spin${PORTVERSION:S/.//g}
@@ -40,23 +39,23 @@ post-extract:
@cd ${WRKDIR}/Test && ${SH} ${WRKDIR}/Test/examples
pre-patch:
- ${TR} -d '\015' < ${WRKDIR}/Xspin4.1/xspin413.tcl \
- > ${WRKDIR}/Xspin4.1/xspin413.tcl.tmp
- ${MV} -f ${WRKDIR}/Xspin4.1/xspin413.tcl.tmp \
- ${WRKDIR}/Xspin4.1/xspin413.tcl
+ ${TR} -d '\015' < ${WRKDIR}/Xspin4.2/xspin420.tcl \
+ > ${WRKDIR}/Xspin4.2/xspin420.tcl.tmp
+ ${MV} -f ${WRKDIR}/Xspin4.2/xspin420.tcl.tmp \
+ ${WRKDIR}/Xspin4.2/xspin420.tcl
post-patch:
@WISH=`(cd ${LOCALBASE}/bin ; ${LS} wish8* ) | tail -1` ; \
if [ -z "$$WISH" ] ; then WISH=wish8.0 ; fi ; \
${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g;" \
- -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin4.1/xspin413.tcl
+ -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin4.2/xspin420.tcl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spin ${PREFIX}/bin
.if !defined(WITHOUT_XSPIN)
${RM} -f ${PREFIX}/bin/xspin
- ${INSTALL_SCRIPT} ${WRKDIR}/Xspin4.1/xspin413.tcl ${PREFIX}/bin/xspin
+ ${INSTALL_SCRIPT} ${WRKDIR}/Xspin4.2/xspin420.tcl ${PREFIX}/bin/xspin
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/Doc