aboutsummaryrefslogtreecommitdiff
path: root/devel/spin
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-10-16 21:50:47 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-10-16 21:50:47 +0000
commitad4701a41f48b1553cca97a10e0c15bc9a7f7693 (patch)
tree80dea4aeade1f7581544a17d1512607ed47558c4 /devel/spin
parent3fefc55b8d6b2eaded3213f75a655207adc854fc (diff)
downloadports-ad4701a41f48b1553cca97a10e0c15bc9a7f7693.tar.gz
ports-ad4701a41f48b1553cca97a10e0c15bc9a7f7693.zip
Notes
Diffstat (limited to 'devel/spin')
-rw-r--r--devel/spin/Makefile18
-rw-r--r--devel/spin/distinfo2
-rw-r--r--devel/spin/files/patch-aa18
-rw-r--r--devel/spin/files/patch-ab10
-rw-r--r--devel/spin/pkg-plist2
5 files changed, 31 insertions, 19 deletions
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index 6225d581e21e..8c30acba9c7b 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -6,18 +6,20 @@
#
PORTNAME= spin
-PORTVERSION= 3.4.14
+PORTVERSION= 3.5.0
CATEGORIES= devel
-MASTER_SITES= ftp://netlib.bell-labs.com/netlib/spin/ \
+MASTER_SITES= http://spinroot.com/spin/Src/ \
+ ftp://netlib.bell-labs.com/netlib/spin/ \
ftp://www.netlib.org/spin/
DISTFILES= spin${PORTVERSION:S/.//g}.tar.gz html.tar.gz
-MAINTAINER= jhanna@home.com
+MAINTAINER= jhanna@shaw.ca
DIST_SUBDIR= spin
-WRKSRC= ${WRKDIR}/Src3.4
+WRKSRC= ${WRKDIR}/Src3.5.0
MAKEFILE= makefile
ALL_TARGET= spin
+USE_REINPLACE= yes
post-extract:
@cd ${WRKDIR}/Test && ${SH} ${WRKDIR}/Test/examples
@@ -25,18 +27,18 @@ post-extract:
post-patch:
@WISH=`(cd ${LOCALBASE}/bin ; ls wish8* ) | tail -1` ; \
if [ -z "$$WISH" ] ; then WISH=wish8.0 ; fi ; \
- ${PERL} -pi \
+ ${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g;" \
- -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin3.4/xspin347.tcl
+ -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin3.5/xspin350.tcl
pre-build:
cd ${WRKSRC} && ${MAKE} clean
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spin ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKDIR}/Xspin3.4/xspin347.tcl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/Xspin3.5/xspin350.tcl ${PREFIX}/bin
${RM} -f ${PREFIX}/bin/xspin
- ${LN} -s ${PREFIX}/bin/xspin347.tcl ${PREFIX}/bin/xspin
+ ${LN} -s ${PREFIX}/bin/xspin350.tcl ${PREFIX}/bin/xspin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/spin/Doc
diff --git a/devel/spin/distinfo b/devel/spin/distinfo
index d479764de80e..721bb82efff2 100644
--- a/devel/spin/distinfo
+++ b/devel/spin/distinfo
@@ -1,2 +1,2 @@
-MD5 (spin/spin3414.tar.gz) = 83b6a9c75dd2390a7ddcc882d962e03d
+MD5 (spin/spin350.tar.gz) = 210e40c253624cac89529136a34108af
MD5 (spin/html.tar.gz) = 18fb3308fac90091de71235941fbdc20
diff --git a/devel/spin/files/patch-aa b/devel/spin/files/patch-aa
index adb09268abf3..e6efd7112681 100644
--- a/devel/spin/files/patch-aa
+++ b/devel/spin/files/patch-aa
@@ -1,7 +1,17 @@
---- ../Xspin3.4/xspin347.tcl.orig Wed Jun 23 18:29:29 1999
-+++ ../Xspin3.4/xspin347.tcl Wed Jun 23 18:30:51 1999
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/wish -f
+--- ../Xspin3.5/xspin350.tcl.orig Sun Sep 29 07:55:34 2002
++++ ../Xspin3.5/xspin350.tcl Sun Oct 6 18:33:12 2002
+@@ -1,14 +1,4 @@
+-#!/bin/sh
+-# the next line restarts using wish \
+-exec wish c:/cygwin/bin/xspin -- $*
+-
+-# adjust the first argument to wish above with the
+-# location of xspin on your system, if different.
+-#
+-# cygwin: even when xspin is placed in /usr/bin/xspin
+-# the above exec line would not find it there
+-# /usr/bin is a symbolic link to /bin, which really
+-# lives in c:/cygwin, hence the contortions above
+#!%%LOCALBASE%%/bin/%%WISH%% -f
#======================================================================#
diff --git a/devel/spin/files/patch-ab b/devel/spin/files/patch-ab
index a50e73daae58..0a9eb5915da3 100644
--- a/devel/spin/files/patch-ab
+++ b/devel/spin/files/patch-ab
@@ -1,12 +1,12 @@
---- makefile.orig Wed Feb 20 13:40:54 2002
-+++ makefile Sun Apr 7 17:44:50 2002
+--- makefile.orig Sun Sep 29 08:47:34 2002
++++ makefile Sun Oct 6 18:24:09 2002
@@ -11,8 +11,9 @@
# The book is available frm www.amazon.com
- # CC=cc -g # or any other ansi compatible c compiler
--CC=cc -g -DNXT # if you need the X operator in LTL
+ # CC=cc -g # or any other ansi compatible c compiler
+-CC=cc -g -DNXT # enables the X operator in LTL
-CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
-+# CC=cc -g -DNXT # if you need the X operator in LTL
++# CC=cc -g -DNXT # enables the X operator in LTL
+# CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
+CFLAGS += -DNXT
diff --git a/devel/spin/pkg-plist b/devel/spin/pkg-plist
index ebd956248f86..6532c26aefeb 100644
--- a/devel/spin/pkg-plist
+++ b/devel/spin/pkg-plist
@@ -1,6 +1,6 @@
bin/spin
bin/xspin
-bin/xspin347.tcl
+bin/xspin350.tcl
share/doc/spin/Doc/Book.Ch6.add
share/doc/spin/Doc/Book.Errata
share/doc/spin/Doc/Book.answers