aboutsummaryrefslogtreecommitdiff
path: root/devel/spin
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-03-08 18:50:38 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-03-08 18:50:38 +0000
commit3a1bc7d42491b753157b464e9a4e7133451cb5fa (patch)
tree6ea332ffa5a8cb98a97b69fa9d936b62499e20ac /devel/spin
parentf3150594a242e431214baf9dcfe9a70f903d6ab7 (diff)
downloadports-3a1bc7d42491b753157b464e9a4e7133451cb5fa.tar.gz
ports-3a1bc7d42491b753157b464e9a4e7133451cb5fa.zip
Notes
Diffstat (limited to 'devel/spin')
-rw-r--r--devel/spin/Makefile30
-rw-r--r--devel/spin/distinfo4
-rw-r--r--devel/spin/files/patch-makefile14
-rw-r--r--devel/spin/files/patch-xspin4
4 files changed, 20 insertions, 32 deletions
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index b9aaac7142df..437908b4261a 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= spin
-PORTVERSION= 4.2.2
+PORTVERSION= 4.2.4
CATEGORIES= devel
MASTER_SITES= http://spinroot.com/spin/Src/
DISTNAME= spin${PORTVERSION:S/.//g}
@@ -14,9 +14,14 @@ DISTNAME= spin${PORTVERSION:S/.//g}
MAINTAINER= jhanna@shaw.ca
COMMENT= An on-the-fly verification system for asynchronous concurrent systems
+OPTIONS= XSPIN "Install xspin and TCL/Tk dependency" on
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_XSPIN)
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
PLIST_SUB+= XSPIN=""
+XSPIN_TCL = ${WRKDIR}/Xspin4.2/xspin423.tcl
.else
PLIST_SUB+= XSPIN="@comment "
.endif
@@ -25,37 +30,34 @@ DIST_SUBDIR= spin
WRKSRC= ${WRKDIR}/Src${PORTVERSION}
MAKEFILE= makefile
ALL_TARGET= spin
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DNXT"
USE_REINPLACE= yes
MANPAGE_WRKSRC= ${WRKDIR}/Man
MAN1= spin.1
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Use WITHOUT_XSPIN=yes to suppress xspin (and TCL/Tk dependency)."
- @${ECHO_MSG} ""
-
post-extract:
@cd ${WRKDIR}/Test && ${SH} ${WRKDIR}/Test/examples
+.if !defined(WITHOUT_XSPIN)
pre-patch:
- ${TR} -d '\015' < ${WRKDIR}/Xspin4.2/xspin422.tcl \
- > ${WRKDIR}/Xspin4.2/xspin422.tcl.tmp
- ${MV} -f ${WRKDIR}/Xspin4.2/xspin422.tcl.tmp \
- ${WRKDIR}/Xspin4.2/xspin422.tcl
+ ${TR} -d '\015' < ${XSPIN_TCL} > ${XSPIN_TCL}.tmp
+ ${MV} -f ${XSPIN_TCL}.tmp ${XSPIN_TCL}
+.endif
+.if !defined(WITHOUT_XSPIN)
post-patch:
@WISH=`(cd ${LOCALBASE}/bin ; ${LS} wish8* ) | tail -1` ; \
if [ -z "$$WISH" ] ; then WISH=wish8.0 ; fi ; \
${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g;" \
- -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin4.2/xspin422.tcl
+ -e "s|%%WISH%%|$$WISH|g" ${XSPIN_TCL}
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spin ${PREFIX}/bin
.if !defined(WITHOUT_XSPIN)
- ${RM} -f ${PREFIX}/bin/xspin
- ${INSTALL_SCRIPT} ${WRKDIR}/Xspin4.2/xspin422.tcl ${PREFIX}/bin/xspin
+ ${INSTALL_SCRIPT} ${XSPIN_TCL} ${PREFIX}/bin/xspin
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/Doc
@@ -71,4 +73,4 @@ do-install:
${INSTALL_MAN} ${WRKDIR}/Man/spin.1 ${PREFIX}/man/man1
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/spin/distinfo b/devel/spin/distinfo
index 5f794f3000c9..8a32f85cb531 100644
--- a/devel/spin/distinfo
+++ b/devel/spin/distinfo
@@ -1,2 +1,2 @@
-MD5 (spin/spin422.tar.gz) = 858e90506c2521a9714658983f22b6ef
-SIZE (spin/spin422.tar.gz) = 324452
+MD5 (spin/spin424.tar.gz) = efa453b21335ff372bca5a6ff9e9abdd
+SIZE (spin/spin424.tar.gz) = 325603
diff --git a/devel/spin/files/patch-makefile b/devel/spin/files/patch-makefile
deleted file mode 100644
index 5f42427e16b0..000000000000
--- a/devel/spin/files/patch-makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- makefile.orig Tue Jan 4 22:47:37 2005
-+++ makefile Tue Jan 4 22:48:24 2005
-@@ -10,8 +10,9 @@
- # Bug-reports: bugs@spinroot.com
-
- # CC=gcc # or any other ansi compatible c compiler
--CC=cc -DNXT # -DNXT enables the X operator in LTL
--CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
-+# CC=cc -DNXT # -DNXT enables the X operator in LTL
-+# CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
-+CFLAGS += -DNXT
-
- # on PC: add -DPC to CFLAGS above
- # on Solaris: add -DSOLARIS
diff --git a/devel/spin/files/patch-xspin b/devel/spin/files/patch-xspin
index d2be25f2ffa3..68ceb28625ae 100644
--- a/devel/spin/files/patch-xspin
+++ b/devel/spin/files/patch-xspin
@@ -1,5 +1,5 @@
---- ../Xspin4.2/xspin422.tcl.orig Mon Mar 8 11:27:07 2004
-+++ ../Xspin4.2/xspin422.tcl Mon Mar 8 11:31:09 2004
+--- ../Xspin4.2/xspin423.tcl.orig Mon Mar 8 11:27:07 2004
++++ ../Xspin4.2/xspin423.tcl Mon Mar 8 11:31:09 2004
@@ -1,6 +1,6 @@
-#!/bin/sh
+#!%%LOCALBASE%%/bin/%%WISH%% -f