aboutsummaryrefslogtreecommitdiff
path: root/devel/spin
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-23 22:34:47 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-23 22:34:47 +0000
commit842ba9821b956a52a363f97848e56a3ad6cfc006 (patch)
tree6e6bc7326629aecde3021241b912cb0f44b43fb4 /devel/spin
parent99112aca6c77751eb350ac44cdd89fc9d56df8b9 (diff)
downloadports-842ba9821b956a52a363f97848e56a3ad6cfc006.tar.gz
ports-842ba9821b956a52a363f97848e56a3ad6cfc006.zip
Notes
Diffstat (limited to 'devel/spin')
-rw-r--r--devel/spin/Makefile17
-rw-r--r--devel/spin/distinfo3
-rw-r--r--devel/spin/files/patch-make_unix2
-rw-r--r--devel/spin/files/patch-xspin15
-rw-r--r--devel/spin/pkg-plist1
5 files changed, 25 insertions, 13 deletions
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index f231a1a48b41..b230e3f04bd9 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= spin
-PORTVERSION= 4.0.7
-PORTREVISION= 1
+PORTVERSION= 4.1.2
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= http://spinroot.com/spin/Src/
-DISTFILES= spin${PORTVERSION:S/.//g}.tar.gz
+DISTNAME= spin${PORTVERSION:S/.//g}
MAINTAINER= jhanna@shaw.ca
COMMENT= An on-the-fly verification system for asynchronous concurrent systems
@@ -28,6 +28,9 @@ MAKEFILE= make_unix
ALL_TARGET= spin
USE_REINPLACE= yes
+MANPAGE_WRKSRC= ${WRKDIR}/Man
+MAN1= spin.1
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Use WITHOUT_XSPIN=yes to suppress xspin (and TCL/Tk dependency)."
@@ -41,13 +44,13 @@ post-patch:
if [ -z "$$WISH" ] ; then WISH=wish8.0 ; fi ; \
${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g;" \
- -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin4.0/xspin407.tcl
+ -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin4.1/xspin412.tcl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spin ${PREFIX}/bin
.if !defined(WITHOUT_XSPIN)
${RM} -f ${PREFIX}/bin/xspin
- ${INSTALL_SCRIPT} ${WRKDIR}/Xspin4.0/xspin407.tcl ${PREFIX}/bin/xspin
+ ${INSTALL_SCRIPT} ${WRKDIR}/Xspin4.1/xspin412.tcl ${PREFIX}/bin/xspin
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/Doc
@@ -56,9 +59,11 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/Doc/* ${DOCSDIR}/Doc
${INSTALL_DATA} ${WRKDIR}/Test/ex.* ${DOCSDIR}/Examples
.for i in README.tests abp eratosthenes hello leader leader.ltl leader2 \
- loops mobile1 mobile1.ltl mobile2 mobile2.ltl pathfinder peterson petersonN pftp priorities snoopy sort wordcount
+ leader_trace loops mobile1 mobile1.ltl mobile2 mobile2.ltl \
+ pathfinder peterson petersonN pftp priorities snoopy sort wordcount
${INSTALL_DATA} ${WRKDIR}/Test/$i ${DOCSDIR}/Test
.endfor
+ ${INSTALL_MAN} ${WRKDIR}/Man/spin.1 ${PREFIX}/man/man1
.endif
.include <bsd.port.mk>
diff --git a/devel/spin/distinfo b/devel/spin/distinfo
index c9bfe4a0cfe4..8820ef990d7e 100644
--- a/devel/spin/distinfo
+++ b/devel/spin/distinfo
@@ -1 +1,2 @@
-MD5 (spin/spin407.tar.gz) = dfb9886dae7985bf08a1a345564581ed
+MD5 (spin/spin412.tar.gz) = 6cbc680c4e441611e31b052201f13848
+SIZE (spin/spin412.tar.gz) = 321465
diff --git a/devel/spin/files/patch-make_unix b/devel/spin/files/patch-make_unix
index 4345af58a4cc..e1deddbdf8bd 100644
--- a/devel/spin/files/patch-make_unix
+++ b/devel/spin/files/patch-make_unix
@@ -1,6 +1,6 @@
--- make_unix.orig Mon Apr 7 20:30:46 2003
+++ make_unix Mon Apr 7 20:31:36 2003
-@@ -12,8 +12,9 @@
+@@ -9,8 +9,9 @@
# [a more up-to-date book documenting Spin will appear in 2003]
# CC=gcc # or any other ansi compatible c compiler
diff --git a/devel/spin/files/patch-xspin b/devel/spin/files/patch-xspin
index 7361718c3277..6167c46fb5ad 100644
--- a/devel/spin/files/patch-xspin
+++ b/devel/spin/files/patch-xspin
@@ -1,13 +1,18 @@
---- ../Xspin4.0/xspin407.tcl.orig Mon Apr 7 20:37:27 2003
-+++ ../Xspin4.0/xspin407.tcl Mon Apr 7 20:40:10 2003
-@@ -1,20 +1,4 @@
+--- ../Xspin4.1/xspin412.tcl.orig Mon Feb 23 12:57:50 2004
++++ ../Xspin4.1/xspin412.tcl Mon Feb 23 12:59:00 2004
+@@ -1,25 +1,4 @@
-#!/bin/sh
-# the next line restarts using wish \
-exec wish c:/cygwin/bin/xspin -- $*
-
+-# make sure this is where (a copy of) this script is stored
+-#
+-
+-# cd ;# enable this line to cd to you home directory by default
+-
-# on PCs:
-# adjust the first argument to wish above with the name and
--# location of this tcl/tk file on your system, if different.
+-# location of this file on your system, if different.
-#
-# Cygwin:
-# if you use cygwin, do not refer to the file as /usr/bin/xspin
@@ -21,4 +26,4 @@
+#!%%LOCALBASE%%/bin/%%WISH%% -f
#======================================================================#
- # Tcl/Tk Spin Controller, Gerard J. Holzmann, Bell Laboratories, USA. #
+ # Tcl/Tk Spin Controller, written by Gerard J. Holzmann, 1995-2004. #
diff --git a/devel/spin/pkg-plist b/devel/spin/pkg-plist
index ad724d08d9fa..a5a1ef16edab 100644
--- a/devel/spin/pkg-plist
+++ b/devel/spin/pkg-plist
@@ -31,6 +31,7 @@ bin/spin
%%PORTDOCS%%%%DOCSDIR%%/Test/leader
%%PORTDOCS%%%%DOCSDIR%%/Test/leader.ltl
%%PORTDOCS%%%%DOCSDIR%%/Test/leader2
+%%PORTDOCS%%%%DOCSDIR%%/Test/leader_trace
%%PORTDOCS%%%%DOCSDIR%%/Test/loops
%%PORTDOCS%%%%DOCSDIR%%/Test/mobile1
%%PORTDOCS%%%%DOCSDIR%%/Test/mobile1.ltl