aboutsummaryrefslogtreecommitdiff
path: root/devel/stlport
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-20 16:03:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-20 16:03:49 +0000
commite8f0564a7106c48da00ef0e332f5424f4a19a1f7 (patch)
treef2c8aa0d7d1b4ee17312db7ef3acdeb715d81dc1 /devel/stlport
parente43d4c7d1342faa8b19d3f9818dd9d451fdb1b57 (diff)
Notes
Diffstat (limited to 'devel/stlport')
-rw-r--r--devel/stlport/Makefile15
-rw-r--r--devel/stlport/distinfo4
-rw-r--r--devel/stlport/files/patch-src::common_macros.mak4
-rw-r--r--devel/stlport/files/patch-src::gcc-freebsd.mak12
-rw-r--r--devel/stlport/files/patch-stlport::_cmath.h11
-rw-r--r--devel/stlport/files/patch-stlport::c_locale.h4
-rw-r--r--devel/stlport/files/patch-stlport::config::stl_gcc.h61
-rw-r--r--devel/stlport/files/patch-stlport::stdexcept10
-rw-r--r--devel/stlport/files/patch-stlport::stl::_bvector.h4
-rw-r--r--devel/stlport/files/patch-stlport::stl::_cwchar.h11
-rw-r--r--devel/stlport/files/patch-stlport::stlcomp.h14
-rw-r--r--devel/stlport/files/patch-test::eh::gcc-freebsd.mak6
-rw-r--r--devel/stlport/pkg-plist12
13 files changed, 88 insertions, 80 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index 66d007f034c0..91637ce05683 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= stlport
-PORTVERSION= 4.5.3
-PORTREVISION?= 2
+PORTVERSION= 4.6.2
+PORTREVISION?= 0
CATEGORIES= devel
MASTER_SITES= http://www.stlport.com/archive/
PKGNAMESUFFIX= -${COMPILER}
@@ -40,10 +40,6 @@ PLIST_SUB+= COMPILER=${COMPILER}
INSTALL_TARGET= install_unix
INSTALLS_SHLIB= yes
-.if ${OSVERSION} >= 502126 && ${COMPILER}!="icc"
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.if ${OSVERSION} < 440000
BROKEN= "Not supported on systems prior to FreeBSD 4.4"
.endif
@@ -65,6 +61,13 @@ pre-everything::
@${ECHO_MSG} "There may be a bug in your version of gcc's exception"
@${ECHO_MSG} "handling code. Consider upgrading to FreeBSD 4.6"
@${ECHO_MSG} "or above."
+.elif ${COMPILER} == gcc && ${OSVERSION} >= 502126
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you have encounted a compiler internal error"
+ @${ECHO_MSG} "during building, do NOT 'make clean', simply continue"
+ @${ECHO_MSG} "building by type 'make ${.TARGET}' again."
+ @${ECHO_MSG}
.endif
post-patch:
diff --git a/devel/stlport/distinfo b/devel/stlport/distinfo
index 7f164860ce70..76566eabea7a 100644
--- a/devel/stlport/distinfo
+++ b/devel/stlport/distinfo
@@ -1,2 +1,2 @@
-MD5 (STLport-4.5.3.tar.gz) = cd4dd34b623a8704fbc800de79705171
-SIZE (STLport-4.5.3.tar.gz) = 739943
+MD5 (STLport-4.6.2.tar.gz) = 4c01c84f1212369ceb369567ed06d1a2
+SIZE (STLport-4.6.2.tar.gz) = 755958
diff --git a/devel/stlport/files/patch-src::common_macros.mak b/devel/stlport/files/patch-src::common_macros.mak
index 33f1f72eb2e7..134c3f755142 100644
--- a/devel/stlport/files/patch-src::common_macros.mak
+++ b/devel/stlport/files/patch-src::common_macros.mak
@@ -1,5 +1,5 @@
---- src/common_macros.mak.orig Thu Nov 15 17:08:56 2001
-+++ src/common_macros.mak Mon Dec 24 10:37:02 2001
+--- src/common_macros.mak.orig Sun Nov 2 16:58:51 2003
++++ src/common_macros.mak Sun Oct 31 17:02:57 2004
@@ -10,7 +10,7 @@
# We do not assume any binary compatibility for betas.
BETA_SUFFIX=
diff --git a/devel/stlport/files/patch-src::gcc-freebsd.mak b/devel/stlport/files/patch-src::gcc-freebsd.mak
index d55cc5682a96..41d05462f9a1 100644
--- a/devel/stlport/files/patch-src::gcc-freebsd.mak
+++ b/devel/stlport/files/patch-src::gcc-freebsd.mak
@@ -1,13 +1,13 @@
---- src/gcc-freebsd.mak.orig Tue Nov 27 02:17:56 2001
-+++ src/gcc-freebsd.mak Tue Jun 25 07:30:55 2002
+--- src/gcc-freebsd.mak.orig Fri Jan 16 08:25:37 2004
++++ src/gcc-freebsd.mak Sat Nov 6 15:40:14 2004
@@ -5,8 +5,8 @@
#
# compiler
#
-CC = gcc -pthread
-CXX = c++ -pthread -fexceptions
-+CC+= $(PTHREAD_CFLAGS) -D_REENTRANT
-+CXX+= $(PTHREAD_CFLAGS) -D_REENTRANT -fexceptions
++CC += $(PTHREAD_CFLAGS) -D_REENTRANT
++CXX += $(PTHREAD_CFLAGS) -D_REENTRANT -fexceptions
#
# Basename for libraries
@@ -16,13 +16,13 @@
LINK=ar cr
# 2.95 flag
-DYN_LINK=c++ -pthread -fexceptions -shared -o
-+DYN_LINK=$(CXX) $(PTHREAD_LIBS) -shared -o
++DYN_LINK=$(CXX) $(PTHREAD_LIBS) -fexceptions -shared -o
OBJEXT=o
DYNEXT=so
@@ -41,8 +41,8 @@
- CXXFLAGS_COMMON = -I$(STLPORT_DIR) $(WARNING_FLAGS)
+ CXXFLAGS_COMMON = -I${STLPORT_DIR} ${WARNING_FLAGS}
-CXXFLAGS_RELEASE_static = $(CXXFLAGS_COMMON) -O2
-CXXFLAGS_RELEASE_dynamic = $(CXXFLAGS_COMMON) -O2 -fPIC
diff --git a/devel/stlport/files/patch-stlport::_cmath.h b/devel/stlport/files/patch-stlport::_cmath.h
deleted file mode 100644
index 28a209d5ead7..000000000000
--- a/devel/stlport/files/patch-stlport::_cmath.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- stlport/stl/_cmath.h.orig Wed Jul 24 03:31:26 2002
-+++ stlport/stl/_cmath.h Wed Jul 24 03:32:38 2002
-@@ -100,7 +100,7 @@
- # define _STLP_DO_TAN(_Tp) _STLP_VENDOR_CSTD::tan
- # define _STLP_DO_TANH(_Tp) _STLP_VENDOR_CSTD::tanh
- # define _STLP_DO_EXP(_Tp) _STLP_VENDOR_CSTD::exp
--# if defined (__GNUC__) || defined ( __IBMCPP__ ) || defined (__SUNPRO_CC)
-+# if defined (__GNUC__) || defined ( __IBMCPP__ ) || defined (__SUNPRO_CC) || defined (__ICC)
- # define _STLP_DO_HYPOT(_Tp) ::hypot
- # else
- # define _STLP_DO_HYPOT(_Tp) _STLP_VENDOR_CSTD::hypot
diff --git a/devel/stlport/files/patch-stlport::c_locale.h b/devel/stlport/files/patch-stlport::c_locale.h
index 7caa6c41eaa5..55cad18d5560 100644
--- a/devel/stlport/files/patch-stlport::c_locale.h
+++ b/devel/stlport/files/patch-stlport::c_locale.h
@@ -1,5 +1,5 @@
---- stlport/stl/c_locale.h.orig Wed Jul 24 03:17:57 2002
-+++ stlport/stl/c_locale.h Wed Jul 24 03:19:25 2002
+--- stlport/stl/c_locale.h.orig Sun Nov 2 16:59:03 2003
++++ stlport/stl/c_locale.h Sat Nov 6 15:44:22 2004
@@ -178,7 +178,7 @@
_Locale_SPACE ) /* Printable */
# endif /* __Lynx__ */
diff --git a/devel/stlport/files/patch-stlport::config::stl_gcc.h b/devel/stlport/files/patch-stlport::config::stl_gcc.h
index 15f2b6db3eb5..ebf04c8fda57 100644
--- a/devel/stlport/files/patch-stlport::config::stl_gcc.h
+++ b/devel/stlport/files/patch-stlport::config::stl_gcc.h
@@ -1,45 +1,44 @@
---- stlport/config/stl_gcc.h.orig Thu Jan 10 19:41:58 2002
-+++ stlport/config/stl_gcc.h Thu Jun 6 23:15:40 2002
-@@ -9,8 +9,14 @@
+--- stlport/config/stl_gcc.h.orig Sun Nov 2 16:59:11 2003
++++ stlport/config/stl_gcc.h Mon Nov 8 19:15:42 2004
+@@ -7,11 +7,21 @@
+ # define _STLP_USE_GLIBC
+ #endif
++#if defined(__FreeBSD__) && (__FreeBSD_cc_version >= 530001)
++# define _STLP_DONT_USE_NESTED_TCLASS_THROUGHT_TPARAM 1
++#endif
++
# define _STLP_NO_MEMBER_TEMPLATE_KEYWORD
--# if defined(__FreeBSD__) || defined (__hpux) || defined(__amigaos__)
-+# if defined (__hpux) || defined(__amigaos__)
- # define _STLP_NO_WCHAR_T
-+# elif defined(__FreeBSD__)
-+# if (__FreeBSD_cc_version < 500005)
+-# if defined(__FreeBSD__) || defined (__hpux) || defined(__amigaos__) || ( defined(__OS2__) && defined(__EMX__) )
++#if defined (__hpux) || defined(__amigaos__) || ( defined(__OS2__) && defined(__EMX__) )
+# define _STLP_NO_WCHAR_T
++#elif defined(__FreeBSD__)
++# if (__FreeBSD_cc_version < 500005)
+ # define _STLP_NO_WCHAR_T
+-# endif
+# else
-+# define _STLP_FREEBSD_HAS_WFUNCS
++# define _STLP_FREEBSD_HAS_WFUNCS
+# endif /* __FreeBSD_cc_version < 500005 */
- # endif
++#endif
- # if defined (__sun)
-@@ -77,7 +83,7 @@
+ #ifdef __USLC__
+ # include <config/stl_sco.h>
+@@ -81,7 +91,7 @@
# endif
-#if defined (__CYGWIN__) || defined (__MINGW32__) || !(defined (_STLP_USE_GLIBC) || defined (__sun))
-+#if defined (__CYGWIN__) || defined (__MINGW32__) || !(defined (_STLP_USE_GLIBC) || defined (_STLP_FREEBSD_HAS_WFUNCS) || defined (__sun))
++#if defined (__CYGWIN__) || defined (__MINGW32__) || !(defined (_STLP_USE_GLIBC) || defined (_STLP_FREEBSD_HAS_WFUNCS) || defined (__sun))
#ifndef __MINGW32__
# define _STLP_NO_NATIVE_MBSTATE_T 1
#endif
-@@ -250,8 +256,17 @@
-
- # if (__GNUC__ >= 3)
-
-+#ifdef __FreeBSD__
-+# if (__FreeBSD_cc_version > 500005)
-+# define _STLP_NATIVE_INCLUDE_PATH ../__GNUC__.__GNUC_MINOR__
-+# else
-+# define _STLP_NATIVE_INCLUDE_PATH ../g++
-+# define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../g++/backward
-+# endif
-+#else
- # define _STLP_NATIVE_INCLUDE_PATH ../g++-v3
- # define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../g++-v3/backward
-+#endif
-
- # elif (__GNUC_MINOR__ < 8)
-
+@@ -267,7 +277,7 @@
+ # define _STLP_NATIVE_INCLUDE_PATH ../g++-v3
+ # define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../g++-v3/backward
+ # else
+-# if defined(__GNUC_PATCHLEVEL__) && (__GNUC_PATCHLEVEL__ > 0)
++# if defined(__GNUC_PATCHLEVEL__) && (__GNUC_PATCHLEVEL__ > 0) && !defined(__FreeBSD__)
+ # define _STLP_NATIVE_INCLUDE_PATH ../__GNUC__.__GNUC_MINOR__.__GNUC_PATCHLEVEL__
+ # define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../__GNUC__.__GNUC_MINOR__.__GNUC_PATCHLEVEL__/backward
+ # else
diff --git a/devel/stlport/files/patch-stlport::stdexcept b/devel/stlport/files/patch-stlport::stdexcept
index f4c963770380..41d193eca8b6 100644
--- a/devel/stlport/files/patch-stlport::stdexcept
+++ b/devel/stlport/files/patch-stlport::stdexcept
@@ -1,8 +1,8 @@
---- stlport/stdexcept.orig Thu Jun 6 23:31:29 2002
-+++ stlport/stdexcept Thu Jun 6 23:31:57 2002
-@@ -49,6 +49,11 @@
-
- _STLP_BEGIN_NAMESPACE
+--- stlport/stdexcept.orig Sun Nov 2 16:59:01 2003
++++ stlport/stdexcept Sun Oct 31 17:05:34 2004
+@@ -60,6 +60,11 @@
+ # endif
+ # define _STLP_EXCEPTION_BASE exception
+/* maybe limit to gcc 3.x */
+#if defined( __GNUC__)
diff --git a/devel/stlport/files/patch-stlport::stl::_bvector.h b/devel/stlport/files/patch-stlport::stl::_bvector.h
index 7fa2212e8298..d58eacd555a0 100644
--- a/devel/stlport/files/patch-stlport::stl::_bvector.h
+++ b/devel/stlport/files/patch-stlport::stl::_bvector.h
@@ -1,5 +1,5 @@
---- stlport/stl/_bvector.h.orig Fri Oct 3 23:22:06 2003
-+++ stlport/stl/_bvector.h Fri Oct 3 23:22:38 2003
+--- stlport/stl/_bvector.h.orig Sun Nov 2 16:59:07 2003
++++ stlport/stl/_bvector.h Sun Oct 31 16:48:31 2004
@@ -34,7 +34,9 @@
# include <stl/_vector.h>
# endif
diff --git a/devel/stlport/files/patch-stlport::stl::_cwchar.h b/devel/stlport/files/patch-stlport::stl::_cwchar.h
new file mode 100644
index 000000000000..ac88a5961d0f
--- /dev/null
+++ b/devel/stlport/files/patch-stlport::stl::_cwchar.h
@@ -0,0 +1,11 @@
+--- stlport/stl/_cwchar.h.orig Sun Nov 2 16:59:08 2003
++++ stlport/stl/_cwchar.h Sat Nov 6 17:01:49 2004
+@@ -24,7 +24,7 @@
+ #endif
+ #endif
+
+-# if defined (__MRC__) || defined (__SC__) || defined (__BORLANDC__) || defined(__FreeBSD__) || (defined (__GNUC__) && defined (__APPLE__) || defined( __Lynx__ )) || defined (_STLP_NO_WCHAR_T)
++# if defined (__MRC__) || defined (__SC__) || defined (__BORLANDC__) || (defined(__FreeBSD__) && !defined(_STLP_FREEBSD_HAS_WFUNCS)) || (defined (__GNUC__) && defined (__APPLE__) || defined( __Lynx__ )) || defined (_STLP_NO_WCHAR_T)
+
+ # include _STLP_NATIVE_C_HEADER(stddef.h)
+ # if defined (__FreeBSD__) || defined (__Lynx__)
diff --git a/devel/stlport/files/patch-stlport::stlcomp.h b/devel/stlport/files/patch-stlport::stlcomp.h
index 14b6a3cd1855..1c2e582338bd 100644
--- a/devel/stlport/files/patch-stlport::stlcomp.h
+++ b/devel/stlport/files/patch-stlport::stlcomp.h
@@ -1,12 +1,12 @@
---- stlport/config/stlcomp.h.orig Wed Jul 24 02:21:28 2002
-+++ stlport/config/stlcomp.h Wed Jul 24 02:21:16 2002
-@@ -103,6 +103,9 @@
+--- stlport/config/stlcomp.h.orig Sun Nov 2 16:59:12 2003
++++ stlport/config/stlcomp.h Sat Nov 6 16:13:47 2004
+@@ -109,6 +109,9 @@
# elif defined (__FCC_VERSION)
/* Fujutsu Compiler, v4.0 assumed */
# include <config/stl_fujitsu.h>
-+/* Intel(R) C++ Compiler */
+# elif defined (__ICC)
++/* Intel(R) C++ Compiler */
+# include <config/stl_icc.h>
- # else
- /* Unable to identify the compiler, issue error diagnostic.
- * Edit <config/stl_mycomp.h> to set STLport up for your compiler. */
+ # elif defined(_CRAY)
+ /* Cray C++ 3.4 or 3.5 */
+ # include <config/stl_cray.h>
diff --git a/devel/stlport/files/patch-test::eh::gcc-freebsd.mak b/devel/stlport/files/patch-test::eh::gcc-freebsd.mak
index ca089998af55..d456c25abcd2 100644
--- a/devel/stlport/files/patch-test::eh::gcc-freebsd.mak
+++ b/devel/stlport/files/patch-test::eh::gcc-freebsd.mak
@@ -1,5 +1,5 @@
---- test/eh/gcc-freebsd.mak.orig Sat May 26 05:06:16 2001
-+++ test/eh/gcc-freebsd.mak Fri Jun 7 11:25:25 2002
+--- test/eh/gcc-freebsd.mak.orig Sun Nov 2 16:58:53 2003
++++ test/eh/gcc-freebsd.mak Sat Nov 6 16:19:16 2004
@@ -34,20 +34,17 @@
D_TEST = ./eh_test_d.out
NOSGI_TEST = ./eh_test_nosgi.out
@@ -11,7 +11,7 @@
# also, test_slist won't compile with -O3/-O2 when targeting PPC. It fails
# in the assembler with 'invalid relocation type'
-CXXFLAGS = -Wall -g -O ${STL_INCL} -I. ${CXX_EXTRA_FLAGS} -DEH_VECTOR_OPERATOR_NEW
-+CXXFLAGS += $(PTHREAD_CFLAGS) -D_REENTRANT -fexceptions -Wall $(STL_INCL) -I. $(CXX_EXTRA_FLAGS) -DEH_VECTOR_OPERATOR_NEW -DEH_DELETE_HAS_THROW_SPEC
++CXXFLAGS = $(PTHREAD_CFLAGS) -D_REENTRANT -fexceptions -Wall ${STL_INCL} -I. ${CXX_EXTRA_FLAGS} -DEH_VECTOR_OPERATOR_NEW -DEH_DELETE_HAS_THROW_SPEC
-D_CXXFLAGS = -Wall -g -O ${STL_INCL} -I. ${CXX_EXTRA_FLAGS} -DEH_VECTOR_OPERATOR_NEW -D_STLP_DEBUG -D_STLP_USE_STATIC_LIB
-NOSGI_CXXFLAGS = -Wall -g -O2 ${STL_INCL} -I. ${CXX_EXTRA_FLAGS} -D_STLP_NO_OWN_IOSTREAMS -D_STLP_DEBUG_UNINITIALIZED -DEH_VECTOR_OPERATOR_NEW
diff --git a/devel/stlport/pkg-plist b/devel/stlport/pkg-plist
index 843eb386a562..f58cfa0bf825 100644
--- a/devel/stlport/pkg-plist
+++ b/devel/stlport/pkg-plist
@@ -17,8 +17,10 @@ include/stlport/config/stl_as400.h
include/stlport/config/stl_bc.h
include/stlport/config/stl_como.h
include/stlport/config/stl_confix.h
+include/stlport/config/stl_cray.h
include/stlport/config/stl_dec.h
include/stlport/config/stl_dec_vms.h
+include/stlport/config/stl_dm.h
include/stlport/config/stl_fujitsu.h
include/stlport/config/stl_gcc.h
include/stlport/config/stl_hpacc.h
@@ -159,6 +161,7 @@ include/stlport/stl/_exception.h
include/stlport/stl/_fstream.c
include/stlport/stl/_fstream.h
include/stlport/stl/_function.h
+include/stlport/stl/_function_adaptors.h
include/stlport/stl/_function_base.h
include/stlport/stl/_hash_fun.h
include/stlport/stl/_hash_map.h
@@ -186,6 +189,7 @@ include/stlport/stl/_map.h
include/stlport/stl/_messages_facets.h
include/stlport/stl/_monetary.c
include/stlport/stl/_monetary.h
+include/stlport/stl/_new.h
include/stlport/stl/_null_stream.h
include/stlport/stl/_num_get.c
include/stlport/stl/_num_get.h
@@ -207,11 +211,11 @@ include/stlport/stl/_range_errors.h
include/stlport/stl/_raw_storage_iter.h
include/stlport/stl/_relops.h
include/stlport/stl/_relops_cont.h
+include/stlport/stl/_relops_hash_cont.h
include/stlport/stl/_relops_template.h
include/stlport/stl/_rope.c
include/stlport/stl/_rope.h
include/stlport/stl/_set.h
-include/stlport/stl/_set_operators.h
include/stlport/stl/_site_config.h
include/stlport/stl/_slist.c
include/stlport/stl/_slist.h
@@ -256,6 +260,8 @@ include/stlport/stl/debug/_deque.h
include/stlport/stl/debug/_hashtable.h
include/stlport/stl/debug/_iterator.h
include/stlport/stl/debug/_list.h
+include/stlport/stl/debug/_relops_cont.h
+include/stlport/stl/debug/_relops_hash_cont.h
include/stlport/stl/debug/_slist.h
include/stlport/stl/debug/_string.h
include/stlport/stl/debug/_tree.h
@@ -323,10 +329,10 @@ include/stlport/wrap_std/streambuf
include/stlport/wrap_std/strstream
lib/libstlport_%%COMPILER%%.a
lib/libstlport_%%COMPILER%%.so
-lib/libstlport_%%COMPILER%%.so_4_5
+lib/libstlport_%%COMPILER%%.so_4_6
lib/libstlport_%%COMPILER%%_stldebug.a
lib/libstlport_%%COMPILER%%_stldebug.so
-lib/libstlport_%%COMPILER%%_stldebug.so_4_5
+lib/libstlport_%%COMPILER%%_stldebug.so_4_6
%%PORTDOCS%%share/doc/stlport/README.BC.html
%%PORTDOCS%%share/doc/stlport/README.CW.html
%%PORTDOCS%%share/doc/stlport/README.DEC.html