aboutsummaryrefslogtreecommitdiff
path: root/devel/stlport
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-05-17 21:09:19 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-05-17 21:09:19 +0000
commit012ab0ea4fd0d99d1c965878fa7bbf6b3f54c87e (patch)
tree9c763749f0d821b3b1ba0a9c80753e4832b685b6 /devel/stlport
parenta4fe6aee2fb5f45fc192530090b274a3d83a963e (diff)
downloadports-012ab0ea4fd0d99d1c965878fa7bbf6b3f54c87e.tar.gz
ports-012ab0ea4fd0d99d1c965878fa7bbf6b3f54c87e.zip
Notes
Diffstat (limited to 'devel/stlport')
-rw-r--r--devel/stlport/Makefile34
-rw-r--r--devel/stlport/files/patch-cwchar5
-rw-r--r--devel/stlport/files/patch-stl_gcc.h12
-rw-r--r--devel/stlport/pkg-plist401
4 files changed, 367 insertions, 85 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index b9dd24956595..6fffc4c265b5 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -9,23 +9,39 @@
PORTNAME= stlport
PORTVERSION= 4.0
CATEGORIES= devel
-MASTER_SITES= http://www.stlport.com/archive/
-DISTNAME= STLport-${PORTVERSION}
+MASTER_SITES= http://www.stlport.com/archive/ \
+ http://www.stlport.com/beta/
+DISTNAME= STLport-${PORTVERSION:S/.b/-b/}
MAINTAINER= obrien@FreeBSD.org
-WRKSRC= ${WRKDIR}/STLport-${PORTVERSION}/src
+WRKSRC= ${WRKDIR}/STLport-${PORTVERSION:S/.b/b/}/src
MAKEFILE= gcc.mak
ALL_TARGET= clean all
USE_GMAKE= yes
-do-install:
- ${MKDIR} ${PREFIX}/include/stlport
+pre-build:
+ ${LN} -sf /usr/include/g++ ${WRKSRC}/../include
+
+post-build:
+.for lib in libstlport_gcc.so libstlport_gcc_debug.so libstlport_gcc_stldebug.so
+ ${MV} ${WRKSRC}/../lib/${lib} ${WRKSRC}/../lib/${lib}.4_0_${PORTREVISION}
+.endfor
+ -# get list from `export' files in version 4.1, rather than do this
+ cd ${WRKSRC}/../stlport ; ${RM} -rf BC50 SC5 config/new_compiler old_hp
+ find ${WRKSRC}/../stlport -name "*.orig" -delete
-.for include in *.h algorith algorithm deque functional hash_map hash_set \
-iterator list map memory numeric queue rope set slist stack utility vector \
-xmemory xutility
- ${INSTALL_DATA} ${WRKSRC}/${include} ${PREFIX}/include/stlport
+do-install:
+ cd ${WRKSRC}/.. ; pax -rw stlport ${PREFIX}/include
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/include
+ ${CHMOD} -R ${SHAREMODE} ${PREFIX}/include
+ ${CHMOD} -R ugo+X ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/../lib/* ${PREFIX}/lib
+.for lib in libstlport_gcc.so libstlport_gcc_debug.so libstlport_gcc_stldebug.so
+ cd ${PREFIX}/lib ; ${LN} -sf ${lib}.4_0_${PORTREVISION} ${lib}
.endfor
+ ${MKDIR} ${PREFIX}/share/doc/html/stlport/images
+ cd ${WRKSRC}/../doc ; ${INSTALL_MAN} *.css *.html ${PREFIX}/share/doc/html/stlport
+ cd ${WRKSRC}/../doc ; ${INSTALL_MAN} images/* ${PREFIX}/share/doc/html/stlport/images
.include <bsd.port.mk>
diff --git a/devel/stlport/files/patch-cwchar b/devel/stlport/files/patch-cwchar
new file mode 100644
index 000000000000..6ee27c9e40f9
--- /dev/null
+++ b/devel/stlport/files/patch-cwchar
@@ -0,0 +1,5 @@
+--- ../stlport/cwchar.orig Thu Jul 13 18:53:26 2000
++++ ../stlport/cwchar Wed May 16 16:05:19 2001
+@@ -37 +37 @@
+-# elif defined (__MRC__) || defined (__SC__) || defined (__BORLANDC__)
++# elif defined (__MRC__) || defined (__SC__) || defined (__BORLANDC__) || defined (__FreeBSD__)
diff --git a/devel/stlport/files/patch-stl_gcc.h b/devel/stlport/files/patch-stl_gcc.h
new file mode 100644
index 000000000000..9c39b612ae2c
--- /dev/null
+++ b/devel/stlport/files/patch-stl_gcc.h
@@ -0,0 +1,12 @@
+--- ../stlport/config/stl_gcc.h.orig Thu Jul 13 18:53:26 2000
++++ ../stlport/config/stl_gcc.h Thu May 17 00:35:52 2001
+@@ -14,7 +14,9 @@
+ # define __STL_HAS_NO_NEW_C_HEADERS 1
+
++#if 0
+ # if defined(__FreeBSD__)
+ # define __STL_NO_WCHAR_T
+ # endif
++#endif
+
+ # if defined(__MINGW32__)
diff --git a/devel/stlport/pkg-plist b/devel/stlport/pkg-plist
index 09c6b812f80f..9e219c2cf370 100644
--- a/devel/stlport/pkg-plist
+++ b/devel/stlport/pkg-plist
@@ -1,95 +1,344 @@
-include/stlport/algo.h
-include/stlport/algobase.h
-include/stlport/algorith
-include/stlport/algorith.h
+@comment $FreeBSD$
include/stlport/algorithm
-include/stlport/algorithm.h
-include/stlport/alloc.h
-include/stlport/auto_ptr.h
-include/stlport/bvector.h
-include/stlport/defalloc.h
+include/stlport/bitset
+include/stlport/cassert
+include/stlport/cctype
+include/stlport/cerrno
+include/stlport/cfloat
+include/stlport/climits
+include/stlport/clocale
+include/stlport/cmath
+include/stlport/complex
+include/stlport/config/_epilog.h
+include/stlport/config/_msvc_warnings_off.h
+include/stlport/config/_prolog.h
+include/stlport/config/stl_apcc.h
+include/stlport/config/stl_apple.bak.h
+include/stlport/config/stl_apple.h
+include/stlport/config/stl_as400.h
+include/stlport/config/stl_bc.h
+include/stlport/config/stl_como.h
+include/stlport/config/stl_confix.h
+include/stlport/config/stl_dec.h
+include/stlport/config/stl_dec_vms.h
+include/stlport/config/stl_gcc.h
+include/stlport/config/stl_hpacc.h
+include/stlport/config/stl_ibm.h
+include/stlport/config/stl_intel.h
+include/stlport/config/stl_kai.h
+include/stlport/config/stl_mlc.h
+include/stlport/config/stl_msvc.h
+include/stlport/config/stl_mwerks.h
+include/stlport/config/stl_mycomp.h
+include/stlport/config/stl_sco.h
+include/stlport/config/stl_select_lib.h
+include/stlport/config/stl_sgi.h
+include/stlport/config/stl_sunpro.h
+include/stlport/config/stl_symantec.h
+include/stlport/config/stl_watcom.h
+include/stlport/config/stl_wince.h
+include/stlport/config/stlcomp.h
+include/stlport/config/vc_select_lib.h
+include/stlport/csetjmp
+include/stlport/csignal
+include/stlport/cstdarg
+include/stlport/cstddef
+include/stlport/cstdio
+include/stlport/cstdlib
+include/stlport/cstring
+include/stlport/cstring.h
+include/stlport/ctime
+include/stlport/ctype.h
+include/stlport/cwchar
+include/stlport/cwctype
include/stlport/deque
-include/stlport/deque.h
-include/stlport/function.h
+include/stlport/exception
+include/stlport/exception.h
+include/stlport/fstream
+include/stlport/fstream.h
include/stlport/functional
include/stlport/hash_map
-include/stlport/hash_map.h
include/stlport/hash_set
-include/stlport/hash_set.h
-include/stlport/hashtable.h
-include/stlport/heap.h
+include/stlport/iomanip
+include/stlport/iomanip.h
+include/stlport/ios
+include/stlport/ios.h
+include/stlport/iosfwd
+include/stlport/iostream
+include/stlport/iostream.h
+include/stlport/istream
+include/stlport/istream.h
include/stlport/iterator
-include/stlport/iterator.h
+include/stlport/limits
include/stlport/list
-include/stlport/list.h
+include/stlport/locale
+include/stlport/locale.h
include/stlport/map
-include/stlport/map.h
+include/stlport/math.h
+include/stlport/mem.h
include/stlport/memory
+include/stlport/memory.new
include/stlport/mmemory.h
-include/stlport/msl_algobase.h
-include/stlport/msl_iterator.h
-include/stlport/multimap.h
-include/stlport/multiset.h
+include/stlport/new
+include/stlport/new.h
include/stlport/numeric
-include/stlport/numeric.h
-include/stlport/pair.h
-include/stlport/ph_iterator.h
-include/stlport/pthread_alloc.h
+include/stlport/ostream
+include/stlport/ostream.h
+include/stlport/pthread_alloc
include/stlport/queue
-include/stlport/queue.h
include/stlport/rope
-include/stlport/rope.h
-include/stlport/ropeimpl.h
include/stlport/set
-include/stlport/set.h
+include/stlport/setjmp.h
+include/stlport/signal.h
include/stlport/slist
-include/stlport/slist.h
+include/stlport/sstream
include/stlport/stack
-include/stlport/stack.h
-include/stlport/stl_algo.h
-include/stlport/stl_algobase.h
-include/stlport/stl_alloc.h
-include/stlport/stl_bvector.h
-include/stlport/stl_config.h
-include/stlport/stl_construct.h
-include/stlport/stl_deque.h
-include/stlport/stl_function.h
-include/stlport/stl_hash_fun.h
-include/stlport/stl_hash_map.h
-include/stlport/stl_hash_set.h
-include/stlport/stl_hashtable.h
-include/stlport/stl_heap.h
-include/stlport/stl_iterator.h
-include/stlport/stl_list.h
-include/stlport/stl_lock.h
-include/stlport/stl_map.h
-include/stlport/stl_multimap.h
-include/stlport/stl_multiset.h
-include/stlport/stl_numeric.h
-include/stlport/stl_pair.h
-include/stlport/stl_pthread_alloc.h
-include/stlport/stl_queue.h
-include/stlport/stl_raw_storage_iter.h
-include/stlport/stl_relops.h
-include/stlport/stl_rope.h
-include/stlport/stl_set.h
-include/stlport/stl_slist.h
-include/stlport/stl_stack.h
-include/stlport/stl_tempbuf.h
-include/stlport/stl_tree.h
-include/stlport/stl_uninitialized.h
-include/stlport/stl_vector.h
-include/stlport/stlcomp.h
-include/stlport/stlconf.h
-include/stlport/stldebug.h
-include/stlport/tempbuf.h
-include/stlport/tree.h
-include/stlport/type_traits.h
+include/stlport/stdarg.h
+include/stlport/stddef.h
+include/stlport/stdexcept
+include/stlport/stdio.h
+include/stlport/stdlib.h
+include/stlport/stl/_algo.c
+include/stlport/stl/_algo.h
+include/stlport/stl/_algobase.c
+include/stlport/stl/_algobase.h
+include/stlport/stl/_alloc.c
+include/stlport/stl/_alloc.h
+include/stlport/stl/_bitset.c
+include/stlport/stl/_bitset.h
+include/stlport/stl/_bvector.h
+include/stlport/stl/_check_config.h
+include/stlport/stl/_codecvt.h
+include/stlport/stl/_collate.h
+include/stlport/stl/_complex.c
+include/stlport/stl/_complex.h
+include/stlport/stl/_config.h
+include/stlport/stl/_construct.h
+include/stlport/stl/_ctraits_fns.h
+include/stlport/stl/_ctype.h
+include/stlport/stl/_deque.c
+include/stlport/stl/_deque.h
+include/stlport/stl/_epilog.h
+include/stlport/stl/_exception.h
+include/stlport/stl/_fstream.c
+include/stlport/stl/_fstream.h
+include/stlport/stl/_function.h
+include/stlport/stl/_hash_fun.h
+include/stlport/stl/_hash_map.h
+include/stlport/stl/_hash_set.h
+include/stlport/stl/_hashtable.c
+include/stlport/stl/_hashtable.h
+include/stlport/stl/_heap.c
+include/stlport/stl/_heap.h
+include/stlport/stl/_ios.c
+include/stlport/stl/_ios.h
+include/stlport/stl/_ios_base.h
+include/stlport/stl/_iosfwd.h
+include/stlport/stl/_istream.c
+include/stlport/stl/_istream.h
+include/stlport/stl/_iterator.h
+include/stlport/stl/_iterator_base.h
+include/stlport/stl/_limits.c
+include/stlport/stl/_limits.h
+include/stlport/stl/_list.c
+include/stlport/stl/_list.h
+include/stlport/stl/_locale.c
+include/stlport/stl/_locale.h
+include/stlport/stl/_map.h
+include/stlport/stl/_messages_facets.h
+include/stlport/stl/_monetary.c
+include/stlport/stl/_monetary.h
+include/stlport/stl/_null_stream.h
+include/stlport/stl/_numeric.c
+include/stlport/stl/_numeric.h
+include/stlport/stl/_numeric_facets.c
+include/stlport/stl/_numeric_facets.h
+include/stlport/stl/_ostream.c
+include/stlport/stl/_ostream.h
+include/stlport/stl/_pair.h
+include/stlport/stl/_prolog.h
+include/stlport/stl/_ptrs_specialize.h
+include/stlport/stl/_queue.h
+include/stlport/stl/_range_errors.h
+include/stlport/stl/_raw_storage_iter.h
+include/stlport/stl/_relops.h
+include/stlport/stl/_relops_cont.h
+include/stlport/stl/_relops_template.h
+include/stlport/stl/_rope.c
+include/stlport/stl/_rope.h
+include/stlport/stl/_set.h
+include/stlport/stl/_set_operators.h
+include/stlport/stl/_site_config.h
+include/stlport/stl/_slist.c
+include/stlport/stl/_slist.h
+include/stlport/stl/_slist_base.c
+include/stlport/stl/_slist_base.h
+include/stlport/stl/_sstream.c
+include/stlport/stl/_sstream.h
+include/stlport/stl/_stack.h
+include/stlport/stl/_stdio_file.h
+include/stlport/stl/_stream_iterator.h
+include/stlport/stl/_streambuf.c
+include/stlport/stl/_streambuf.h
+include/stlport/stl/_string.c
+include/stlport/stl/_string.h
+include/stlport/stl/_string_fwd.c
+include/stlport/stl/_string_fwd.h
+include/stlport/stl/_string_hash.h
+include/stlport/stl/_string_io.c
+include/stlport/stl/_string_io.h
+include/stlport/stl/_strstream.h
+include/stlport/stl/_tempbuf.c
+include/stlport/stl/_tempbuf.h
+include/stlport/stl/_threads.c
+include/stlport/stl/_threads.h
+include/stlport/stl/_time_facets.c
+include/stlport/stl/_time_facets.h
+include/stlport/stl/_tree.c
+include/stlport/stl/_tree.h
+include/stlport/stl/_uninitialized.h
+include/stlport/stl/_valarray.c
+include/stlport/stl/_valarray.h
+include/stlport/stl/_vector.c
+include/stlport/stl/_vector.h
+include/stlport/stl/c_locale.h
+include/stlport/stl/char_traits.h
+include/stlport/stl/concept_checks.h
+include/stlport/stl/container_concepts.h
+include/stlport/stl/debug/_debug.c
+include/stlport/stl/debug/_debug.h
+include/stlport/stl/debug/_deque.h
+include/stlport/stl/debug/_hashtable.h
+include/stlport/stl/debug/_iterator.h
+include/stlport/stl/debug/_list.h
+include/stlport/stl/debug/_slist.h
+include/stlport/stl/debug/_string.h
+include/stlport/stl/debug/_tree.h
+include/stlport/stl/debug/_vector.h
+include/stlport/stl/msl_string.h
+include/stlport/stl/stdio_streambuf
+include/stlport/stl/type_traits.h
+include/stlport/stl/wrappers/_deque.h
+include/stlport/stl/wrappers/_hash_map.h
+include/stlport/stl/wrappers/_hash_set.h
+include/stlport/stl/wrappers/_list.h
+include/stlport/stl/wrappers/_map.h
+include/stlport/stl/wrappers/_mmap.h
+include/stlport/stl/wrappers/_set.h
+include/stlport/stl/wrappers/_slist.h
+include/stlport/stl/wrappers/_vector.h
+include/stlport/stl_user_config.h
+include/stlport/streambuf
+include/stlport/streambuf.h
+include/stlport/string
+include/stlport/string.h
+include/stlport/strstream
+include/stlport/strstream.h
+include/stlport/time.h
+include/stlport/typeinfo
+include/stlport/typeinfo.h
+include/stlport/using/cstring
+include/stlport/using/fstream
+include/stlport/using/h/fstream.h
+include/stlport/using/h/iomanip.h
+include/stlport/using/h/iostream.h
+include/stlport/using/h/ostream.h
+include/stlport/using/h/strstream.h
+include/stlport/using/iomanip
+include/stlport/using/ios
+include/stlport/using/iosfwd
+include/stlport/using/iostream
+include/stlport/using/istream
+include/stlport/using/locale
+include/stlport/using/ostream
+include/stlport/using/sstream
+include/stlport/using/streambuf
+include/stlport/using/strstream
include/stlport/utility
-include/stlport/utility.h
+include/stlport/valarray
include/stlport/vector
-include/stlport/vector.h
-include/stlport/xfunction.h
-include/stlport/xmemory
-include/stlport/xutility
+include/stlport/wchar.h
+include/stlport/wctype.h
+include/stlport/wrap_std/complex
+include/stlport/wrap_std/fstream
+include/stlport/wrap_std/h/fstream.h
+include/stlport/wrap_std/h/iostream.h
+include/stlport/wrap_std/h/streambuf.h
+include/stlport/wrap_std/h/strstream.h
+include/stlport/wrap_std/iomanip
+include/stlport/wrap_std/ios
+include/stlport/wrap_std/iosfwd
+include/stlport/wrap_std/iostream
+include/stlport/wrap_std/istream
+include/stlport/wrap_std/locale
+include/stlport/wrap_std/ostream
+include/stlport/wrap_std/sstream
+include/stlport/wrap_std/streambuf
+include/stlport/wrap_std/strstream
+lib/libstlport_gcc.a
+lib/libstlport_gcc.so
+lib/libstlport_gcc.so.4_0_0
+lib/libstlport_gcc_debug.a
+lib/libstlport_gcc_debug.so
+lib/libstlport_gcc_debug.so.4_0_0
+lib/libstlport_gcc_stldebug.a
+lib/libstlport_gcc_stldebug.so
+lib/libstlport_gcc_stldebug.so.4_0_0
+share/doc/html/stlport/FAQ.html
+share/doc/html/stlport/README.BC.html
+share/doc/html/stlport/README.CW.html
+share/doc/html/stlport/README.DEC.html
+share/doc/html/stlport/README.VC++.html
+share/doc/html/stlport/README.aCC.html
+share/doc/html/stlport/README.gcc.html
+share/doc/html/stlport/README.os390.html
+share/doc/html/stlport/README.pow.html
+share/doc/html/stlport/README.sgi40.html
+share/doc/html/stlport/README.sunpro.html
+share/doc/html/stlport/README.xlC.html
+share/doc/html/stlport/auto_configure.html
+share/doc/html/stlport/bug_report.html
+share/doc/html/stlport/buglist.html
+share/doc/html/stlport/build.html
+share/doc/html/stlport/build_nosgi.html
+share/doc/html/stlport/compiler_readmes.html
+share/doc/html/stlport/configure.html
+share/doc/html/stlport/contributors.html
+share/doc/html/stlport/copyrights.html
+share/doc/html/stlport/debug_mode.html
+share/doc/html/stlport/eh_testsuite.html
+share/doc/html/stlport/exception_safety.html
+share/doc/html/stlport/extensions.html
+share/doc/html/stlport/getting_started.html
+share/doc/html/stlport/images/blue.gif
+share/doc/html/stlport/images/logo.jpg
+share/doc/html/stlport/images/logo_1.jpg
+share/doc/html/stlport/index.html
+share/doc/html/stlport/install.html
+share/doc/html/stlport/license.html
+share/doc/html/stlport/major_modes.html
+share/doc/html/stlport/platforms.html
+share/doc/html/stlport/prepare.html
+share/doc/html/stlport/projects.html
+share/doc/html/stlport/release_notes.html
+share/doc/html/stlport/select_io.html
+share/doc/html/stlport/sgi_stl.html
+share/doc/html/stlport/story.html
+share/doc/html/stlport/style.css
+share/doc/html/stlport/test.html
+share/doc/html/stlport/testsuite.html
+share/doc/html/stlport/thanks.html
+share/doc/html/stlport/use_stlport.html
+share/doc/html/stlport/vendor_interface.html
+share/doc/html/stlport/wrappers.html
+@dirrm share/doc/html/stlport/images
+@dirrm share/doc/html/stlport
+@dirrm include/stlport/wrap_std/h
+@dirrm include/stlport/wrap_std
+@dirrm include/stlport/using/h
+@dirrm include/stlport/using
+@dirrm include/stlport/stl/wrappers
+@dirrm include/stlport/stl/debug
+@dirrm include/stlport/stl
+@dirrm include/stlport/config
@dirrm include/stlport